Question about Ovens

2 Answers

My Kenmore 911-4298814 oven won't hold broil or bake temp setting. The oven powers on with no error. When I press the "Bake" and dial up a temperature to (say) 350 degrees, the LCD displays the setting for 1 second then resets to 100 degrees for a few seconds then reverts to the clock display. If I dial "Broil" and select either "Hi" or "Lo" settings, the broiler seems to kick in for a second then reverts to the clock display. I have ohmed out the temperature sensor. Any ideas are welcome and would be very much appreciated!

Posted by Paul Perkins on

Ad

2 Answers

benny garcia

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

Im having the same problem did you ever find a solution? I was thinking that maybe something coul be wrong with the didplay.

Posted on Dec 06, 2011

Ad

tim goode

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

Just had similar problem with frigidaire, temp display would go blank, not even show clock, i took off back of stove, the circuit board would wiggle. when i pushed in on the circuit board it worked correctly.

Posted on Oct 30, 2011

  • Paul Perkins
    Paul Perkins Oct 30, 2011

    Thank you for your suggestion, but that doesn't work for me. I tried re-seating all of the connectors, sub-boards and ribbon connectors... removed the ERC, pulled apart all modules that could be separated, cleaned all contacts and re-inserted everything. Same problem recurs.

×

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have just moved from UK and we don't have broil and bake on our ovens - what do they mean/what's the difference as I've been cooking garlic bread on bake but it's taking twice as long to cook?


Hi,
The broil is the top element and the bake is the bottom element...so with broil you are heating from the top and with bake you are heating from the bottom...if your oven has a fan, turn that on with a bake setting and it will speed up the process..

heatman101

Apr 20, 2011 | Kenmore 40494 / 40495 / 40499 Electric...

1 Answer

Top element doesn't get red hot on bake but does on broil is my controler bad


The top element (broil element) will come on when you put it in bake only to help the oven temp get to the desired setting. If your temperature is reaching the right degrees you shouldn't have a problem.

If you need further help, I’m available over the phone at https://www.6ya.com/expert/jason_4570d45317834dd3

Nov 02, 2010 | Kenmore Ovens

1 Answer

My oven is burning my baked goods, but shows the right temp with a thermometer. Do I have to turn the dial to broil and then back to the desired temp? Even if the rack is in the middle, everything burns....


If it is convection bake you have to turn the temp down (25 degrees or so) that is listed in the recipe.

The broil setting is not used to bake because it operates differently from the bake setting. So, don't go to the broil setting at all.
The element for bake is under the floor of the oven. You have not indicated whether it is gas or electric, but both of these can have issues with the burner or element.

If you are baking on the correct setting and the oven is heating from the bottom, not the top, this can be caused by hot spots that are created by elements/burners.

to check, look under the floor of the oven. Turn the bake heat up to high and see if the flame is uneven. For an electric oven, the color of the element should be evenly red, no brown spots.

If you are using an oven thermometer, move the thermometer to the spot in the oven that seems to be burning things the most.

Nov 27, 2009 | Kenmore Ovens

1 Answer

Kenmore oven - will not heat on bake / will heat on broil


its your temp sensor. replace it and it should fix ur prob
F2=overheat
is your bottom element connected?

Mar 23, 2009 | Kenmore Ovens

1 Answer

Bake and Broil not working


After you hit the function you want...bake or broil...click the up arrow.  That should give you the default temp of 350 and the unit should light.  Now adjust to the temp you want.

Nov 28, 2008 | Ovens

1 Answer

I have to cook way longer than recipe says.


This is usually caused by a weak oven ignitor. As they age, they seem to perform less effectively. Sometimes the oven will take several minutes to ignite the first time, and even worse on subsequent ignition cycles, resulting in overall low oven temp and poor baking. Replace the oven ignitor. Note, if you have a self clean gas oven, the ignitors are usually the same part number for the bake and broil, so you can try moving the broil ignitor (which is generally used much less than the bake ignitor) to the bake burner if you want to test it out before buying a replacement ignitor.

Nov 28, 2008 | Kenmore Ovens

2 Answers

I need to disable my ovens auto shut off


The control is automatically set to turn off the oven after 12 hours baking or 3 hours broiling should you forget and leave the oven on. If you want to remvoe this feature do the following steps: 1. Press and hold, at the same time, the BAKE and BROIL buttons for 3 seconds, until the display shows "SF". 2. Press the DELAY START TIME button. The display shows "12Shdn" for 12 hour shut off. Press the DELAY START TIME button again. The display will show "no Shdn" for no shut off. 3. Press the START button.

May 21, 2007 | Kenmore 33464 / 33465 / 33469 Gas Single...

Not finding what you are looking for?
Ovens Logo

Related Topics:

197 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ovens Experts

Michael Thomas
Michael Thomas

Level 3 Expert

3053 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

Cindy Wells

Level 3 Expert

6185 Answers

Are you an Oven Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...