Question about Sony XM-1502SX Car Audio Amplifier

1 Answer

Lit up like a christmas tree

With only the power, ground and rem hooked up the Power, O.C and thermal lights are on ?????

Posted by on

  • nate Aug 05, 2008

    power is green thermal is red and over current is also red no sound ???

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If they're green, that's normal. IF they turn amber, there's a problem. The lights don't indicate whether the power supply is working or not. If you get no sound, the power supply in the amp may have failed.

Posted on Aug 02, 2008

  • Perry Babin Aug 05, 2008

    The amp seems to have a problem with the protection circuit. There's no wiring fault that would cause the thermal light to be red if the amp was cold. The amp will need to be repaired.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Their are 2 power wires,2 negative wires and 2 rem wires...how is this wired..im getting ready to get this put i


Some amps come with extra, power,rem,ground, so you can , power up another Amp Without runing to many wires. , or using a power block.like a parallel, being your 1st Amp your power block, and your remote, ground .

Apr 03, 2016 | Jensen JXA8BA2 Amplified Subwoofer, Max...

1 Answer

No output light on top of amp lit, also light by speaker output lit.


sounds like something internal as long as you have a good ground and power but remember that there is a remote power too, that is supose to hook up in the back of stereo so there are two power lines that are for the positive side of amp and one ground

Mar 24, 2011 | MTX Thunder® TC8001 Car Amp

1 Answer

What is the REM for in between the power and ground hookup for?


can you use a house subwoofer for a car cutting the power plug nd hooking the cord to pos and neg to amp

Jan 20, 2011 | Kicker 06ZX750.1 Car Audio Amplifier

2 Answers

Thermal light goes away when ground added


Doesn't sound like anything is wrong. If the thermal light is on before you have the ground hooked up then the amp is probably getting a small amount of electrical ground from the shielding on the RCAs or its mounting to the chassis of the vehicle allowing the amp to "barely turn on" (not enough ground). I can imagine this would make the amp think something is wrong (ie: thermal light) . May I suggest that you do not try to turn any amplifier on without ALL appropriate wires connected correctly.

Mar 01, 2010 | Rockford Fosgate Punch P5002 Car Audio...

1 Answer

Pyle pla2170


The power cable and the rem cable need to have different power sources. The best thing to hook the rem. to is a power antenna wire, or if you don't have a power antenna, you'd need to hook it to the ign. or accessory wire.

Jul 31, 2009 | Pyle PLA2180 Car Audio Amplifier

1 Answer

No power to amp


you need to hook up the rem wire, that runs from head unit to amp its usaully a blue wire on the head unit and there should be a rem input near where the power leads are on the amp

Mar 21, 2009 | Kicker ZX400.1 Car Audio Amplifier

2 Answers

Visonik 350watt Amp Doesnt Come On....


With your multimeter set to DC volts, the black meter probe on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red probe alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Let me know if you have any other questions.


Oct 06, 2008 | Visonik V117SX Car Audio Amplifier

1 Answer

Help me


If the wire is getting hot, the fuse in it is too large and you're in danger of burning your car to the ground.

Generally, if the amp draws excessive current only AFTER remote is applied, the output transistors have failed. If solder has melted, it may have bridged other traces and could cause more extensive damage.

Oct 28, 2007 | Autotek XS-900.2 Car Audio Amplifier

1 Answer

No power to amp


Are you sure it has the full voltage going to both BATT and REM? sounds like the REM signal is weak.

Aug 23, 2007 | Pioneer GM-7200M Car Audio Amplifier

Not finding what you are looking for?
Sony XM-1502SX Car Audio Amplifier Logo

Related Topics:

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

xxxxxx xxx

Level 3 Expert

4724 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

286 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...