Question about Yamaha 12V Air Pump

Open Question

Have a 1997 Yamaha Waverunner 760 Venture.. It does fire up and rides great but I do not have a display.....how do I go by testing it...Everyone tells me that my display is bad because of the jetski running fine....I can not find or get voltage present going to display from the harness...4 connections....1 going to speedometer / 1 going to fuel tank / 1 going to oil tank / last one going to my C.D.I. Unit....that has 4 wires (blk,red,grn,pink) and a vent tube for some reason...I thought that the vent tube was some kind of pressure switch activated by a vacuum tube ? but nothing when appling pressure in or out...what other test can I do ??????

Posted by on

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

finish line
  • 207 Answers

SOURCE: 2006 yamaha waverunner wont idle

what is it idle at? how much? remove your seat check air filter if is black oily remove it and see if that fixes your problem you may want to change your spark plugs as well # one cylinder may be starting to foul the new yamahas are the worst for fouling plugs use a cr8eb instead of the cr9eb the 8s are hotter and work better try those and let me know thank you

Posted on Jul 09, 2009

  • 1 Answer

SOURCE: excessive smoke coming from waverunner exhaust

is their a trick to putting on exhaust 1998 waverunner xl 1200?

Posted on Aug 23, 2009

PWCYoda
  • 118 Answers

SOURCE: 2004 gp1300r jetski 20 mins riding and overheating

pull out the cat temp sensor and check to see if its bent. if so then its definently your catalist, even if not bent chances are still good it has failed. you need to be sure which light is coming on. does it look like a tube with squigly lines going up?

Posted on Mar 10, 2010

  • 1 Answer

SOURCE: my '94 yamaha waverunner 3 runs great for the

Could be a bad temp sensor. The bog is a rev limiter to keep engine from running full throtle when hot or when there is another problem. You can bypass the temp sensor and see if that takes care of problem. The parts about 100.00. I disconnected mine a now run a temp gauge which I mounted on the right side just above oil gauge.

Posted on Jun 20, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have 96 760 yamaha waverunner I rebuilt the


water in your gas or air cleaner is getting wet somhow

Sep 01, 2014 | Motorcycles

1 Answer

1992 yamaha waverunner 111 wra650q Runs great until you shut it off or it shuts off? Ok as long as you restart in a few seconds it will fire instantly , if you wait 5 minutes or longer it will turn over...


Not real familiar with waverunners (this is a car and truck section after all), but remember that when you have been riding and stop engine it gets much hotter. Could possibly be coil "Heat Soak", or even a fuel system vapor lock issue caused by a pinhole leak in a line or a bad gas cap. Not very confident in this, but the best I got. Try posting in the waverunner section.

Jul 12, 2017 | Cars & Trucks

1 Answer

Yamaha waverunner forum


It's best to use a new gasket, however I have reused carb gaskets, and it worked fine. It will probably work ok if the gasket is not torn or deformed to any great degree. I smear a thin coat of Permatex non hardening sealant no.2 on both sides. If you can get new ones, that's best.

May 21, 2014 | Sport & Outdoor - Others

1 Answer

1998 Yamaha waverunner xl 760. Cranks, no spark.


are you getting power from the other end of the starter? if not then there you go.

Aug 18, 2013 | Yamaha Boating

1 Answer

1997 waverunner 760 will run fast for 50yd then die fuelline & filter full of gas


does this happen repeatedly or just sometimes? check the one way vale and the line its attached too on top of the fuel tank then make sure theres no water in the fuel filter, if there is water in the filter it should be visible and kind of look like a bottle of salad dressing or oil and vinegar before its been shaking up.

Aug 24, 2012 | Yamaha 12V Air Pump

Not finding what you are looking for?
Yamaha 12V Air Pump Logo

Related Topics:

606 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Water Sport Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Piyal Perera
Piyal Perera

Level 3 Expert

528 Answers

Are you a Yamaha Water Sport Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...