Question about 1997 Chevrolet S-10 Pickup

3 Answers

SKIPPING WHEN YOU FIRST TAKE OFF

MY 1997 CHEVY S10 SKIPPES WHEN YOU FIRST TAKE OFF. IVE CHANGED THE PLUGS ,WIRES,AND FUEL FILTER. AFTER 3000 RPMS IT STARTS TO FIRE ON ALL CYLINDERS. SHOULD I JUST SHOOT IT?????

Posted by DONALD TAPLEY on

  • martinez187 Mar 22, 2009

    I have that problem when i first try to take off it takes a moment to kick in and go. i have changed the plugs wires fuel fiter and it is still running the same it has its good days and bad days i was thinking maybe my fuel pump is going out what do you think?

  • brian18 Apr 03, 2009

    i have the same prpblem 98 chevey blazer new wires new cap rotor plugs ... when it starts acting up i can take cap off and put back on doing nothing and it then seems to run fine for a week or so any suggestions

×

Ad

3 Answers

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the CTS, Plugs, Wires, and it continue to have a slow take off and sometimes stalls, plenty of Black Smoke when accelerating or first start-up

Posted on Apr 16, 2009

Ad

Anonymous

Distribucion

Posted on Aug 26, 2008

Ad

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I too have the same problem and wondering if it is heater core related. It now has 219 miles on it and it is using alot of engine coolant which is not visibily running out. It is also not starting well on wet mornings, When first starting out after refueling it is slow but after a few seconds runs fine. Also when you attempt to pass or accelerate quickly it hesitiates. Does this sound like yours. I thought it was a a fuel pump or fuel filter but it seems this may not be the problem is you have changed yours and it still does the same thing. I think it may be heater core related. Also no heat in truck.

Posted on Sep 23, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What would cause you to lose fuel pressure while driving.


Chevrolet S-10 Questions - Fuel System Loses Pressure ...

www.cargurus.com > Questions > Chevrolet > S-10

CarGurusJul 28, 2012 - Fuel System Loses Pressure - I have a 2003 Chevy S-10 Pick Up with the 4 ... car a few times, what essentially you are doing is priming the fuel pressure. ... A dirty fuel filter will not cause the lines to lose pressure after the engine is shut off. ... I have a 98 s10 2.2 liter and it was driving fine all day then when ...

Chevrolet S-10 Questions - My 2001 S10 has a hard starting ...

www.cargurus.com > Questions > Chevrolet > S-10

CarGurusSep 16, 2012 - My 2001 S10 has a hard starting problem if the truck sits between 1 ... Vacuum leak, have you checked fuel pressure while it sits? ... Would the spider alsocause a misfire at low rpms? .... at an idle, or squeaking while driving and it gets faster as you go? ..... 1994 Chevrolet S-10 2 Dr STD Standard Cab LB.

Chevy S-10 Won't Start - Repalced Fuel Pump and Pressure ...

www.cartruckinfo.com/chevy-s10-wont-start.html
Chevrolet S-10 pickup won't run and has no fire unless I jumper the fuel pump relay. ... Once the truck starts and is running you can remove the jumper to the fuel pump ... Iwould get the fuel pressure checked to start with, because that's where the ... 93 gmc 4.3l FI runs but dies out loss of power after 5 mins of running then ...

Stalling S10: I Have a 1994 Chevy S10 2.2l It Stalls After 35 ...


Dec 10, 2015 | 1994 Chevrolet S-10

1 Answer

My 1997 chevy s10 2 wheel drive will crank but won't rev up.


motors do not rev up because they are not getting correct air/fuel for the throttle opening. So check that the accelerator position sensor is working and if you have a cable operated throttle to the body check that it is not broken. IT may be your throttle motor is not working

Mar 19, 2014 | 1997 Chevrolet S-10 Pickup

1 Answer

3.0 LITRE V-6 STARTS AND IDLES GOOD.ENGINE SURGES WHILE HOLDING THROTTLE STEADY BETWEEN 1500 AND 3000 RPMS.NEWER TIMING BELT.PLUGS ,WIRES ,CAP. NEW INJECTORS 3000 MILES AGO. FUEL PRESSURE REGULATOR,BACK...


go to villager quest yahoo group for expert help. Sounds like a dirty MAF sensor. Clean heated wires with carb cleaner.

TPS readngs are good.

fuel pressure should be 43 engine off, and 34 engine running.

try disconnecting front oxygen sensor for a day & see if better.

Read All ABut files at our site.

gerry

Aug 03, 2011 | 1997 Mercury Villager

1 Answer

92 nissan 240sx wont run after 2500- 3000 rpms changed cap and rotor new wires w/ plugs starts right after dies timing is also good


a weak coil could cause that problem
could also be an issue with the ECM / PCM
low fuel pressure caused by a weak fuel pump, clogged filter or dirty injector(s)

if you haven't tried this already then you should. get some QUALITY fuel system cleaner / injector cleaner, and follow the directions.

hope this helps.

May 24, 2011 | Nissan 240SX Cars & Trucks

1 Answer

I have2003 chevy express cargo van V8 4.7. My problem is when it's idle my cylinder 2 and 7 not working, once i give about 3000 rpm its starts working again. Check engine light is on! I changed spark...


O.k. I've been looking at this post for a while and thinking. You said the check engine light is on right? What are the codes. I'm guessing PO302 and PO307, but do you have any other ones? I'm thinking you might have leaking intake manifold gaskets.

Apr 24, 2010 | Chevrolet Express Cars & Trucks

2 Answers

2000 chevy s10 starts fine but dies out when push


Have you changed the fuel filter lately? If not do so. Sounds like fuel restriction. Filter usually on frame rail passenger side. Good luck!

Apr 13, 2010 | 2000 Chevrolet S-10

2 Answers

Need a wiring diagram for a chevy s10. brake


your power starts at the brake light fuse,check with a test light,then proceed to stop light switch on brake pedal under dash,one wire will be hot when when you check it with your test light, the other won't be until you press down the brake pedal then the power flows through to the second wire,if no power to second wire replace switch,if you have power remove tail light bulbs and check for power in side socket.

Nov 24, 2009 | 1997 Chevrolet S-10 Pickup

2 Answers

97 s10 blazer cuts out and loses power while driving.


Had the same problem with by 1998 S10 a couple years ago. Changed fuel filter?? didn't work. Changed the fuel pump?? didn't work. Changed the fuel pressure regulator?? didn't work.

I was about to the end of my rope when I put a timing light on it and it showed firing on cylinders more then once a cycle. Turns out my distributor cap was bad and spark was jumping between contacts. When a spark is spread out over more then one cylinder, it doesn't fire correctly and that is causing it to bog out. Simple and a lot cheaper then all the other fixes I tried. Crank sensor was my next option though.

Feb 01, 2009 | 1997 Chevrolet Blazer

Not finding what you are looking for?
1997 Chevrolet S-10 Pickup Logo

262 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8984 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...