Question about 2005 Suzuki Forenza

Open Question

The EMU 10amp fuse keeps blowing. - 2005 Suzuki Forenza

Posted by on

  • A Miller Oct 03, 2010

    That is because there is a short in your EMU circuit.

×

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2000 eldorado etc keeps blowing the interior lights fuse, all bulbs are fine and connectors are good, I'm stumped on how to fix it.


Check the courtesy lamps relay . The fuse that blows ,just to make sure we have the right one , INT LPS fuse 10amp ,located in the underhood fuse box.
The relay is located in the rear compartment relay center 2

Sep 18, 2017 | Cars & Trucks

1 Answer

10amp fuse keeps blowing


check for excessive amp draw on the circuit that is blowing fuse.

Jul 28, 2015 | Cars & Trucks

1 Answer

10amp meter fuse keeps blowing


SOUNDS LIKE THE MLPS ON THE SIDE FOR THE TRANS IS BAD

May 11, 2014 | 1995 Nissan Maxima

1 Answer

2002 pt cruiser fuse #11 blown


According to my diagram, number 11 is a 10amp fuse that powers the ac clutch relay. I don't see how it would keep the engine from starting.
Is the fuse you are talking about in the engine compartment box and is it a 10amp ?

Aug 06, 2012 | 2003 Chrysler PT Cruiser

1 Answer

2000 Saturn blowing pcm fuse


There are two PCM 10amp fuses that power the computer. The computer provides grounds to some 20 or 30 different circuits. Any one of those circuits could blow one or both of the 10amp fuses.
I would probably unplug the PCM and see if the fuses still blow. If not, you will need to pin test each circuit from the PCM to find the short. And you'll need a shop manual to get the wiring diagrams for those circuits.

Aug 03, 2012 | 2000 Saturn SL

1 Answer

My 1999 Monte Carlo A/C fuse keeps blowing, why?


Is the a/c clutch blowing the fuse ?
Did the fuse blow with the compressor clutch disconnected ?
You will need a wiring diagram to find out what is in that circuit.

Jul 01, 2012 | 1999 Chevrolet Monte Carlo

1 Answer

2002 kia rio keeps on blowing out 10amp fuse. when running. I think it's the 10amp computer fuse?


SOUNDS LIKE A SHORT COULD BE ANYWHER FROM ECM TO WIRING I WOULD TAKE IT TO A SHOP FOR 1-2 HR LABOR THEY CAN LOCATE THE PROBLEM ? MOST COMMON ARE WIRES RUBBED INTO IN HARNESS HIGH STRESS AREAS NEAR ENGINE, LOOK FOR WIRES TOUCHUNG OR FRAYED INSULATION ON THE WIRES GOOD LUCK

Aug 24, 2009 | 2002 Kia Rio

Not finding what you are looking for?
2005 Suzuki Forenza Logo

Related Topics:

43 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...