Question about Alpine MRA-F350 Car Audio Amplifier

2 Answers

Help with my goodmans car stereo

All of the conections are fitted correctly but there is no power coming through so it isn't working

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert that has over 500 points.


    An expert who has answered 200 questions.

  • Expert
  • 223 Answers
Re: help with my goodmans car stereo

Also try checking ALL earth connections. They sometimes work loose.

Posted on Sep 26, 2008

  • Level 1:

    An expert who has achieved level 1.


    An expert that has over 10 points.


    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 18 Answers
Re: help with my goodmans car stereo

Check Your voltage coming in AT your 12volt power wire   and them check voltage on your Power Remote wire and make sure you have both of them.....  Next Check your RCA's For signals.    IF  all that is  checked out to be good then you have a bad board in your amp.

Posted on Oct 13, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

REAR door speakers dont work in 98 gmc c1500 suburan

Hi, generally when you a buy a car, the steroe and speakers are all stock fitted, if bought second hand, they may have been upgraded.
Down to your speakers, check connectors behind the steroe unit, should be 2 plugs, one for power with red, black, yellow and blue wires, and the other plug is your speakers. Check there is 8 wires into the plug.
If all is correct then check the rear of your speakers, check the connection and that the wire isnt loose.
If all is fine there must be a wire break somewhere, your stereo presets are only set to the front speakers (fade setting).

Hope this helps

Mar 08, 2012 | Car Amplifiers

1 Answer

Install dual xd1222 into a 1993 dodge intrepid

The best way is to get a stereo installation kit designed for your car. It will have the surround for the new stereo to fit where the stock stereo fit. Also, it comes with a wiring harness that you connect the new stereo to then it plugs in to the stock radio plug. Most local automotive stereo stores should carry them.

May 12, 2010 | Car Amplifiers

1 Answer

No sound coming from sub woofers amp is connected and powered properly,all connections are correct,i have checked all connections to head unit,to battery i have disconnected and re connected all...

check your amp fuse also any car fuses, then check inside the sub box at the connections as they dont come connected when you buy it, try that 1st

Jul 11, 2009 | Car Amplifiers

2 Answers

Three blue lights blink

check you speakers and power source make sure all connection is correct

May 26, 2009 | JBL CS300.1 Subwoofer Mono Amp - 200W CS...

1 Answer

Wiring car amp up

the rem wire is for switched power from your head unit usually most after market stereos(head units) have an output for the rem wire.......if not use the power antenna wire from the back of the radio (usually blue or blue white) as for the input you need to use one or the other low or phono
Hope this helps..Good Luck!

Dec 13, 2008 | Car Amplifiers

1 Answer

Thumping speakers - no power light is on - wired correctly

the amp is going into protect mode due to something wrong in the amp or some thing in the wiring to it ooh yea if you are getting 18v power to the amp that is way to high it should not be higher then 15v if the amp is in protect mode it will not play at all.

Nov 02, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Car stereo

wich car stereo do you have?
generally you have 3 connection for power, one to the positive battery, one to the ignition and one to the ground.
by the way let me know more details for helping

Apr 26, 2008 | Car Amplifiers

1 Answer

Audiobahn A 18001DT

the remote of amp. is not a ground it is a pos.+ 12 vlts look the back of your car stereo red the remote and conect to remote of the amp. if no sign remote of the car stereo conect to the 12 vlts of your bat.

Sep 18, 2007 | MTX Thunder 8302 Car Audio Amplifier

1 Answer

Amp not working

my friend your amp could be getting power that does not mean that it is working.the power only goes to certain point but because your regulator or other related component is defected your amp power supply will not work until the defect is corrected.take it to a tech and have your set repaired.good luck.

Jun 11, 2007 | Alpine MRP-M450 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRA-F350 Car Audio Amplifier Logo

Related Topics:

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Are you an Alpine Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides