Question about 2000 Chevrolet S-10

1 Answer

2000 Chev S-10 4.3L 6 cylinder

2000 Chev S-10; when cold bogs, almost stalls and has poor gas mileage when warm.
When I unhook the mass airflow meter, just beyond the air filter, it seems to run fine but also runs fine when I just unhook the air temp. sensor. Tried electrical cleaner but no results. Any ideas??

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

Sounds like a o2 sensor run code scanner to see which on is bad

Posted on Nov 25, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I took my truck to the repair shop because it was stalling and turning off after warming up it worked for about 3 months and now I have the same problem I paid $600 dollars for the air flow meter I...


mass airflow meters should not affect idling of engine ,,, if they are faulty the power will be reduced or acceleration will be poor ,,,, it seems as if you have a idling issue or a tick over problem ,,, firstly check the throttle body for dirt and make sure there are no airleaks in that area ,,,,

Feb 11, 2012 | 1997 Nissan Pickup

1 Answer

Car does not run well with mass air flow connected , once electrical connecter remove it runs great, tryed a new mass sensor but still runs poorly . what should i look for ?


You installed a new Mass Airflow sensor and still runs poorly, then it sounds like the computer is messed up (ECU). First try to unhook the negative battery cable for a couple minutes, and plug the new airflow sensor in, reconnect battery terminal and let it run for a couple minutes with the part in. It can reset the ECU.

Dec 06, 2011 | 1993 Oldsmobile Cutlass Ciera

1 Answer

Bmw 318i e46 1999 poor engine response cold better hot but low power on take off


check gig flexi hose between air mass meter and engine, it has a tendency to split, also try disconnecting air mass meter plug, if it runs better without it mass meter may be faulty, try replacing it with a known good one

May 10, 2010 | 2000 BMW 3 Series

2 Answers

My 2000 ford expedition would run and then start to jump and then shuts off....what can be causing this...?!


sounds like a coil pack going back ....they work ok while cold but once it gets hot it stops putting spark out causing car or truck to stumble and stall and not start back up till it cools back down. Or it could be a bad fuel injector either clogged which would cause a lean cond. that would also make engine temp. higher then normal that over time will burn out a cat. converter which will choke the engine also or leaking tip which would make for poor gas mileage -rich, gas mixture and also cause a soot-black looking exhaust ,to check if cat. is back you can simply unhook exhaust before it reaches the cat and see if it will stay running then if it does then the cat is melted down -bad and need replaced if not something else like stated above is your problem.

Dec 01, 2009 | 2001 Ford Expedition

1 Answer

02 VW Jetta TDI with ALH engine glow plug


this is a common problem for these cars glow plugs go bad like spark plugs however the smoke would lead to bad mass airflow meter. it is not telling ecu corrcet miss. disconnect mass airflow meter. when cold see if this makes it start better. it should would means you need new m.a.f. glow plug issue take a test light place clamp on positive of battery then pull off glow plug connectors place tip of test light on glow plug the bad one will have a dull light unlike the good one which will be brighter. will need new plugs and wire harness four **** connectors and wire striper and crimper will fix concern good luck

Sep 01, 2009 | 2002 Volkswagen Jetta TDI

3 Answers

Poor gas mileage 2000 S10 4.3L 4WD


Thats the mass air flow meter.Should get changed at 60.000 miles. Also change the air filter.

Jun 18, 2009 | 2002 Chevrolet Blazer

1 Answer

Motor bogs down at stoplight when pushin gas pedal


The fuel pump relay will cause a stalling or no start condition. You are likely having mass airflow sensor, fuel pump, or fuel pressure regulator issues.

Bret
RepairPal.com

Nov 08, 2008 | 1985 Volvo 740

3 Answers

1998 Rodeo TF Series 2WD 5-speed manual


vacuum leak......bad tps.......bad mass airflow meter system........any of those are suspect...... also check for bad ground at battery to be sure all is not computer freak out from bad readings ...good luck

Oct 24, 2008 | 1998 Isuzu Rodeo

1 Answer

Poor idle on my 2000 grand am gt


egr valve,or throttle position sensor

Jul 07, 2008 | 2000 Pontiac Grand Am GT

Not finding what you are looking for?
2000 Chevrolet S-10 Logo

Related Topics:

207 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

64052 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...