Question about 1993 Ford Festiva

1 Answer

My ford festiva has no heat.

Changed thermostat,refilled anti freeze...seems like i dont have coolant flow through engine/ i flushed the heater core but still no heat help me plz its cold in nebraska

Posted by on

  • Anonymous Dec 11, 2008

    Changed the thermostat and flushed the radiator and still no heat, what do I do?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,920 Answers

Check the watetr pump if its not working there will be no heat at all

Posted on Nov 22, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No heat in my 72 mark IV


The first item to check is the engine temperature. To help cold engines warm up fast, the flow of coolant is restricted by way of the thermostat-a thermal valve that opens when it's hot and closes when it's cold. When the thermostat wears out, it remains stuck open or shut, which leads to either overheating or cool operation. A worn-out thermostat might be preventing the coolant from getting warm enough to heat the cabin. Replacing the thermostat can be a 20-minute job or a real hassle. Check your service manual to see how involved the replacement is.

If the thermostat is fine, the flow of coolant in the heater core may be restricted by built-up goop. Sediment and grime can accumulate between coolant changes and collect in the heater core. A flush can be done by disconnecting the heater hoses at the water pump (when the car is cold) and using compressed air to push the coolant and gunk backward, out the inlet hose. Be sure to capture all the old coolant and dispose of it properly. Follow that with a few rounds of filling the core with tap water and flushing it out in the same way, then refill the core with mixed coolant and reattach the hoses. None of these fixes is hard, but the heater-core flush is messy, so you might want to take your car to a shop for service.

Oct 13, 2014 | Cars & Trucks

2 Answers

Drained radiator added prestone Radiator flush refilled and started overheating, drained radiator replaced thermostat and now I get no heat from heater,Radiator water is hot


disconnect the heat hoses going into fire wall , put hose into one with pressure and flush as it sounds like it could be bloked in the heater core,the other thing that could be the problem be the hot ,cold switch as it restricts the flow to makes the heater hoter or colder , it might need tlc or replacing as it is manaul not elec

May 08, 2012 | 1995 Toyota 4Runner

3 Answers

1997 Cirrus is still overheating... The heater does not blow out hot air...would the heater core cause the vehicle to overheat? if not, what other problems am I looking for, I was loosing anti freeze...


it appears that you have a large air pocket/low on coolant. The engine is getting hot due to the lack of coolant but there is no heat because nothing is flowing through the core.

Feb 20, 2011 | Chrysler Cirrus Cars & Trucks

1 Answer

Air flow will not get hot. Only warm, about 67 degrees is all. Have replaced thermostat. Fan motor operates fine, just temp sensor seems to have no effect.


Hello! The heater core is partially blocked...I would suggest flushing the cooling system with the temperature control on high...NOTE...The type of anti-freeze used in your vehicle is DexCool...If another type is used it may damage the cooling system...To flush...Drain radiator...Fill with plain water...Run engine until thermostat opens...Turn engine off...Let cool then drain...Do this at least three times or until water drains clear...Install new thermostat...Refill with 50/50 DexCool...Leave the radiator cap off as engine warms...Allow all air bubbles to escape...Then install cap...

The down side of DexCool is electrolysis...Electrical current flowing in the cooling system which can cause the anti-freeze to "clump" blocking its flow...Periodic flushing eliminates the problem...

Guru.........Saailer

Feb 03, 2011 | 1994 Cadillac Fleetwood

1 Answer

Hi. 2005 Impala 3.4. My water pump is failing for the second time in two years. Coolant flushed after first pump installed. Coolant flushed again six months ago. Pump is failing again. Thermostat...


WATER PUMP FAILURE COULD BE CAUSED BY WRONG COOLANT USE DEX COOL ANTI FREEZE.REPLACE THERMOSTAT AND BOTH RADIATOR HOSES TOP HOSE AND BOTTOM HOSE.SOFT HOSES COLAPSE LIKE PUMP HOSE.IT WILL COLAPSE FROM PUMP VACUUM CLOSING OFF SOME COOLANT FLOW.MAKE THE HEATER CORE NOT STOPPED UP IF SO IT WILL RESTRICT WATER PUMP BYPASS CAUSE EARLY PUMP FAILURE.YOU NEED 50/50 COOLANT MIXTURE YOU HALF WATER AND HALF DEX COOL DONT USE GREEN ANTI FREEZE USE ORANGE DEX COOL.I HAVE 3.4L ENGINE AND 3.1L ENGINE BEEN USING DEX COOL ANTI FREEZE SINCE I HAD BOTH VECHICLES. HAD NO WATER PUMP PROBLEMS.

Jan 23, 2011 | 2005 Chevrolet Impala

1 Answer

Heater does not work have flushed engine changed thermostat and heat flapper valve


the problem maybe heater core stopped-up. need to see if coolant is flowing thru heater core.and check to see if heater hoses are getting hot near heater core . if take off heater hoses to core with water hose run water thru one side of the hoses to see if water flows thru the other hose.

Nov 19, 2010 | 1998 Ford Econoline

2 Answers

Car will only have sometimes and i have replaced


If the car is not providing heat and thermostat is good, then your problem is a faulty heater core. Sometimes when heat cores wear out, they sometimes give off an anti-freeze smell.
You can go to autozone.com and register for full free online repair manual with everything you could need for your car.

Nov 15, 2009 | 1996 Ford Explorer

1 Answer

Heater doesn't work. A/C works and air blows, but no heat. Flushed antifreeze and replaced thermostat already. Help.


There are 3 possible cases: 1- The Flap Divert air direction valve for air flowing through the heater core is not doing its job. 2- The heater core gets clogged up. 3- The valve to control amount of hot coolant flow to heater core gets stuck. Let's check if the water can flow to the heater core first, by disconnect the output hose from heater core while running the engine with heater set up at maximum level to see if coolant flowing out. Catch this coolant with a container to refill it back. This way you can eliminate # 2 and # 3. Good luck.

Sep 15, 2009 | Ford Taurus Cars & Trucks

1 Answer

How to dianose waterpump to find problem


Could be the water pump or the serpentine belt is slipping on the water pump pulley. Is the radiator coolant hot? If it is, the coolant is not circulating through the block and heater core. I am assuming you see and hear no leaks and you have installed the thermostat in the correct direction to match the coolant flow.You should be able to squeeze the radiator hose before the thermostat and feel it expand when you have the engine running. You might be able to splice a hose with a T connection and valve to see the flow. Otherwise you would have to take out the pump and check the impeller.

Sep 09, 2009 | Ford Cars & Trucks

Not finding what you are looking for?
1993 Ford Festiva Logo

Related Topics:

389 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...