Rainbow Logo

Rainbow Recent Questions, Troubleshooting Help & Support

Do you work here? Claim your company

  • 53 Products
  • 778 Answers
  • 68K Views

It sometimes takes a good soaking with water in the tank for a while. Maby a Week or longer, and it also takes a little running time. Not more than 10 minutes at a time, then cool for 30 minutes inbetween runnings, for the water to pump out of them. Do not even hook up any hoses, until it pumps water.

Thank you,
Ralph

Rainbow E series... | Answered on Oct 08, 2019


you need to hold the seperator to keep the whole thing from spinning, then get a pair of pliers and turn the nut counter clockwise.

Rainbow Vacuums | Answered on Sep 08, 2019


check for a clog in the hose...most likely down by the hose/power nozzle connection

Rainbow Vacuums | Answered on Sep 08, 2019


Breakers trip when there is a short...looks are deceiving...electricity doesn't lie....you have a short...keep looking.

Rainbow 75th... | Answered on Sep 08, 2019


held on by screws on the bottom of the unit...unscrew to access the inside parts

Rainbow Vacuums | Answered on Sep 07, 2019


Undo the 2 clips (one on each side, and lift the canister/motor off the water basin.

Rainbow Vacuums | Answered on Sep 07, 2019


you have a clog in the hose....put the hose onto the exhaust and blow out the obstruction.

Rainbow Vacuums | Answered on Sep 07, 2019


Most models the casters slide into slots on the tray

Rainbow Vacuums | Answered on Jul 14, 2019


It won't run if the bowl isn't on. There's a safety switch

Rainbow Vacuums | Answered on Jun 03, 2019

Not finding what you are looking for?

Ask a Question

Usually answered in minutes!

Top Rainbow Experts

 Russ Hill
Russ Hill

Level 3 Expert

4057 Answers

Carl Rock
Carl Rock

Level 3 Expert

2436 Answers

Bill Boyd

Level 3 Expert

53813 Answers

Are you a Rainbow Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...