La Crosse Logo

La Crosse Recent Questions, Troubleshooting Help & Support

Do you work here? Claim your company

  • 94 Products
  • 545 Answers
  • 82K Views

  • Remove all batteries
  • Install known-good batteries in transmitter. Wait for it to initialize and begin sending data
  • Install batteries in "main station". You should see temperature displayed. If not, the transmitter may be ng

La Crosse... | Answered on Sep 24, 2017


Most LaCrosse weather station manuals are available here: http://www.meade.com/support/manuals/ or on the product page (see the Support tab). Using the search feature on the support page, I found three models which start 308-1414. Two of these differ in the color of the case of the weather station. Hover over the picture of any of these weather stations and click on the More button to go to their product page. The direct link to the manual for the 308-1414MB is http://www.lacrossetechnology.com/media/catalog/product/3/0/308-1414m.pdf . This product page is http://www.lacrossetechnology.com/308-1414mb-weather-station/ . The manual for the 308-1414W/308-1414B is http://www.lacrossetechnology.com/media/catalog/product/3/0/308-1414.pdf . The product page for the 308-1414W is http://www.lacrossetechnology.com/308-1414w-weather-station/ .

I hope this helps.

Cindy Wells

La Crosse... | Answered on Jul 10, 2017


Having same problem. Replaced with good new batteries from 2 different brands and still no go.

La Crosse... | Answered on Jul 08, 2017


There should be controls on the rear for the purpose.

La Crosse... | Answered on Jul 03, 2017


Probably due for battery replacement.

La Crosse... | Answered on Jul 02, 2017


Try Googling (LaCrosse)(WS916OU-IT)(manual) without parens.

La Crosse Radio... | Answered on Jun 25, 2017


The batteries in the outdoor unit may have failed.

La Crosse... | Answered on May 25, 2017


The new batteries could be defective or installed incorrectly. Remove all batteries and start over again. Be sure to let the transmitter initialize and begin sending data before you install the batteries in the receiver. If you can't receive a signal, the transmitter may have failed.
I have an Oregon Scientific receiver that is within line of sight of the transmitter and receives nothing......

La Crosse... | Answered on May 17, 2017


There may be defective batteries or a poor battery connection at the transmitting end.

La Crosse... | Answered on Feb 13, 2017


The instructions for your station call for a specific set up procedure. Batteries should be installed in the transmitter first with time allowed for it to initialize and begin sending data. After installing batteries in the receiver, you should see wind speed and temperature displayed. BUT, here in the real world I have a Lacrosse receiver currently displaying a balmy 67 degrees inside and a not-so-balmy - - outside. I believe the alkaline batteries used in the transmitter lose efficiency or freeze at low temperatures. Warmer weather restores the outside temperature display.

La Crosse... | Answered on Jan 05, 2017

Not finding what you are looking for?

Ask a Question

Usually answered in minutes!

Top La Crosse Experts

The Knight
The Knight

Level 3 Expert

76321 Answers

Cindy Wells

Level 3 Expert

6099 Answers

Tom Chichester

Level 3 Expert

55379 Answers

Are you a La Crosse Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...