Crate Music - Page 4 - Recent Questions, Troubleshooting & Support


If you wish to get some details; check the site linked here. Pull up older posts. Surf the site with patience. http://electronicshelponline.blogspot.com/

Crate Music | Answered on Mar 20, 2015


Your best bet would be ebay.

Crate Music | Answered on Mar 16, 2015


If u can bend the 2 prongs back towards plug end it. Will work on prong rides on tip of it the second rides in between the to nylon rings on it if that doesn't work any radio shack carry it for about 1-2 dollars

Crate Music | Answered on Jan 02, 2015


Hello Jamie.
Your right, it is not rocket science, this is way bigger and funnier!
Now, that you took apart the chasis fron the cabinet, you may try testing if the channel switching occurs when you hit the Printed Circuit board with some tool like the handle of a screwdriver. you can try with light hits and different places of the PCB while watching what happens in the front panel light. also you can try bending the PCB with your hand to see what happens, if the switching occurs, maybe you have a cracked solder on the pedal jack or in any component related to the switching circuit, in this case, you will have to pull out the pcb, and re-solder those points that can be cracked. Using a magnifiying glass is very helpful in looking for those cracked solders.
Good luck and best wishes.

Crate Music | Answered on Dec 10, 2014


need model number, manufaturer, just like a car..

Crate Music | Answered on Sep 20, 2014


is this a loud tech speaker or SLM speaker?

Crate Music | Answered on Sep 20, 2014


because something in it is shorted..shop time.

Crate Music | Answered on Sep 20, 2014


did it blow a fuse or is it just dead?

Crate Music | Answered on Sep 20, 2014


Check Battery

Crate TX50DB 50... | Answered on Aug 03, 2014


Sounds like your pots are dirty. You need to spray a cleaner such as Deoxit in the pots then rotate them a few times..This has to be done with the power off and the amp unplugged from the wall...Remove the knobs, get some food grade plastic hose which will be a snug fit when shoved on over the shafts of the pots...make sure to cut a piece off the hose about one inch in length...spray the cleaner into the hose and then with the hose still shoved down over the shafts rotate the shafts back and forth a few times...Then power up the amp and recheck...This will only work if the pots are not gone beyond the point of no return..Outside of that, they will need to be replaced which means you will have to disassemble the unit...

Crate CA125DG... | Answered on Jan 21, 2014

Not finding what you are looking for?
Crate Logo

200 questions posted

Ask a Question

Usually answered in minutes!

Top Crate Music Experts

Brad Brown

Level 3 Expert

18520 Answers

Ngoro

Level 3 Expert

2826 Answers

ray gallant

Level 3 Expert

70866 Answers

Are you a Crate Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...