Question about Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

I just installed a new xo vision x349nt dvd receiver in my car . My rockford fosgate p3001 amp turns on but the subs doesnt come on but when i would take the base control out and put it back in i can hear the subs beat for a second but nothing afterwards. Any help?

Posted by dariopratt on

Ad

1 Answer

Pablo Gonzalez

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 733 Answers

Make sure and check the RCA wires in the back of your radio that send audio to the amp and make sure that they're connected to the OUTPUT/SUBS RCA's and not an input rca's. Also, check your ground and make sure no speaker wires in the subs are shorted. Try one speaker at a time see if that helps.

Posted on Sep 26, 2011

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

I need parts for an amp

callem up im sure someone in tech dept. call help ya jus cus its not on a screen dosent mean rockford doesnt have it....i mean they made the amp n all .....u know
0helpful
1answer
0helpful
1answer

P3001 problem

if amp is mounted to back of the box try and move to in front of box near subs or port. the air movement of the sub will help keep the amp cooled. or you can orer some 12v cooling fans and take back plate of the amp and cool it that way. or you can buy higher quality audio, your choice
1helpful
3answers

How do I hook up one sub to my rockford fosgate p3001 amp

Hey i have looked over many rockford manuals,(i own a 300.1 my buddy owns a 325.1) and for there mono(.1) amps there hooked together on the inside so channel A+ and B + are cencted on the inside the amp. So you ither hook one 2ohm sub to channel A or you can hook 1 4ohm subs to channel A and 1 4ohm sub to channel B. There 2ohm stable so any lower will eventualy burn the amp out.
0helpful
1answer

Rockford fosgate p3001 lights up but around logo doesnt

check and make sure all powers (12v) and remote ground are were they should be then check signal outputs is in the right spot comeing from (THE Radio) to THE AMP imputs.THEN CHECK ALL OF THEM AGAIN. if thats not it you will have to bring it to someone like me and be charged around $30 an hour to fix.
0helpful
1answer

Fosgate amp 3001

It sounds like you may have open shields on the head unit. The following page tells you how to check them.

Temporary Shield Ground Repair
0helpful
1answer

Amp turns on but doesnt power my subs

well ill need 2 know wat knobs are all on the front of your amp
0helpful
1answer

RF P3001 power problems

check your sub woofer connection if you have multiple subs the could be wired in a parallel or with has to many ohms that my cause it to not hit right and cause the amp to get really hot and cut in and out
3helpful
1answer

P3001 amp may be fried

Check this out: http://www.techlore.com/article/14696/
Not finding what you are looking for?
Rockford Fosgate P3001 Car Audio Amplifier Logo

140 views

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8991 Answers

The Knight
The Knight

Level 3 Expert

76823 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1190 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...