Question about Hitachi 55HDX99 55 in. Plasma HDTV

Open Question

My 55HDX99 has no picture but has sound, what happened?

Posted by heersema on

Ad

1 Related Answer

Korede Atunrase

  • 1456 Answers

SOURCE: Hitachi 55HDX99 55 in. HDTV

Hello

Check the settings on your external devices,check the settings on the devices you are having a problem with. For example, if your Blu-Ray player is outputting to 1080p but your television supports a resolution of only 720p, this could cause the audio and the video to slip out of sync.

Try different inputs. If problems persist with external devices, plug them into different ports. The problem may be a bad input rather than a bad TV. Replace cables to make sure that isn't the problem.

Check the settings menu. If the image on your Hitachi TV looks too dark or too washed out, adjust the picture settings in the television's main menu. Sometimes the factory settings on a Hitachi TV aren't in line with the needs of the user

If this does not solve the problem,Press Menu Button, then in sequence 4, 7, 2 and 5.You are now in the Service Menu

Goto Options and press Factory Reset, it will only take a couple of seconds

Press Escape, Standby and Unplug from Mains Leave for 5 mins and turn all on again

If the problem persists, Open your TV and find PSB. (The board that the power cord plugs into) Check for faulty caps. If you find some (bulged or leaking) bad caps replace the entire board. They can be found online.

Remove and then replace individual faulty caps. This takes some soldering skill.

Caps are inexpensive and if you can take care of it yourself it will save you hundreds.

NOTE; If your tv is still under warranty,do not open the tv as this may void warranty.Best option will be to send the tv back to the dealer for replacement.

Posted on Dec 22, 2010

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

55HDX99 picture is getting darker and darker. Have adjusted settings but no improvement. It's 4 years old and has probably less than 7000hrs.


I would try that if available but suspect a bad board somewhere in the set--average life on all Plasma sets is 3-5 years so maybe time to upgrade to a new set?

May 30, 2012 | Hitachi 55HDX99 55 in. Plasma HDTV

2 Answers

Hitachi ultravision director's series 55"


I don't know how to fix your issue but I have the same tv with a cracked glass front. I would be interested in buying your tv for parts to replace my glass front if you are unable to fix yours. Please let me know. Thanks, Dan
[email protected]

Jun 10, 2011 | Hitachi 55HDX99 55 in. Plasma HDTV

1 Answer

I got a 55dhx99 the red standby light stays on when i turn it on and i get no sound or no picture?


sounds like bad capacitors in the power board. open it up and check for 1s that look like thay have swelling or are opening up. type in bad caps on you tube to see what a bad capacitor looks like....

Jun 08, 2011 | Hitachi 55HDX99 55 in. Plasma HDTV

1 Answer

I have a plasma 55 dirctors cut. No picture or sound was told upper y board was bad replaced it and still doing same thing


It is really hard to fix sets like this without voltage checks, but if you have any led lights flashing this may tell what is wrong with your set. Also if there are lights in the back of the set that are flashing on the logic board or the Digi-Main PWB But usually with a bad digi-main you have audio, also check the buffer board and see if any holes lie in the buffers. These are the boards on the far left side of the set looking from the back. The buffer chips are the black square IC's sometime you will see chip pieces out of the buffers. This mean that one is bad.

Feb 28, 2011 | Hitachi 55HDX99 55 in. Plasma HDTV

1 Answer

I have a thin purple streak on one side of my tv screen


panel is bad not economical to repair. usually repair is 90% of what you paid for tv new.

Jul 06, 2009 | Hitachi 55HDX99 55 in. Plasma HDTV

1 Answer

My plasma picture looks green


You are proberbly using RGB leads, wich is red green blue, each colour runs through each cable, have a look at your cables maybe one is loose, or damaged. check on both ends, but the cables MAY NOT be red green and blue, but the terminals that the plug into will be.

Jul 05, 2009 | Hitachi 55HDX99 55 in. Plasma HDTV

1 Answer

55HDX99 TV with Sony DAV-HDX500


Connect RCA Red-White audio cable to INPUT of DAV-HDX500 and hook it to TV AUDIO OUT pins at back of TV.
Now select INPUT in DAV-HDX500 to get TV sound in Sony system speakers.

Apr 19, 2009 | Televison & Video

1 Answer

Turned tv on got picture and sound,turned sound down lost picture now can only get sound and no picture


Sounds like a loose video connection. Try re-attaching your cables. Also, see if the same thing is happening with DVD's

Aug 24, 2008 | Televison & Video

Not finding what you are looking for?
Hitachi 55HDX99 55 in. Plasma HDTV Logo

Related Topics:

249 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76466 Answers

matt martin
matt martin

Level 3 Expert

1258 Answers

Cindy Wells

Level 3 Expert

6220 Answers

Are you a Hitachi Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...