Question about Krups 572 Power Xtreme VI Work Top Blender

2 Answers

Krups 572 Power Xtreme VI Work Top

After 10 years of very light use, my blender refuses to work. Pres any button and the result is the same: nothing. Please help.
Thanks,
Cindy

Posted by ttcindy on

Ad

2 Answers

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

Repairing the blender:
My guess: You worked the motor too hard on your last blending session and it overheated. That will cause a thermal fuse inside to cut off. The blender won't work again until you replace the fuse but otherwise it should be fine. The fuse looks like a white diode and it will be attached tightly to the motor with a nylon strap (so that it can pick up the heat of the motor). The leads to the fuse are shielded with heat resistant nylon wrap. You will need to remove the rubber drive gear in order to remove the plastic house so you can work, although if you are really handy you might be able to at least test the unit by only removing the plastic bottom on the base unit.

To remove the plastic housing, remove the little rubber feet and then remove all of the screws on the bottom of the unit. You may need to buy a bit set for tamper resistant screws (I ***hate*** those), I don't remember. When the bottom is removed, you will see that the there is a screw head on the bottom of the central motor shaft. You can use a screw driver here to hold the motor from turning, then you can carefully use a pliers to unscrew the rubber drive gear on the top of the base unit (try not to damage the rubber). With the gear removed you can get access to the wires.

To test the fuse unit, just check its continuity. Short=good, open=bad. To further test, short out the fuse with a jumper cable and your blender should work.

EPO (Electronics Parts Outlet) in Houston, TX, has the replacement fuse unit. I don't know that they like mail order.

Posted on Feb 03, 2009

Ad

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Mine quit also.  
I put in a toggle switch that bypasses the circuit board and now it works fine.  Only one speed now, but what the heck.
It only took a few minutes.
Mark

Posted on Oct 20, 2008

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

I need 0914084 Blender Sealing Ring Diameter 2 1/16"or its substitute.

Unfortunately that gasket, part number MS-0914084, has been discontinued.

Here is a link to the part online: Seal MS 0914084 for Krups Appliance eReplacement Parts

Unfortunately the gasket is obsolete, and there are no known replacements. The gasket is very perticular and i do not know of any other gaskets that have a similar shape.


25623986-qdbf5uehmmwbuijkgejle2ph-1-0.png

[email protected]
0helpful
1answer

O RING 574

There are 4 Krups 574 models, the seal shows as obsolete for 2x of them and still current for the other 2x

Part number for the seal that is current is MS 0974091
0helpful
1answer

Part number and price

You have to contact the manufacturer for that kind of information. We do not have part numbers or prices. We do not sell any parts.
5helpful
1answer

Teeth sheared off the rubber drive gear on Krups Blender Style 572. Have ordered part and need installation instructions

take a flat head screw drive to the bottom of the blender and us it to hold the blender shaft in place while you turn the gear by hand or with a plyers (it is reverse threaded) and it should spin right off. when you get the new on it should spin right on.
0helpful
1answer
0helpful
1answer

WHEN i PUSH ANY BUTTON TO TURN IT ON, IT WORKS FOR A FEW SECONDS THEN IT STOPS, i HAVE TO UNPLUG IT AND SHAKE IT, IT WORKS FOR ANOTHER FEW SECONDS THEN IT STOPS AGAIN. wHAT CAN i DO TO FIX IT?

Sounds like the brushes are not making good contact or you have a defective switch. Run the blender witout the container or blades . Free run it for 5 minutes id you can and see if that helps.
0helpful
1answer

I have i blend 5 speed and i turn it on and nothing happens

COMMON sorry to say , the problem is with the control , there is no fix except to return it . what i have been telling people is untill appliaces start getting better and not just this PRETTY JUNK from china go find a goodwill store and get a nice 20 year old blender and you will have it for years . or if you have the bucks buy a VITA-MIX there good but expensive good luck
1helpful
1answer

Will not work

First ensure that the blender jar is placed on the right orientation, othherwise the blender wont start.
Remove the Jar and place it on the other way if you are not sure.

If you still get the click, try leaving the blender power cord unplugged for a while. The click means that the blender has power, but the motor is not starting.
If it still does not work , and the jar is in the correct way and you did the above, then the blender is faulty, probably a faulty motor, or a broken wiring.

1helpful
2answers

Krups Type Blender 577

Mine did the same thing. I am ordering a new one from America for around $5.
http://www.abtecparts.com/index.htm

I am in Australia and they deliver worldwide.

Caz
Not finding what you are looking for?
Krups 572 Power Xtreme VI Work Top Blender Logo

651 views

Ask a Question

Usually answered in minutes!

Top Krups Blenders Experts

Ross Keen

Level 3 Expert

1365 Answers

Kolbrun...

Level 3 Expert

1218 Answers

Jeff Bird

Level 3 Expert

1348 Answers

Are you a Krups Blender Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...