Question about Audio Players & Recorders

1 Answer

Hello i have a 1980s technics suv9 amp when its playing it some times makes a static crackley sound and when i use any of the buttons they mke a cackley noise

Posted by green2007 on

Ad

1 Answer

Anonymous

Hi Green

You can fix that by spraying the controls and switches with CRC 2-26 (contact lubricant)You need to take the lid off to get at the internals of the controls, flood them with CRC using the straw that comes with the can. Do the same to any switches that are noisy also. It will be good as once again :)

regards
Graeme

Posted on Apr 15, 2008

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Technics su-g75 amp goes to loud static after a few minutes


Hi Aawpharmd,

system control error.
please go for repair shop.
regards,
nuwan

Jan 13, 2014 | Technics SU-G75 Amplifier

1 Answer

I have a Technics SL-QD33 turntable. Sometimes while playing a LP static will come out of either the left or right speaker, not at the same time. I have checked all my connections. I have a Bose system and...


It could be static electricity itself. Records are prone to picking it up. You can get rid of it with a verity of methods, too many to list, plus some better than others. Just search on-line for static record cleaning.

Jan 01, 2018 | Audio Players & Recorders

1 Answer

I have a Technics RS-TR373. Yesterday, during tape playing back, he sound suddenly stopped. The db level meter shows no sound being pickup. I switch to tape 2, it was the same. Tape was played (I can...


hi rich,
i had this problem it was touching the buttons that lost the sound to the speakers, do you have a re-set button if so press it if not press A or B to get your sound back if thats does nothing then try head cleaning tape as you might have some static thats transfered from your tape to your heads an anti- static head cleaning tape will do the job, you should use these cleaning tapes every week as the heads pick up a lot of dust particles and static that cause very poor reproduction and qulity such as crackling and muffled repro,
hope this helps

Jan 22, 2011 | Technics RS-TR373 Single Cassette Deck

1 Answer

Tape players wont play the tapes. THey are turning but no sound is coming out. checked all connections and can't figure out whats' happening. Technics model RSTR72. Is it worth fixing or should I get...


you have two buttons B+C USE B to get sound to your speakers if no joy try a simple tape cleaner or anti static tape cleaner this is usually the problem.

Dec 19, 2010 | Technics RS-TR272 Single Cassette Deck

1 Answer

Technics SL1200MK2 - audio issue with ''s'' sounds only


Try some anti-static record cleaner. You can also get an anti-static matt to put the records on.

Jul 27, 2010 | Technics SL-1200MK2 Turntable

1 Answer

Protect mode


Protection circuit.
Checek the wiring of the amp and speakers, don' forget to look for shorts at the speakers. Make sure no wires are touching each other

Apr 30, 2010 | Volfenhag 1600 WATT CHROME AMP AMPLIFIER 2...

1 Answer

Car radio/cd player cuts off radio will not play cd will not play ,hit the power button and will come back on some times it wil not. its seems like there is static sound when the music does not play on the...


Hello pinkperry,

It sounds like the wiring between the cdplayer and the dash has come loose. When the wires are not making proper connections some of the speakers or functions of the radio cut on and off.

This is just my first thought and the easiest thing to fix. You will have to remove the cd player from the dash. After which you will want to check the wiring. Chances are your cd player has a harness if it's an aftermarket cd player installed in your car. If it does there will be two sets of wires to double check.

Just make sure all the wires are securely twisted together (the sets of wires) and taped up with electrical tape.

Try that and post back if you have any further questions. Thank you for choosing Fixya!

Aug 25, 2009 | Car Audio & Video

1 Answer

CASIO PX575R 1 year old off warranty. Randomly, keyboard will lock up. The keys will stop triggering any sound, but the rhythm machine keeps on playing. And all the controls are locked, not a single button...


This may be a hard one to analyze, however my educated guess is that a static discharge is putting the internal processor in a program loop it shouldn't be in.

It is my experience that you MAY not even feel a discharge even.

Suggest you make sure to not wear static producing clothing as a test. Sliding across a piano bench might even create the discharge.

The unit SHOULD not be sensitive to this, but the designers don't always do things right.

ALSO make sure the unit is plugged into a grounded receptacle.

Use of external things like amps and headphones can WORSEN the problem of static. External amps MUST be fed from the same receptacle.

Aug 07, 2009 | Casio Music

1 Answer

Technics SL-L3 turntable no sound until warm up


either the cartridge is bad in the phonograph tone arm.  Or the pre-amp in the stereo is bad...remember that the turntable is the only accessory that uses the pre-amp input on the stereo.  I'm betting the pre-amp is bad.

Mar 10, 2009 | Technics SL-1210 Turntable

1 Answer

Amp not working properly.............


Mke sure that the tape monitor switch is turned off.
Dan

Apr 09, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

Muntejaya Ginting
Muntejaya Ginting

Level 3 Expert

10422 Answers

 Grubhead
Grubhead

Level 3 Expert

5700 Answers

The Knight
The Knight

Level 3 Expert

76390 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...