Question about AudioBahn AW1206T Car Subwoofer

1 Answer

I have a 12" sub and i dropped it and now its "stuck" when i hook it up it makes a popping noise

Posted by johnnie johnson on

Ad

1 Answer

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 383 Answers

If you cracked the giant magnet its a gonner

Posted on Jun 11, 2010

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Popping noise


Check the sub with a multimeter. It should read the ohms it is rated at when you hook it to the positive & negative inputs. It its off your coil if bad.

Mar 16, 2013 | Alpine SWR-1241D Car Subwoofer

1 Answer

Popping noise on my 12" type r subs


The subs are making that sound when the bottom out + when they reach full excursion be careful if it keeps happening eventually your subs will fail because you will end up damaging the subs voice coil.

Happy Booming

Apr 20, 2010 | Alpine Type-R SWR-1222D Car Subwoofer

2 Answers

MTX 12'' sub noise


Sounds like your sub is overextending itself, and possibly losing contact at the voice coil. Overextending will make a weird rattling sound, losing contact at the voice coil will make a popping sound.

I’m happy to help further over the phone at https://www.6ya.com/expert/jeremy_69f3cc28d95bf514

Jan 12, 2010 | Car Audio & Video

1 Answer

Amp is pulsating the subs uncontrolably, maybe its not hooked up right? its a kicker kx800.2 with a cap ooked up to 2 12 mtx audio subs....any ideas?


Hey make sure your ground is good. i had a problem like this befor and it was when i hooked the rca's in it would be pumping out bassing staticy noise and i had no acual ground hooked up took the screw and moved it to scratch the paint and Boom the real Bass came in. ....i thought it was grounded but it was not.

Jan 10, 2010 | Kicker KX800.2 Car Audio Amplifier

1 Answer

I have a Rockford PL2-110 and intermittently I get a loud popping noise out of nowhere. the sub sounds good the majority of the time but occasionally it will make the noise more and more often. any ideas?


Have you double checked the wiring ( + to + and - to -)? When hooked up correctly, a sub should push outward when bass hits. If your wiring is correct and your amp isnt too big for the speaker then its about to go out.

Jun 29, 2009 | Rockford Fosgate Punch Stage P312 D4 Car...

1 Answer

Make the sub pop and hum and no rca wire are hooked in?


first off nice choice on the amp check ur power and ground connections make sure the main battery to bady ground is good if questionable add a new one cant hurt to have extra grounds from the batt to the body make sure the amp ground is as short as u can make it make sure its grounded to bare metal if any of these dont work u may have a prob inside ur amp 

May 06, 2009 | Hifonics XX-Zeus Car Audio Amplifier

1 Answer

Sounds like a rainstorm


i had the same problem when i hooked up my memphis 500. i called the local audio store and they told me to make sure i had a good ground wire and keep the power and the remote wire away from each other. if they are to close they cause interference making the whining and popping noises. running your power and remote wires on opposite sides is what i had to do.

Mar 13, 2009 | Car Audio & Video

Not finding what you are looking for?
AudioBahn AW1206T Car Subwoofer Logo

Related Topics:

146 views

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5023 Answers

ADMIN Canada
ADMIN Canada

Level 3 Expert

38032 Answers

Trippy Tripp

Level 2 Expert

197 Answers

Are you an AudioBahn Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...