Bazooka ELA300.1 Car Audio Amplifier Logo

Related Topics:

Question about Bazooka ELA300.1 Car Audio Amplifier

1 Answer

My amp just stopped working the other day while i was driving and it wont turn on. there is power going to it and the remote wire is working. neither the red or green light will turn on. whats going on?

Posted by sbuker3 on

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

Blown fuse in amp or blown transistors in amp might check ground but i dont think thats it make sure no paint in the way on ground

Posted on May 17, 2010

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

I have a PYLE Amp. Model No. PLA-2380. I had it installed into my car it was working great! And then one day it just stopped turning on. It is getting power, the Ground is still good, And my remote wire...

You want to verify your wiring first. Use a volt meter to make sure the power and ground are good. You can jump the + to the Remote to bypass the head unit(after unhooking the remote wire). If at any point you had your speakers short out or wires hit together it will have smoked your power supply and damaged it internally. If you end up verifying the power and remote are working right and there is still no amp turn on, measure the fuse for resistance. Should be 0 ohms. If the fuse is good, the power/remote are good, then the amp is internally damaged. Any number of things could be wrong. Good luck
0helpful
1answer

Sony xplod amp won't work it stopped for no reason

try hooking the amp up with 3 wires, the red power wire, the black ground wire, and the remote wire, do not hook up the speakers at this time
0helpful
1answer

I have a kenwood kdc 233 cd player in my car but the remote wire aint working because i tried hooking up an amp i pit a light power tester on the remote wire but dont work and i dont think the input plugs...

as far as the remote wire a keyed power wire from under dash can be used its the same thing.if the remote wire is working it wont turn on your amp so are you sure thats not why your rcas dont work or have u hooked power to the remote on the amp.
0helpful
1answer

I have a linear amp 1600 I ahve power to it but it wont work and what is the remote wire supose to be connected to?

The remote wire is supposed to be connected to the remote output on the back of the head unit that is feeding the amp.
Without the remote wire hook up the amp will not turn on.
Reason for this is, the Head Unit tells the AMP to turn on, without the remote connected the AMP is going to do nothing, find the remote switch wire on the back of your Head Unit and run the wire to the remote input on the AMP.
0helpful
1answer

Alpine amp wont turn on..

your power wire is sufficating yor amp probably
0helpful
3answers

Jl audio 250/1 thermal light

Disconnect all speaker wires from the amp and disconnect the RCA cables from the amp. If it still goes into protect mode, use a multimeter to confirm that you have 12v on the B+ and remote terminals. Place the black meter probe on the ground terminal of the amp when measuring the voltage. If the voltage is sufficient and the amp goes into protect, it will have to be repaired. JL only accepts repairs from authorized dealers. You'll have to find one in your area or you'll have to find a repair shop willing to work on JL amps.

Let me know if you have any other questions.
0helpful
1answer

Jonny Rafael Every time i turn on my amp it stops and says Amp Err and shuts down and wont let me turn on like in about 20 min.I dont know wats wrong but i need help please.

Says amp error on the amp? what kind of amp? Have you checked the fuses and are you properly installed ie. remote wire to a remote power source. Properly grounded? Power wire to a constant power source? Please be more specific?
0helpful
2answers

My amp wont turn on

The reason it used to cut-off at 60% volume as you said before,
Is probably due to the "protection circuit mode" being tripped.

You can try resetting it by turning off your CD player ,removing the Batt( + ) and Gnd ( - ) terminals from the amp for a short period. Reconnect them Allow the amp to receive power but not switch on (keep cd player/remote power source off)

If you dont know how to wire the CD player to control the amps power status , the easiest way is to connect the 'power antenna' or similar low voltage throughput wire from the head-unit to the amp's Remote terminal.

My old amp did the same thing ,and would need to be powered off/on before resuming sound output, sometimes I had lots of trouble with the protect mode staying on , even with little or no sound output from headunit.
0helpful
2answers

My 2000 watt nitro amp just stopped working need help

Think about anything out of the ordinary that may have happened the day (or day before) it quit.
  • Was work done to your system?
  • Did someone mess with your system?
  • Smell anything odd?
  • Especially loud?
  • Did it quit mid-song or did it work yesterday and not today?
Assuming nothing special, here are some diagnostics you can perform. At the very least, they will help tell you what the problem isn't, First....

Eliminate power supply problems.

Use a meter to make sure you have power to your amps +12v terminal. A meter is preferred over a test light to confirm a full +12 volts.

Make sure the ground terminal is grounded. A meter with a continuity test option is best for this.

If either of these fail, trace the wires to find the fault. Large amps like yours normally have dedicated power cables. These cables usually have an additional in line fuse close to the battery. Check it.

If they pass, double check the amp fuse.
Pull the wire (usually blue) from the 'remote' terminal on the amp.
Then try jumping the +12v line to the remote terminal.

If it still doesn't power up, check for signal shorts.
Turn the gains down low.
Pull the input lines and try the +12v to remote jump again.

Next pull the speaker wires.
Your amp should now have only two wires and a jumper attached to it. Try the same jump.

If it still fails, the problem is in the amp itself and (I'm sorry to say) leaning toward the serious.

Hope this helped
Mike.
0helpful
1answer

Amp not turning on

wouldn't be the first JL amp I saw fried...but there are some tests you can do. First of all, double check your fuses, they may appear to be fine, but sometimes they are blown even if you can't see it. Either blindly change them or test them for continuity with a digital multimeter. Also, disconnect the remote turnon and jump power directly over from the power wire to the remote terminal on the amp, if the amp powers on then you have to go double check your remote wire. Hope this helps.
Not finding what you are looking for?

178 views

Ask a Question

Usually answered in minutes!

Top Bazooka Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5047 Answers

Marvin
Marvin

Level 3 Expert

85240 Answers

The Knight
The Knight

Level 3 Expert

76851 Answers

Are you a Bazooka Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...