Question about John Deere 420,1020,2010,2020,2510,2520 Tractor Float

1 Answer

John Deere x520 pto issue

I have a 4 year old John Deere x520 lawn tractor with 219 hours of use (90% of that time is cutting grass on 3 acre lot). After I removed my snow blade and put the cutting deck back on, I pulled up the PTO swich to engage the blades and nothing happened. I checked the fuses and all looked good. I pulled the cutting deck off to look underneath to make sure no wires were damaged. I cleaned the electrical plugs to remove dirt. My last trouble shooting check before I spend money to have it picked up and looked at by a local John Deere repair shop, is to replace the PTO swich itself to see if that is the issue. Don't think it will be it because I have not used the tractor that many hours and did not have any trouble with the PTO switch last year. Any suggestions before I send it off?

Posted by lkcyford on

Ad

1 Answer

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 235 Answers

Not trying to insult your intelligence, but did you make sure the belts were installed properly.it does happen to the best of us..good luck

Posted on Apr 11, 2010

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

John deere la105


Grass is too thick & tall and may require a second pass until next time when it'll be easier to cut, or... blades are dull & need resharpening, or... tractor speed too high for the length of the grass.

Jul 31, 2014 | Briggs & Stratton Garden

1 Answer

Why


On 90 psi remove plug, Spray WD40 in cylinder, this will increase the compression for a short time and lube cylinder. Before doing this with both plugs removed try to start engine 3 times to let compression stroke blow out both cylinders. Then spay the wd40. Ensure the oil ha been changed this year!

Jun 15, 2014 | John Deere 23HP VTwin Dual Hydrostatic 54"...

1 Answer

John deere x475 mower will not engage after cutting heavy grass


It is probably full of grass in the mower deck. Clean it out and try again.

Sep 25, 2013 | Craftsman 17.5 hp 42 in. Deck Lawn Tractor...

1 Answer

My john deere L130 with hydrostat won't drive,eng is fine


did you knock the drive belt off?did you pull the lever that allows you to push it when not running?

Aug 15, 2012 | John Deere Garden

1 Answer

I have a John Deere L120 tractor with a hydrostatic transmission which after a half an hour of mowing struggles to go in reverse and seems to loose power when moving forward without stressing the motot. I...


Hi, your problem is caused by the transmission over heating. Remove the battery and battery carrier and clean all grass and debris from the hydro cooling fins and fan. Hope this is helpful, regards Phil.

Sep 08, 2011 | John Deere 22HP VTwin 48" Riding Mower

1 Answer

My john deere z840a keeps overheating. regardless of the grass height and mowing at the proper speed; the temp alarm will come on after about 2 hours of cutting. it has plenty of water/coolant mix and the...


you may want to try heavily washing the radiator with high pressure water from all angles. Over time grass and dirt gets in there and causes overheating.

May 04, 2011 | John Deere Garden

1 Answer

"I have a 3 year old 19"self propelled john dere mower and have had to replace the needle bearings on the drive and told they had rusted due to me washing the mower down (*********) I have never in my 60...


You are one of the unfortunate ones who purchased the John Deere BRANDED push mower.Deere's upper managment decided to use a lesser quality mower made by someone else and slap their logos on it,all to save some $.In all my years with Deere I have never seen so many pushers come back for warranty work.Look on the net and you will find your exact mower a different color for 40% less.

Sep 06, 2010 | John Deere 420,1020,2010,2020,2510,2520...

1 Answer

The riding mower does not mow small strips in the middle of the row being cut. It almost looks like a bad haircut? This happens when I am going fast or slow. It is not a mulcher. This problem is...


Sounds like it is time to replace your blades, I have 2 scotts mowers made by john deere both machines are 9 years old I mow comercially and get 4 to 5 sharpenings the they need replacing.

Oct 08, 2009 | John Deere 420,1020,2010,2020,2510,2520...

Not finding what you are looking for?
John Deere 420,1020,2010,2020,2510,2520 Tractor Float Logo

1,066 people viewed this question

Ask a Question

Usually answered in minutes!

Top John Deere Garden Experts

Dennis Key
Dennis Key

Level 3 Expert

2481 Answers

john h

Level 3 Expert

23438 Answers

Brad Brown

Level 3 Expert

18438 Answers

Are you a John Deere Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...