Question about Televison & Video

2 Answers

Hitachi 53uwx10ba no sound/picture flashing power light cricket sound

I have a Hitachi 53uwx10ba Ultra vision t.v. it was working fine until a loud pop sound then no picture no sound. The power light flashes and it makes a cricket sound from the back, any ideas?

Thanks,
Mark

Posted by mlambert1 on

  • 4 more comments 
  • mlambert1 Mar 05, 2008

    Thanks,

    I took the back panel off and found that the problem is located on the "center" board. There are two lights flashing in time with the cricket sound. I have to leave town and won't be able to check anything until i get back next week.



    Thanks again!

  • lousgal Apr 04, 2008

    has good picture but no sound. plug in dvd player to front of tv then sound just went out

  • jnelson33 Apr 20, 2008

    I have the same problem. Can I fix this my self?

  • Anonymous Jul 15, 2008

    Hi, My 53WUX10BA is experiencing the same issue with, no power/sound with Power light on. I had the convergence board replaced about a year ago. I will replace both relays, but cannot find E907. Is it on the power supply board, convergence board, center board or far left board when looking from the back of the unit? When the power is on there is one led DP23 on the center board witch is not on, could this be of any indication as to which relay/pico fuse to replace?



    I am a technician, but have no schematics for this unit and cannot get any as I am not Hitachi certified.





    Any help would be appreciated

  • matthewmirow Nov 30, 2008

    I have the same problem after doing manual adjustments instead of using magic focus. I over adjusted. red power light flashes, on main board 2 green lights flash and one red stays lit. dont forget the cricket sound too. lol Take off the bridge and pic and sound work but picture is all over the place. Any ideas?

  • garytammy May 02, 2009

    tv wont turn on red light beside power button stays on. opened back,, 3 green led lights light up,, 1 red light,, but one dp23 green led does not light up. does this indicate the problem. what does it mean

×

Ad

2 Answers

Rodrigo Monroy

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

Hi there, i have the same problem, i was checking and moving the first board on right hand and works for two days, then i move the TV and happen again, same problem, and a just kick on the bottom of TV an works, and it's working for two weeks, i think may be it's a shot or lost contact in boards

Posted on Jun 14, 2010

Ad

Vista Electronics

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,694 Answers

Possible shorted cap C702 ? Open E994 pico fuse.....check
carefully with ohmmeter...all fuses and let me know.....T.

Posted on Mar 05, 2008

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I purchased my 60 inch hitachi plasma tv in 2007. Had been working fine until today when it made a popping sound and the picture fizzled out but oddly the sound remains, just no picture with sound.


This is fixable and if you can find someone in your area that fixes these it will cost you a couple hundred bucks. Seeing how this is a 2007 I would consider buying a new one. They just don't make them like they used to.

Jan 25, 2016 | Hitachi Televison & Video

1 Answer

My ultra vision stopped working the red light comes on showing power but the blue light will not come on and I get no picture or sound. Any ideas? Thanks


sounds like power supply board. easy fix..remove the back of TV take picture of the insides, and of the power supply board. jot down the part numbers off the board. do not remove till u get the replacement board. be careful back there even if it is unplugged u can get a shock. go to shopjimmy.com or amazon and look for a NEW board using the part # besure it is exact match..

Jan 25, 2015 | Hitachi UltraVision 42HDS52 42 in....

1 Answer

I have a Hitachi 53uwx10ba power light flashes and tv won't turn on


It is rare in this set but it indicates a short somewhere that is pulling voltage inside the set down---not a do it yourself repair unless you are a Technician with some basic equipment and a schematic diagram.

Have someone look at it from a repair shop or ?

Apr 14, 2012 | Hitachi Televison & Video

1 Answer

Toshiba TP50G90, makes a loud popping sound then shuts off. red light flashes


it sounds like its over heating.clean all the fans ,put new artic paste on the cpu

Jan 25, 2018 | Toshiba TP50G90 50" Rear Projection...

1 Answer

Pioneer Elite. Loud popping sound and picture disappeared


Power supply board is dead.The board where the power a/c cord plug into it.Replace the power supply board.Tries websites like Shopjimmy.com,Ebay.com to buy a refurbish power supply board for the replacement.

May 30, 2010 | Pioneer Elite PRO-1140HD 50 in. Plasma...

1 Answer

TV Exploded


Sounds like the DLP lamp failed. You can decipher the Hitachi flashing red light. That should help to be sure.
The DLP lamp replacement is fairly straightforward and can be done with minimal tools

Sep 10, 2009 | Hitachi UltraVision CineForm 55VG825 55"...

1 Answer

Hitachi 53uwx10ba turns on & off when off red flashing light/clic


Same problem. Replaced both convergence ICs about 5 months ago. Worked fince since then and just recently no sound, no video, blinking red on front panel and clicking sound. I suspect that the ICs went bad again and blew a resistor or two. I used cheap Chinese ICs instead of the Sanyo ones and thing this is why. I'll be looking at it again and post solution.

Jan 21, 2009 | Hitachi 50SBX78B 50" Rear Projection...

1 Answer

Power light flashes on Hitachi TV model #53UWX10BA


Hi


Can u tell me model no and company name so that i can help u clearly..

If u have warranty then u can claim it..

thank you

Oct 12, 2008 | Hitachi 53UDX10B 53" Rear Projection...

1 Answer

Hitachi 51F510


The loud "pop" sounds like high voltage arcing coming from one of the CRT's.....you may have to pull each CRT out and put silicon sealant on the anode connectors to prevent the arcing.(one of the CRT's may be arcing internally also and the only cure is to replace that CRT) If you let the arcing continue,it will short out the horizontal output transistor sooner or later.......

Mar 28, 2008 | Hitachi 51F510 51" Rear Projection...

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

938 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76443 Answers

Cindy Wells

Level 3 Expert

6197 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...