Question about Jensen VM9510 Car DVD Player

2 Answers

Jensen VM9311/ UV7i wont turn on!!?

I got my uv7i for Christmas and installed it, worked fine for a while, then i had to unhook my amp and hooked it back up. Then i went to turn the radio on to test everything out, the head unit turned on for about two seconds then it turned off with the red power light coming on. I pressed the power button and it beeps like it is working fine but the red light stays on and nothing happens.

I pulled out the head unit to check the inline fuse, pulled the fuse, it was not blown, waited a few minutes and put the fuse back in. As i put the fuse back in the radio beeps as it does when you first hook up the power. So i turn the key to see if resetting it did anything, but again it turned on for 2 seconds and did the same thing.

Any guesses on this one?

Posted by mrbomb on

  • 1 more comment 
  • Anonymous Mar 21, 2008

    when i try to turn on a red light just comes on and it keeps beeping every thime i hit power

  • Anonymous Apr 18, 2009

    t hat **** does not work u dumb **** ***** i tryed it

  • Anonymous Mar 26, 2014

    tried in stalling it but still wont boot up

×

Ad

2 Answers

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 2 Answers

I have the same problem. Any fix or solution for this yet?

Posted on Jul 11, 2010

Ad

Anonymous

Yo, I've got the perfect solution to your problem. Pull out the head unit from your dash. Then, remove the wiring harness carefully from the unit. Now, push in the yellow power wire (even jiggle it a little) making sure it's tightly snug the small port of the wiring harness. Then, plug the harness back into the unit and try turning it on. I've found that the wires come lose easily on this unit. hit me back up at [email protected]

Posted on Mar 28, 2008

Ad

1 Related Answer

Anonymous

  • 1 Answer

SOURCE: Jensen UV7i Need internal amplifier

I own a shop either get me the PN off the IC. I will either have it in stock or, can order for you. Audiovox will not sell parts for this unit. But, they will service this unit for you. Call us @ 727-530-5221, Radioactive Car Audio #1 in Tampa Bay area since 1987.

Posted on Jan 14, 2010

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Pioneer VSX 42 Elite receiver will not stay on


Your unit is going into protect mode. More than likely it is an issue with a channel. Check the back and make sure your speaker wires are not touching anything they shouldn't be. Also check your speakers as well for any wire shorts. If all checks good, you probably have a blown channel.

Jun 20, 2012 | Pioneer Audio Players & Recorders

2 Answers

My UV7i just opens and closes as it pleases


Some loose connection on the LCD panel to the device, or inside the LCD, by a certain vibration the monitor seems to get like a christmas lights one on/off..

you better bring it to a certain service technician to provide through test on your device.

thanks

Feb 23, 2008 | Phase Linear UDV9010 Car DVD Player

1 Answer

My pyle 2200 1400 watt 2 channel amp wont get power..... why!!!!!


did you check the remote turn on wire connection at the back of stereo?

Jan 15, 2012 | Pyle Car Audio & Video

1 Answer

Wii will NOT turn on!


IT could be a BLOWN FUSE , check the main power supply , good luck, AJ

Jul 09, 2009 | Nintendo Wii Console

1 Answer

I have a power acoustik ps2-2600 it went out this morning the red light was on i checked the ground it was fine when i unhook the remote or the audio cables it turns off if i hook up the audio alone it...


unhook all the cables including power let sit for 15 minutes and than hook up the ground rca cables remote and than power in that order with the car off and the battery unhooked that hook the battery up the amp went to protect mode to keep it from blowing i hope your amp isnt like some that only the factory can reset most amps arent and reset themselves

Apr 20, 2009 | Car Audio & Video

1 Answer

Amp Turns off after 30 seconds of song play.


Check your ground and make sure it is grounded to metal in your car with no paint. Also, make sure you are running 4 gauge power wire. Another possible cause could be that the ohm load is too low on the amp. Also, if your car battery drops below 10v it will send the amp into protection.

Apr 15, 2009 | Kenwood KAC-8103D Car Audio Amplifier

1 Answer

Amp won't turn back on, all fuses fine, all connections good


that sounds like the amp might have a bad ground.

Mar 15, 2009 | Kenwood Car Audio & Video

2 Answers

Jensen UV7I Problem when i push my clutch in its mutes the sound.


i would check to see if a wire is touching the clutch pedal ,when its depressed.either its grounding out on the clutch arm or its a loose connection that is being moved by the clutch arm.

Mar 10, 2009 | Jensen Car Audio & Video

Not finding what you are looking for?
Jensen VM9510 Car DVD Player Logo

955 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jensen Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5023 Answers

The Knight
The Knight

Level 3 Expert

76455 Answers

Muntejaya Ginting
Muntejaya Ginting

Level 3 Expert

10422 Answers

Are you a Jensen Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...