Question about Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Amp is not working right

My amplifire is not working correctly because every time i listen to the raido and the amp turns on it makes my speakers move in and out really fast and makes a wow wow sound while it does it and it even does it when my volume on my deck is turned all the way down. ( none of the wires are touching and the circutboard is not fried and non of the diodes on the board are poped).

Posted by on

  • Anonymous Mar 07, 2008

    When the power is turned off, I get a loud humming noise out of the base speakers.Is there a fix?

×

Ad

2 Answers

Try turning down the wattage to your speakers
i had the same problem with my sub it was just getting too much power

Posted on Apr 16, 2008

Ad

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 36 Answers

It is possible you need a filter between your head unit and your amp. I had a simalar problem with my car system where you turn it on and the subs go mental. I fixed itby going to my local car audio store and buying a noise filter to go between the amp and head unit. Hope this helps

Posted on Jan 26, 2008

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I own a Stanton T55 and I seem to have a problem making both speakers work with it. It is attached to an amp (Sansui A-910) and speakers (two Boston Acoustics A25). Yet when I listen to my vynils, only one...


Remove the wires to the cartridge (make a note of where they fit first). With your amp on, touch each wire (one at a time) with your finger. On one wire you should hear a buzz in the right channel, on another wire a buzz in the left. The two others should make hardly sound at all, or nothing. This test will prove the signal is getting to the amp. While testing make sure you move any RCA leads or plugs, to be certain they don't cut out.
If this checks out then replace the cartridge.
If it does not then you have a problem either with the connectors or and internal amp inside the turntable itself.

Dec 27, 2013 | Stanton T55 USB Turntable

4 Answers

Subwoofer


go to audio set up and configure the system for 5.1 or higher sound output.then only all the speakers ll work

Jan 03, 2008 | Yamaha RX-V640 6.1 Channels Receiver

1 Answer

Ilive bluetooth computer speaker system


replace the speaker with a new one :-)
but!!!
it can be aproblem with the amplifire !!!
if it bad in high levels and good in low its a speaker
if its bad all the way its a burn chanell in the AMP.
injoy

Dec 11, 2013 | Audio Players & Recorders

1 Answer

Hi I just got a Technics SU V2 amp and can't get sound from the speakers. What size speakers would suit this amp? What is the correct method to connect the speaker leads to the back of this amp,...


Being a 500W amplifier, you need to connect speakers with 300W each. The correct method to connect speakers is red terminal of speaker should be connected to red terminal of amplifier & black to black. The left side to left side speaker & right to right speaker. There may be main & remote terminals. Main speakers are the speakers at local place of the amplifier & remote for remotely placed speakers. I do have Technics SU-V85A which is somewhat similar. Enjoy! A nice piece to listen.

Oct 22, 2011 | Technics SUV500 2-Channel Amplifier

3 Answers

I have a pioneer vsx 515. Two days ago I went to turn it on and watch tv, and no sound. I have tried normal speakers as well as headphones (and it recognizes the headphones when i plug them in). ...


Get this service manual and follow it - basically you will have to determine
1 - if the amplifiers get powered
2 - if the amplifiers themselves are good - touch with your finger their input and listen for the buzz on the speakers.
3 - finally if the controller is still functional - if it's not then i'm sorry but there is nothing more to be done for it: the controller is not sold as a separate part, the receiver is dead. maybe you're lucky and you can find another one with failed amplifiers - buy it and use the parts from it.

Sep 18, 2011 | Pioneer VSX-515 Receiver

1 Answer

My PG Xenon 600 watt amp will not power my subwoofers


hello it sounds like your problem may be in the remote/power wire that goes from the back of your radio deck to the amplifier. the amp should have a wire connection that says remote,p.con, or antenna. and its usually the smallest wire connector located by the power and ground wire. this wire goes to the solid blue wire coming out of the deck. you can conect the wires together any way you want. i usualy shave off a little pice of the wire cover and wrap the wire coming from the amp around the bare wire then cover it in electical tape or cut the blue wire from the deck at a fit length and use a wire nut and put the two cut ends in and also the wire coming from the amp. also make sure the amplifire dose not have power to it just to be safe. wouldent want to fry anything.

There is also the left and right wires(ususaly red and white) that go on the back of the deck to the amp.

also chek the volume on the amplifire

Apr 12, 2009 | Phoenix Gold XENON 600.1 600 Watt...

1 Answer

Uv8 some seakers dont work in dvd/cd mode


You have the wrong wire hooked up to turn on your amplifire. You used the blue wire but need to use the Blue/White wire!! That is an amp turn on wire Thje blue one is for a power antenna and goes dead when you put in a disc. The tweeters play because they are hooked direct to your Jensen. You'll be jamming in no time.

Larry T
Winona Lae

http://www.cybersoundsaudio.com/cybersounds/vehiclepics.html IN

Jan 26, 2009 | Jensen VM9510 Car DVD Player

1 Answer

I have a samsung home theater system HT-X70. After 10 to 15 minutes the word protection scrolls across the screen then goodbye and finally the unit shuts itself off.


ther is dc voltage applying your speakers by amplifire itself and turn on speaker protection circuit itself.
it can be happens because
1.loose connection in amplifire board
2.faulty output section of amplifire
3.short circuit of speakers
4.error detecting circuit faulty.
if youcan open the cover and clean the circuit for dust and resolder the circuit with 30 W soldering iron cairfully.if you want the more asistence please come again
ican hlp you more.

Jan 08, 2009 | Samsung HT-WX70 Theater System

2 Answers

600w legacy amp


9 times out of 10 if your amplifire is in protect mode and evrything externaly, like speakers, fuse, voltage, etc. checks out fine then
either you have shorted out output transistors or power mosfet transistors. Basicly that just about what happens with car amps.
It's easy enough to fix IF, IF you know what your doing. First you
need to check the output transistors with a digital volt meter on diode check, If they check out then check your power supply mosfet transistors. I can almost guarantee this is your problem. Very common. I buy non working amps all the time and repair them. Listen to pbabin also he has helped me out. Good luck

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/mark_b53a7494531bf96d

Sep 08, 2008 | Legacy Audio American Legacy II LA490 Car...

Not finding what you are looking for?
Sony Xplod XM-1652Z Car Audio Amplifier Logo

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5013 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

288 Answers

Dalynn Turner

Level 2 Expert

346 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...