Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

1 Answer

No Suction in Hoover U6450-900

I do not get suction power. The passages are clean, motor gets on, roller is working. Appreciate any help. My e-mail address is [email protected]

Posted by on

  • Anonymous Jan 08, 2008

    i need a manual for this vacuum cleaner-grandmother passed away and must have thrown it out

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

If there is no suction, check the filters, if they are clean then there has to be a clog either in the hose or in the inlet down by the brush roll. See if there is suction at the hose end. If there is, then it is clogged down lower. Are you sure that the brush roll is turning when it is on the carpet? For a manual, go to www.hoover.com, put on your model number, if one is available, you can down load it.

Posted on Jan 09, 2008

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

5 Answers

I turn on the vacuum and it does nothing but when i put the brushes down is turns on and the brush motor runs.....but the suction motor won't do anything.......help!


You have power so it can't be the switch or power cord. It is most likely the motor or the cord from the switch to the motor that is the problem. Start by checking these areas first.

Mar 29, 2015 | Dyson DC17 Animal Bagless Upright Cyclonic...

3 Answers

How can i fix vacuum cleaner


check for blockages in all passages

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/david_2f6e03df6c124197

May 29, 2014 | Panasonic Vacuums

2 Answers

No suction


I presume the motor is running, take the front brush roller off and check the fan is still intact. Possibly broken fan.

Mar 30, 2014 | Kirby Ultimate G Bagged Upright Vacuum

2 Answers

Motor runs, but noisey, smells hot, brushes don't turn


First you need to check why the brushes are not turning, this could be due to a lack of suction, which means the smell of heat and excess noise is due to a faulty motor, this can also be tested simply by testing the units suction power.
A faulty motor is the most comon problem when it comes to smells of heat or 'ozone' as well as excessive noise. Good Luck.

Apr 12, 2010 | Hoover H3030 FloorMate SpinScrub 500...

1 Answer

The bar isn't turning on my Dyson Ball vacuum. It is brand new, never has been used, turn it on and the bar doesn't turn around.


Greetings from GoVacuum,

The Dyson DC15 Ball is a two motor upright vacuum. Most other uprights use just a single motor that controls the suction on one end, and the roller brush on the other end.

The Dyson however is different. The DC15 has two motors, one dedicated to suction, the other dedicated to running the roller brush. You should first check to make sure that you in fact have turned on the lower motor for the carpet setting. There are two switches right next to each other, one is for the suction, the other for the roller brush, make sure both switches are turned to the on position.

If both are in the on posistion, and the brushes still don't come on, the machine also has a reset switch for the lower motor. This is here to help protect the belt from burning if something gets stuck in the vacuum while it's on. There is a little red reset button on the top of the roller brush housing (I believe on this model it's on the left side of the brush if you were vacuuming), try pressing this red reset switch.

If neither one of these suggestions fixes your machine, I would personally return the vacuum to where you bought it. There's no reason that it should not work right out of the box, and this may mean that the machine was damaged in shipping.

If you'd like some further help, please let me know by entering a clarification request to these suggestions, and I'd be more then happy to try and diagnosis this further with you.

Was this helpful to you? If so, please be sure to rate the repair tip as helpful, this will help me out a lot. I really appreciate it.

Chris J.
GoVacuum

Mar 20, 2010 | Dyson DC15 All Floors - The Ball Bagless...

1 Answer

The performance indicator light is red and I have no suction.


If the motor runs, then the problem is usually plugged air passages near the bag/canister or the sweeper head/hose. Remove any hoses/bags/canisters so that you are dealing with only the vacuum producing parts. If it has a sweeper head, remove the bottom plate and clean any visible clogs in the air passages--the same with the area where the debris collects normally. Turn on the motor to see if you are getting air flow through the machine. If nothing, dig deeper into those air passages. Hope this helps!

Mar 17, 2010 | Vacuums

1 Answer

I have the A6000. It has power to the suction


If you have power in the wall and power where the cord enters the machine, you have a switch problem.

That is the approach I would follow.

Find replacement parts at a FixYa.com advertiser, your local appliance parts place or at www.repairclinic.com

thanks for your questiion

Please vote

thanks

Dec 13, 2009 | Vacuums

2 Answers

My Electrolux Upright vacuum cleaner will not suction. Motor will run to turn roller, though.


sounds like the hose is clogged.take off bag and look in the hose.or you may need a new bag

Oct 19, 2009 | Vacuums

4 Answers

My VAX Vacuum has lost ALL suction power. I've


vax power pet 1 filter keeps getting clogged up so dirt not going into cylinder

Jul 05, 2009 | VAX Appliances Vax X5 Bagless Upright...

2 Answers

Eureka 2961 BVZ no suction, burning smell


I have the same vacuum. The burning smell is letting you know that your belt is either broken or about to break. I have had mine for a year and have had to replace the belt 5 times. Now I have to replace the brush roller 'cause it broke under normal use. My next vacuum will be a Dyson Ball.

Jul 05, 2009 | Eureka 2961AVZ Bagless Upright Vacuum

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

Related Topics:

225 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Kirk Thompson

Level 1 Expert

11 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1481 Answers

Brad Brown

Level 3 Expert

18110 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...