Car Audio & Video Logo

Related Topics:

Question about Car Audio & Video

1 Answer

The hifonics amp is on but the subs dont work

When ever i hook up my hifonics generation x thor amp up the ligh cuts on but the subs will not work

Posted by chucktown250 on

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 26 Answers

Pull your subs out of your box and test each sub with a 9 volt battery it should **** in if postive is to negative and extend if matched neg to neg pos to pos

Posted on Nov 02, 2009

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer
0helpful
1answer

I hook it up and the diag light comes on

yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.
0helpful
1answer

I hook the hifonic amp up and it cuts on but the subs dont beat but the subs work

Try switching around one of the pos/neg speaker wires (you may have one crossed and they are firing out of phase, meaning when one pushes out the other pushes in and vise versa causing the base signals to cancel each other out) while the system is playing, only switch one speaker,not both. You can normally look at the subs and tell if they are moving very good and not much bass is there, you could also have the wrong box for them, this will also give a similar result
0helpful
1answer

Speakers cut off when bass goes up

probably the amp going to safe or protect mode judging by the fact that you have 3 subs wired to it i would say it is not 1 ohm stable try disconnecting 1 sub and see if it still happens this will be running a 2 ohm load rather than 1 if it stops happening then you need to figure out a better wiring configuration that will work with your amp.
1helpful
1answer

Make the sub pop and hum and no rca wire are hooked in?

first off nice choice on the amp check ur power and ground connections make sure the main battery to bady ground is good if questionable add a new one cant hurt to have extra grounds from the batt to the body make sure the amp ground is as short as u can make it make sure its grounded to bare metal if any of these dont work u may have a prob inside ur amp 
4helpful
1answer

Illuminating the sub

i would assume hooking it to the remote and ground of the amp
0helpful
1answer

Gets very hot and do not turn on

SOUNDS LIKE YOU BURNT UP THE POWER OUTPUTS IT'S UP TO YOU WEATHER YOU WANT TO BRING IT TO A REPAIR PLACE
IT MAY COST ALOT TO FIX GOOD LUCK
0helpful
2answers

Hifonics X generation galiath old school

Find your manual here: http://www.maxxsonics.net/manuals/hifonics/ Next tell me the exact model number of your subs and type of box they're in Be sure to leave good feedback or I don't get paid
0helpful
1answer

No sound to speakers

is the sub dual or single?check sub first then try disconnecting all power including ground for 20min to discarge caps some amps mute if driven hard at low impedience .
0helpful
1answer

Overheating

The Kicker 10 may be running a 1 ohm load and that amp isn't 1 ohm stable.
Not finding what you are looking for?

Open Questions:

134 views

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5047 Answers

Marvin
Marvin

Level 3 Expert

85241 Answers

The Knight
The Knight

Level 3 Expert

76851 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...