Audio Players & Recorders Logo

Related Topics:

Question about Crown Audio Players & Recorders

Open Question

Crown xti 6000 low input problem - Crown Audio Players & Recorders

Posted by Dj krish on

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1helpful
2answers

Crown xti 6000 SHEMATIC

Hello Anonymous,
Here are 2 links to Harman ( Crown ) Support and Service Manual.
Crown suggests you call their tech support First to determine the need for repair.
Best of Luck,
JP
https://3e7777c294b9bcaa5486-bc95634e606bab3d0a267a5a7901c44d.ssl.cf2.rackcdn.com/product_documents/documents/2862_1433871166/XTi_Series_Service_Manual_original.pdf

https://www.crownaudio.com/en/support
1helpful
1answer

I use the crown xti 6000 for 2 double 18s pd186 for bass per channel

Send a signal from the mixer to the amp directly, seems as if you have a distorted signal from your crossover
1helpful
1answer

Crown xti 6000 cuts on then cuts off in 3 seconds of the start up.

It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be your output drivers- the MOSFETS/IC's fitted for both the channels, Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise like a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.
You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board, maybe the protect circuit by itself is shutting off due to a faulty bias , maybe a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the protect is off then check for short on the speakers.

Thank you for using Fixya

0helpful
1answer

Does the input signal to the xti 2002 amp make adifferance balanced or un?

The balanced line input will be used for long runs to eliminate noise. it is low impedance.the high impedance line (unbalanced) is ok for sort runs such as in a rack. if you were say running output from a mixer 50' away you want to use the balaced output on the board and the balanced input on the amp.
0helpful
1answer

I have four xti amps in a rack ,a 2000 playing the highs 2 x 4000 playing mids at 4 ohms and a 6000 playing low mids at 2ohms Whenever i turn the 6000 on the three other amps starts to behave crazy the...

Assuming the behavior is instantaneous and doesn't wait for thermal change, you have a nasty ground loop problem that is coupling into the amps. Make sure ALL the speaker leads use TWISTED pairs, not the flat zip cord type wires. Make sure ALL the audio cables to these from the mixer are BALANCED using either XLR or TRS cables and not plain unbalanced cables like guitar cables.
Make sure the receptacle these amps are plugged into have grounding pins. Here is the biggee: Make sure ALL interconnectd equipment is powered from the SAME receptacle or POWER conditioning module. Using several building receptacles to power the amps and the mixer and any CD players is a NO-NO and is asking for the problem you are seeing. I can't go into the electrical engineering reason for this other than to say multiple feeds have resistance and inductance between them causing "ground bounce" that cross couples in systems like this. With this much power you should be using a large power conditioner and distribution unit at your venue. The pro's run power from a stage with the amps back to the mixer alongside the snake as an example.
Fix any/all of these problems you might have and if you still have trouble get back to me as these problems are a specialty of mine.
1helpful
3answers

Fan don't work when power is turn on crown xti 4000

the fans on these amps are heat sensitive, only when the amp heats up, then they come on
2helpful
2answers

Crown Xti 2000, signal to both channels, no sound out of one, swapped speakers, connectors, etc. , still no sound out of one channel

common problem with xti series... all the amp needs is a soft ware update contact crown and they can sort it for you... you dont have to send the amp back to them. it was a verry common fault with all the early xti amps..
0helpful
1answer

I need the schematic for the crown amplifier xti 1000 crown xti 1000 2-channel amplifier

These are available for purchase from Crown. Generally they are not available on the web. Is there a specific problem that you are having?

Dan
0helpful
1answer

Hooking up in Stereo

You'll need to use one of the four stereo inputs on the mixer and make sure you wire the speakers separately to channels one and two of the amplifiers. Assuming both of your amps are xti series amps, that's all you have to do.

Good Luck,
BB
Not finding what you are looking for?

15 views

Ask a Question

Usually answered in minutes!

Top Crown Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5750 Answers

The Knight
The Knight

Level 3 Expert

76851 Answers

Paul Bade

Level 3 Expert

1744 Answers

Are you a Crown Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...