Televison & Video Logo

Related Topics:

Question about Vizio Televison & Video

1 Answer

I have a Vizio M50-c1 and have no picture

My tv has no picture but has audio and I have pulled the one cable off of the T-Con board on one side and I get half a picture and when I do the reverse on the other side no picture what could my problem be can you help

Posted by Melvin Epps on

Ad

1 Answer

Larry

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Vizio Master
  • 4,632 Answers

You have a bad panel, time for a new TV

Posted on Oct 04, 2022

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Vizio M50-C1 two images on screen My TV show one image split into two.

Are you saying that the same picture is split into two, or that there are 2 images split on the screen? Might be the PIP board or setting on the remote that is bad.
0helpful
1answer

I have a Vizio LED TV, model M50-c1. I have audio but no picture. No backlight. First step to replace t-conn or main board?

Chances are your T-con may be bad . I would check the backlight by shining a flashlight by the screen to look for an image on the screen . If an image is present, then the backlight is the problem. Your Tcon and main board could be ruled out, if this is the case . At this point check the power board for voltage to the led driver. The leds could have issues.
0helpful
1answer

I have an M50-C1 model Visio LCD tv and being told I need to replace my T-Con board. Do I?

The T-con board is inexpensive. Try replacing it. You will find one online for cheap price with a google search.
0helpful
1answer

I have a vizio tv model m50-c1. I have audio and backlight but nothing on screen. I have replaced the t conn board and did not fix the problem. Any idea on what my next step would be? thanks

1. Screen buffer test: Disconnect the two flex cable between the T-CON board & the screen one by one to see if one cable is disconnect the picture is come on a half a screen or not, if it does, the screen buffer board is bad that is not fixable, you need a new screen.
2. If the buffer test with no result, i will try a new main board.
1helpful
1answer

TV image vibration

Fault at its main digital board. Short circuited component/s at it. Contact any service technician; or the authorized service center. If you wish to get some details; check the site linked here. Pull up older posts.
http://electronicshelponline.blogspot.com/
In most cases, the main board might have to be replaced. If so, a software [firmware] update too might be necessary.
0helpful
1answer

MY VIZIO M50-C1 TV BROKE, AND I NEED A LITTLE HELP. I REPLACED THE POWER BOARD ON IT AND THE SAME THING STILL HAPPENS.

If you have no picture and no sound, go with the main board first since that board works with both. If you have sound try the t con board first since it specializes in the video that appears on our screen..
Not finding what you are looking for?

Open Questions:

29 views

Ask a Question

Usually answered in minutes!

Top Vizio Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76851 Answers

Cindy Wells

Level 3 Expert

6556 Answers

Marvin
Marvin

Level 3 Expert

85241 Answers

Are you a Vizio Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...