Question about Car Audio & Video

1 Answer

Subwoofer problems I bought 2 10'' Visonik V105PR subs from www.thedeepdiscount.com over 2 months ago and just tried installing them now. My problem is that they do not work. No sound or nothing. Amp is fine, my other subs work with it. Any answers or help on how I can fix it since my 30 day return is up?

Posted by rheabarb on

Ad

1 Answer

Wayne Bayley

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 30 Answers

Have you checked the subs properly to make sure that they are faulty. If you do not have a multi meter then jus take a small batter for a torch or something. Take a wire and touch the + to the positive on the sub ad the - to the negitive. If the sub makes a staticsound then sub has passed the quick test. If no noise comes out then sub is shoe laced. heck that the pig tails are in tact. There is not much that you can do if the sub is faulty. Hope this helps but normaly a faulty sub is a throw away unless it costs alot of cash, then it would be worthwhile seding it in for repairs.

Posted on Sep 18, 2009

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My visonik v700hc keeps going into protect modeafter listening for a couple minuits then will go green light then back to red after a coupke more any solutions


I suggest checking what ohm load you're presenting to that amp. go to www.the12volt.com and find the subwoofer wiring diagram and choosing the amount of subs you have on it and then the impedence of each one. you're probably sending too low of an ohm load to the amp this would cause it to go into protection quite frequently and eventually stay in protection.

May 30, 2010 | Visonik V700HC Car Audio Amplifier

1 Answer

Nothing will come on


have you wired it back in correctly? and have you connected the auto ariel lead back to the remote connection on your amp?

Mar 17, 2010 | Visonik V117SX Car Audio Amplifier

1 Answer

I have a visonik V8EQ, that i just bought last weekend, & it didn't with a manual or install instructions, i tried going to web site i found on warranty card, but i get an error message. i searched the...


Hello,

I tried my best but was not able to find one also. I was able to browse their website and its not there on the downloads page.

Your best bet would be to contact them at [email protected] The shop where you bought the device should give you the manual. How will you install it if you don't have a guide.

Best of luck!

Aug 07, 2009 | Visonik Audio Players & Recorders

1 Answer

Does it sound hot cool and bad ***


Hello dylanholick,

Visonik is somewhat low-end car audio and band pass enclosures in general usually produce rather muddy and boomy bass. It will probably sound "bad", but not hot, and not cool.

If you aim is a good self-contained system with amp, sub and enclosure all in one, why not consider an Infinity Basslink, MTX Thunderlink, or perhaps a Bazooka. They're all available at www.crutchfield.com for little more than you'll pay for the Visonik and any of them will definitely sound better.

Hope this helps.

Jul 14, 2009 | Visonik 10" 500-Watt Single Bandpass...

1 Answer

Visonik V12D4


i would wire the coils of each sub in series which would yield an 8 ohm resistive load per sub - and then wire the subs in parallel to the amp which would bring the resistance back to 4 ohms for a bridged load which will give you max power handling from the subs and draw the full power of the amp at the same time

Jun 18, 2009 | Earthquake Sound PH800W.2 Car Audio...

1 Answer

Visonik amp problem... amp goes in and out of protection


Check for intermittent shorts on the speaker leads.

Turn down the volume control on your head unit while operating the amp, you could be over driving the amp.

Remove Speaker leads and reset the amplifier. IF the protection LED still comes on amplifier is faulty.

Below is the link to put in a help request with the manufacture for repair.
http://www.visonikcaraudio.com/category.jhtm?cid=27

Mar 25, 2009 | Visonik V408XT 250W x 2 Car Amp Car Audio...

1 Answer

Ok this problem is killing me...


maybe the speaker is bad

First try one thing, switch the rca jacks around and see if the other speaker stops working this time.

If so the problem is in the rca jack or head unit.

If the same speaker is still not working, the problem will be the speaker, you will have no other options left since you changed amplifiers and checked all wiring.

Let me know if this helps you

Jun 18, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Installing visonik bass system


Here is a link to visonik to download manuals.
http://old.visonik.de/en/downloads.php

If you let me know your model number of the sub, vehicle make and model, and brand and model of headunit or CD player you have then i can provide wiring color codes, recommended wire routing locations, etc...

Jan 03, 2008 | Visonik 10" 500-Watt Single Bandpass...

1 Answer

P3001 amp may be fried


Check this out: http://www.techlore.com/article/14696/

Aug 06, 2006 | Rockford Fosgate P3001 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

The Knight
The Knight

Level 3 Expert

76416 Answers

Brad Brown

Level 3 Expert

18438 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...