Question about Hifonics Car Audio & Video

Open Question

Green power light will come on and stay on but the blue hifonics light on top will just flicker with no sound at all. Bought a complete new wiring kit it didn’t fix the problem

Posted by on

Ad

5 Suggested Answers

Anonymous

  • 631 Answers

SOURCE: no sound in my Hifonics Brutus BXi 1206D amp

Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Posted on Jan 02, 2008

Ad
fixerdlt1

Darrin Thrun

  • 18 Answers

SOURCE: kicker zx 1000.1 green light flickers and no sound

The first thing I would suggest is to check all connections to the amp and speakers, especially the ground. A loose ground can cause the problem listed. You can test this by temporarly running a ground from the amp to the battery neg. . If the amp fires up ok then that means your grounding point for the amp should be checked and cleaned and reattached firmly. If you have a meter(multitester) set it to ohms and check the impedances of the voice coils in the woofers. If one is cooked it may be shorted and tripping the amps protection. Always hook thing up with the sys off and then turn on and test.

Posted on Jul 22, 2009

Ad

dewey wyatt

  • 202 Answers

SOURCE: Fix new pull switch to turn on light on ceiling fan

either one all it does is complete the circuit. only one wire is broken to open the circuit when you cut it on and off you just open and close the circuit with one wire.

Posted on Jul 29, 2009

Anonymous

  • 18 Answers

SOURCE: Green light wont turn on, but the amp has some power because it is lite up blue.

I have the same problem in my car, and both the fuse in the amp and battery are good, is there another fuse I am not aware of that I should check?

Posted on Jul 29, 2009

budmrtn

Bud Martin

  • 11361 Answers

SOURCE: My Sceptre LCD TV Power turns on briefly (blue

Power supply is the place to look, look for bulging on top of the capacitors in the secondary side of the main power supply.

Posted on Oct 24, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a brand new Hifonics amp 1500 watt Brutus the only thing that powers up is the logo the power light and protection light stay off the amp brand new out the box what can be the problem


Some amps will not power up internally if u donot have remote wire. Also if u connect power then remote wire it will not power up until u reconnect in correct order. But if all that is ok. Than u have a bad amp

Mar 11, 2017 | Hifonics Car Audio & Video

1 Answer

I have a hifonics brutus 1606d 1600 watt amp it gets power green light is on lit up across the top but i cant get any sound


Your amplifier may have experienced circuit failure other than a dead short that still allows power to be applied

Dec 05, 2016 | Hifonics Car Audio & Video

1 Answer

I just bought a hifonics amp the brz2100.1D and when i tryed to hook it up every thing is correct as far as the wireing compared to the manual and the blue lights come on power light is on but its not...


MAKE SURE YOUR GROUND WIRE IS GROUNDED GOOD,,AND IT IS IMPORTENT TO HAVE YOUR REMOTE WIRE HOOKED UP. IT WILL BE A BLUE WIRE,,FIND THE HOT WIRE FOR YOUR TAIL LIGHTS AND HOOK IT THERE THEN WHEN YOU TURN YOUR CAR ON THE AMP WILL ALSO COME ON.THAT SHOULD STOP ALL THE NOISE AND POWER YOU UP.

Jul 15, 2011 | Hifonics BRZ21001D Car Amp

1 Answer

Amp not working


sounds like the amp is going into protection mode. maybe a sub is shorted (blown). Or, the only other possibility is the mosfet transistors on the inside of the amp are blown.

Feb 01, 2010 | Hifonics Brutus BX 1205D Car Audio...

2 Answers

D52W20BYX1 Green problem


I would go back to green tube disconnect ,unplug CRT board to green tube if set stays up playing its the tube.

Sep 19, 2009 | RCA D52W20 52" Rear Projection HDTV-Ready...

1 Answer

HiFonics txi4008 not working, partially lighting up


Sounds like your amp has some power supply compents shorted out. Maybe some of the power mosfets are shorted and your only getting a little bit of power. That why only the H is lighting and as far as the green light, it don't take much for it to turn on. If it was major it would go into protect mode but it is'nt. I repair amps for a living and I'm the cheapest you'll find. But if you know about electronics and think you can take a crack at it, check it out. Becareful you could do more damage. Let me know if your interested. [email protected]

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/mark_b53a7494531bf96d

Jun 06, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

I cut the plastic wiring connector, fan motor to to light kit, from a Harbor Breeze paddle fan. This connector had a short in it, and I wanted to hard wire around this connector. I reconnected all of the...


The top wires, black, white, and green are the ones to hook to just run the fan. The blue wire is wired with the black at the top if you want the lights to work. At the light kit, the blue and white wires power the lights.

Apr 21, 2009 | Electrical Supplies

2 Answers

Power good no green light no subs


Make sure you got a good ground. do not ground on painted surfaces! If you got power from battery, check the remote wire running to cd player. Hook up remote blue wire with the one for cd player. If you still have a problem and the fuse is good, then the amp is fried

Jan 30, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Okay i have a problem hifonics brutus 1500 mono d class amp


well your amplifier is obviously going into protect mode,(i used to have this amp and it is awesome) anyway i would go through just to be sure and check all the power connections with a test light, remote wire, positive, and ground. and check the fuse to see if it is still good. you can buy a test light at wal-mart and any automotive store. if you stil have a problem then i would check to see if your running below 1 ohm on this amp. that would cause it to go into protect mode. if all this fails i would just go buy a new one.

Oct 07, 2007 | Hifonics Brutus BX 1505D Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

116 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

93 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1176 Answers

Marvin
Marvin

Level 3 Expert

85223 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...