Question about Alphasonik Car Audio & Video

Open Question

What color light is post to be on for a alphasonik app for the power and what color light is for protection mode

Posted by Jason Cotter on

Ad

1 Related Answer

fingaz22

michael schultz

  • 1068 Answers

SOURCE: I have an alphasonik pma600hca everytime i power

yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.

Posted on Jan 31, 2010

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Is the red light that says protection on the hifonics hifi1001.1d suppose to be on or of? My is not on is that bad


My guess is if there is a fault and it has to go into protect mode the light will come on. The red color is usually stop or warning etc ... green = go or good.

Dec 01, 2013 | Car Audio & Video

1 Answer

I have an alphasonik pma600hca everytime i power it up it goes into protect rite away???? Any ideas???


yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.

Jan 21, 2010 | Alphasonik PMA600HCA Car Audio Amplifier

1 Answer

How to fix protection light


It's usually your ground. Make sure it's secured to something metal. If it's a painted metal, sand a spot down to the paint for the contact. It could also be a screwed up speaker or even interference between wires. Make sure they're separated and insulated.

Jan 04, 2010 | Alphasonik PMA1000HCA Car Audio Amplifier

2 Answers

My sansa fuze wont play i know it has power in it because the blue light surrounding the center dial is lit yet i cant get a screen to come up nor can i shut it off


Hello,

Sandisk gives next support link, how to recover the player:
http://kb.sandisk.com/app/answers/detail/a_id/4/kw/blue%20ring/r_id/101834

Solution 1: RESET THE DEVICE
Scroll to the Sansa Fuze on next site, how to perform a reset:
http://kb.sandisk.com/app/answers/detail/a_id/188/kw/blue%20ring/r_id/101834
f78ea59.jpg

When solution 1 did not help.
Solution 2: RELOAD AND UPDATE THE LATEST FIRMWARE
All data on the player will be erased when updating firmware !
Go to next sites, seeing how to do a firmware update:
1. To perform a firmware update the player has to be in MSC mode.
How to put the player in MSC mode, see the information about the
Fuze player:
http://kb.sandisk.com/app/answers/detail/a_id/61/kw/blue%20ring/r_id/101834
Putting Sansa Fuze in MSC mode:
1. Turn device OFF.
2. Slide the Hold switch down to Lock (orange color showing).
3. Press and hold the left button ( |<< ) while connecting the device to the PC.

2. Continuing with the firmware reinstallation you can choose either automatic or manual update, see:
http://kb.sandisk.com/app/answers/detail/a_id/278/kw/blue%20ring/r_id/101834
Automatic update using the Sansa Updater.
or
Manual update going to Sansa Forums.

Need more help ? Just post a comment.

Dec 10, 2009 | SanDisk Sansa Fuze MP3 Player

1 Answer

3 caps inside exploded powere light just flashes


WELL MY FRIEND THAT NEED TO BE BENCH TESTED YOU HAVE SHORT CIRCUITED THE AMP

Jul 14, 2009 | Alphasonik PMA1200D Car Audio Amplifier

1 Answer

Alphasonik amp is getting power but no power to subs


either your rca inputs are bad or your mosfets are bad

Jul 05, 2009 | Alphasonik PMA1000D Car Audio Amplifier

1 Answer

Unit is in protection mode


Disconnect all speakers from it, then turn it back on. If the unit is OK, it should come out of protection. Turn it off, then reconnect one speaker and power on, repeat until it goes into protection, then you know where the problem is. Now disconnect the speaker wire that caused the problem but this time at the speaker. Make sure your wires do not touch, then turn it back on. If it stays on, it's a speaker problem, if it shuts off it's a wire problem. If you still need more help, post a comment and I will help some more. Hope this helps

Jun 14, 2009 | Pioneer M10X 2-Channel Amplifier

1 Answer

Protection Light


when the protection light comes on means either you have something like you power and bround backwords,or you have speaker wires touching somewhere..

Dec 04, 2008 | Alphasonik PMA1200D Car Audio Amplifier

1 Answer

Red status Light


If the protection LED is lit, the amp is in protect mode and probably has shorted output transistors. To eliminate other possible causes, read through the following page:

Amp in Protect Mode - Trubleshooting

Let me know if you have any other questions.

Nov 07, 2008 | Boss AUDIO RIP-596 2-Channel Ripper Series...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

50 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alphasonik Car Audio & Video Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

The Knight
The Knight

Level 3 Expert

76407 Answers

Brad Brown

Level 3 Expert

18397 Answers

Are you an Alphasonik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...