Vacuums Logo

Related Topics:

Question about Bissell Vacuums

Open Question

Bissell spotbot pet, only the hose button works; spray & suction are fine. Hose isn't clogged. FIXED!!

Someone on the internet is a genius; not me! But this worked!! The hose was no longer "clicking" into place. So I removed the phillips head screw on the part of the hose an attachment is supposed to go on. That little, rusty gross chunk inside is what remained of the magnet. I tried cleaning it off, further disintegrating it. I tried sliding up what was left to the top of the hose thing. Nope. Too small & crumbly. Went to Hobby Lobby, got 12 teeny magnets for $5.99, put the old magnet back (to hold them up where they should go) shoved in 1, then a 2nd, and crammed the plastic lid back on, screwed it back shut and rammed the hose back into place, and ALL THE BUTTONS WORK NOW!! Also wrote "DO NOT USE THE HOSE" on top with sharpie. It was a pain getting them to sit just so. Never want to go thru that again, but I have 10 magnets left if I need to!

Posted by Arline Sprau on

Ad

5 Related Answers

Anonymous

  • 1673 Answers

SOURCE: Bissell Lift Off pet revolution vacuum losing suction

You may have a clog in the hose. Unhook the hose and see how the suction is there, if ok, then check the dirt inlet by the brush roll. If suction is low at the hose, then there is a clog in it.

Posted on Mar 20, 2008

Ad

Lots a Hair

  • 1 Answer

SOURCE: bissell lift off pet-no suction through base (hose is fine)

I had a similar problem with mine. When you take the collector container out, if you reach your hand up, you will fill a round, plastic piece. Gently turn it and the piece pulls out. On the outside of the piece is a foam filter that may be plugged. There is another filter underneath the collection container in a pull-out drawer. Both filters can be washed with cool water, allowed to dry totally, then replaced. I understand that both of these filters need to be washed "frequently". It worked for me, hope it works for you.

Posted on Jun 15, 2008

Ad

Anonymous

  • 701 Answers

SOURCE: bissell pet hair eraser-the brush is not rotating

That means that you need to replace the belt. Here is the belt you need and a manual you can view which has instructions:

Bissell Pet Hair Eraser Belts and Manual

Posted on Jan 01, 2010

heatman101

D. Floyd Kolb

  • 43501 Answers

SOURCE: I have Bissell ProHeat 2X

Hi,

Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101
eyy642

Posted on Sep 30, 2010

askdyson

AskDyson

  • 2572 Answers

Official advice and support for Dyson technology

    Verified Fixya Pro

    SOURCE: the vaccum works fine but when I use the hose the brushes don't rotate and neither does the hose have any suction

    Hi there,

    I'm sorry to hear you're having difficulties with your DC18. The brushbar is designed not to rotate when the machine is standing upright, so this is nothing to be concerned about.

    However, if there is no suction from the hose, there may be a blockage in the machine. To resolve this, please follow the steps shown in our online Support guide:

    http://www.dyson.com/support/help.asp?article=1049&product=DC18-ALLFLOORS

    You may also want to give the filter a wash - in normal use, this should be done at least once every 3-6 months, as shown in the video below. Use cold water without detergent, and allow at least 12 hours for the filter to dry completely somewhere warm before replacing it.

    If you'd like any further assistance or advice, please call us on 0800 298 0298 (UK), or 1-866-693-9766 (US).

    Best wishes,

    Jack
    Dyson Online Customer Support
    http://www.dyson.com

    Posted on Mar 27, 2012

    Add Your Answer

    ×

    Uploading: 0%

    my-video-file.mp4

    Complete. Click "Add" to insert your video. Add

    ×

    Loading...
    Loading...

    Related Questions:

    0helpful
    1answer

    My Bissell Spotbot Pet cleaner stopped working. Took it out of the closet, plugged it in, No power? It worked great the last time it was used.

    Well, if cycling it manually doesn't work and replacing the controller board didn't make a difference did you check the flex hose sensor? Bots won't run unless everything is clicked into place.

    "Testimonials" don't continue the thread :)

    I managed to dig up a copy of the service guide since I haven't owned a spotbot in years. http://evacuumstore.com/images/spotbot-repair-guide.pdf
    tip

    How To Replace The Hose On A Bissell Spot Bot, SpotBot, and Little Green...

    Replacing the Suction Hose on a Bissell SpotBot can be a challenging repair. We frequently get this question, how do you remove the old hose, so we decided to shoot a video repair demonstration on how to replace the hose assembly.
    This repair works for all Bissell SpotBot models in the 1200 Series, as well as the 7887, and some Little Green Machines.
    If you need to purchase a new Hose Assembly, you may find it on our website below:Bissell SpotBot Hose Assembly Part 203-6665

    Here's the video showing how to replace the hose:





    Please feel free to email us with any questions or clarification requests, and please be so kind and rate the video helpful if you found it to be.
    Thanks so much,
    Chris JonesGoVacuum
    0helpful
    1answer

    SPOT BOT NO SUCTION

    Hey Courtney! Sorry to hear about the suction problem on your SpotBot. Here's a quick link to troubleshooting steps to assist you.

    http://www.bissell.com/FAQDetail.aspx?id=1040&cid=ccsocial

    0helpful
    1answer

    Automatic Clean on Spot Bot 1200 dosent work

    Ted, it can be bear when the auto settings aren't working. One of our service centers can inspect and fix any warranty repairs needed.

    To locate a BISSELL Authorized Service Center, please click on the following link:http://www.bissell.com/service-centers/&=ccsocial
    0helpful
    1answer

    Bissell pet green machine has no suction

    1) clogged in the hose , repair
    2)see if the belt is broken or worn, replace
    God bless you
    1helpful
    1answer

    Eureka pet expert vacuum lost suction

    I had the same problem with exact same vacuum, was working great and the one day just lost almost all suction in the hose and in very very poor suction on base when vacuuming carpet, also when vacuuming the carpet everything I vacuum shoots out the bottom and hits my feet, never happened b4, checked all hoses and tor apart every thing to see if their war dust in motor, clogging anywere but nothing everthing looked great, NEED HELP CANT AFFORD TO BUY ANOTHER VACUUM OR TO TAKE TO REPAIR MAN TO B CHRGED AN ARM AND LEG, SOMEONE PLEASE HELPPPP!!!!!!!!!!
    1helpful
    1answer

    Bissell Lift Off pet revolution vacuum losing suction

    You may have a clog in the hose. Unhook the hose and see how the suction is there, if ok, then check the dirt inlet by the brush roll. If suction is low at the hose, then there is a clog in it.
    Mar 20, 2008 • Vacuums
    Not finding what you are looking for?

    1,658 views

    Ask a Question

    Usually answered in minutes!

    Top Bissell Vacuums Experts

    Brad Brown

    Level 3 Expert

    19163 Answers

    Marvin
    Marvin

    Level 3 Expert

    85240 Answers

    David Shaub

    Level 3 Expert

    2994 Answers

    Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...