Question about KLH ASW10-120 Subwoofer

2 Answers

Sub woofer keeps blowing fuses

I just recently moved and now my sub woofer won't come on . I replaced the fuse and it came on for 5 minutes then went out. Ireplaced the fuse again and it blowes then immediatly. can you help please I really like this sub

Posted by 99maxima on

  • 1 more comment 
  • gene O Jan 01, 2008

    The original fuse was a 2 amp 250 volt T fuse. I replaced it with a 2 amp 250 volt fuse from Radio Shack and it keeps blowing the fuses,

  • Anonymous Sep 02, 2008

    I keep replacing my 2A 250Volt fuse, the second I plug in my subwoofer to an outlet it keeps blowing fuses. What can I do? Who fixes sub woofers for good prices?

  • carmonav Sep 24, 2008

    i have the same sub with the exact same problem, i have to agree its a great sub when working. if anybody has a serious solution please help out would like to keep it instead of replacing it with a definitive technology sub i have borrowed from a friend they have the same sound quality.

×

Ad

2 Answers

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

NO dont try a 3 amp fuse.It is made to BLOW if there is a problem. That sub is not worth fixing, JUNK it. There are a lot of problems with it. Such as heating up and melting the board witch could cause fires. Thats what happened to mine. Like I said JUNK it and buy a different one.

Posted on Dec 13, 2008

Ad

Anonymous

Try a 3 amp fuse

Posted on Jun 24, 2008

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

RCA RT2770 Sub-woofer sound doesn't come


The sub should generally have its own power supply, is it plugged in ???

Feb 16, 2016 | RCA RT2770 Theater System

1 Answer

Why does the fuse blow Instantly?


Link for the service manual: http://elektrotanya.com/pioneer_vsx-305_405.pdf/download.html On page 50 of the manual (36 of the pdf) it says for the "Sub woofer pre-out jack (Not available on the VSX-305 model) If you want to boost the low frequencies, connect to a subwoofer power amplifier" Your model will not drive a sub-woofer with out another amp. His sub may be a powered sub?

Aug 31, 2014 | Pioneer VSX-305 Receiver

1 Answer

What is happening to my sub woofer????? D: So I have the sony muteki HT-DDW1600 and have had for the past year. In that time it has served its purpose for many many house parties. Recently I noticed that...


If a fuse blows it won't self-heal when you cycle power.

Swap the subwoofers between the two subwoofer speaker feeds. Maybe it will stay with the channel or maybe it will follow the speaker and make next steps easier.

Jul 20, 2011 | Sony MUTEKI HTDDW1600 Theater System

2 Answers

Mirage s8 subwoofer is emitting a constant hum


that is just the radio from the input,its normal

Jun 19, 2010 | Mirage Prestige S8 Subwoofer Speaker

1 Answer

Alesis M1 active 620 woofer problem


There clearly is a fault in the sub's amp section. It's probably the main part that does most of the work. It will need to be replaced.

Mar 07, 2017 | Alesis M1-Active MkII Main / Stereo...

3 Answers

Athena AS-P4100 Sub Woofer - blown main fuse - who repairs these?


Sorry I can't solve your problem. I think the main fuse on mine is blown too. Can you tell me where it is located?

Mar 09, 2010 | Athena AS-P4000 Subwoofer

1 Answer

No sound


if the display is working your pre-amp is ok
check the sub-woofer
amplifier is in the sub-woofer, check fuse inside first
after that mail again, thanks

Feb 15, 2010 | Bose 3 2 1 GSX System

6 Answers

Dell MMS-5650 5.1 speakers not working


sounds like they are picking up interference. make sure they are grounded well.

Aug 19, 2009 | Dell 5650 Computer Speakers

1 Answer

Bose acousticmass 15 sub-woofer making a noise


The sub contains the amp for the other speakers. But it sounds like the amp has a seriously damaged section and will probably have to be serviced by Bose.

Jun 24, 2008 | Bose Acoustimass 15 System

1 Answer

Amp light is on but no power to my subs!


Hi There.

When you say the 40 Amp fuse blew. Was it your mains battery fuse or was it the fuse on the amplifier? If it was the fuse on the amplifier then you may have hurt the amplifier. The Kenwood KAC-8101D is a 1000 Watt monoblock amplifier. Therefore if you say that 1 of your woofers is not playing, then it is almost certainly blown if you are sure it is connected correctly. Try disconnecting it and only running the woofer that tries to play. If this woofer is still working correctly, you will notice a drastic drop if the sound of your bass. The reason for this is because you have changed the impedance load on your amplifier due to the fact that the other woofer is not working. Have your working woofer checked and replace the faulty woofer then you should be banging again.

Hope this helps!!

Jan 30, 2008 | Kenwood KAC-8101D Car Audio Amplifier

Not finding what you are looking for?
KLH ASW10-120 Subwoofer Logo

1,606 people viewed this question

Ask a Question

Usually answered in minutes!

Top KLH Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5700 Answers

The Knight
The Knight

Level 3 Expert

76407 Answers

Vincent G
Vincent G

Level 3 Expert

2363 Answers

Are you a KLH Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...