Question about Hoover Vacuums

1 Answer

My hoover steamvac spinscrub is losing all the clean water from the tank when it's off. The water tank on its own is holding water but soon as I connect it to the machine the water starts to drain out

Posted by Cesar Valentin on

Ad

1 Answer

Chuck Stillwell Jr.

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

The seal between the vac and the tank is bad,you can most likely get a replacement from manufacturer.

Posted on Aug 10, 2016

Ad

5 Related Answers

Geterdun

  • 184 Answers

SOURCE: replacing valve on water tank on hoover steamvac

buy the whole tank not worth the time to repair the valve

Posted on Feb 10, 2008

Ad

Anonymous

  • 3 Answers

SOURCE: hoover f5520 steamvac duo upright wet washer

Your problem is inside the vacuum hose where they have installed a small coiled hose that carries water to the smaller power head for upholstery. After taking this apart I found the inner smaller coiled hose was broken at 2 different places. A very poor design and poor quality material. The hose looked like it was rotted. This could be from old detergent left in the line or maybe the wrong detergent. A job to get it apart but if you remove the three screws that hold the side plate over the electrical you can block that hose off and the machine will work on floors only as the water to the power head is terminated.

Posted on Aug 16, 2008

Anonymous

  • 1 Answer

SOURCE: Hoover Floormate SpinScrub won't dispense cleaning liquid

I had the same problem and was preparing to take it back, the last thing I tried was to 'reseat' the handle -- I removed it then snapped it very firmly back into place. That did it, it's working beautifully now!

Posted on Feb 07, 2009

Anonymous

  • 2 Answers

SOURCE: recovery tank not working

recovery tank empty where do you look to see where the hair ball is so i can clean it

Posted on Apr 04, 2009

dbqsaints

dbqsaints

  • 1 Answer

SOURCE: Hoover Steamvac hose won't spray water

SOLUTION#1 If the attachment wont spray water, the white plastic nozzle tip may be clogged. Take the brush attachment off, remove the two screws from the gray retaining cover (BE CAREFUL THE WHITE TIP UNDER THE BLACK PLASTIC TRIGGER MECHANISM IS SPRING LOADED and WILL GO FLYING). The trigger mechanism can be taken apart by lifting the black part off (may have to slide it back slightly), remove the spring from the white plastic valve insert, then take a flat screw driver and carefully pry the two white pieces apart and blow out both ends. You may have to find a hair size piece of wire to push threw it to clear it. The whole process is really simple once you take it apart and see how it works. Putting it together is in reverse order. The white piece will only go in to the black part one way and with the spring on you need to push it through the hole and the trigger part hooks on, slide it back on to the hose, then while holding it all, and put the gray retaining cover back on. Sounds more difficult than it really is. If your not mechanically inclined take some pictures as your taking it apart to refer to.
Solution#2 If the nozzle and trigger are clear, with the trigger assembly off the hose, plug the hose into the shampooer and turn it on (if the hose inside the suction hose is clear you should start seeing water flowing out the hose. If not run a piece of wire through that hose to unclog it. If its still not flowing then the Pump on the unit needs to be replaced.
Solution #3Cost Around $20 with shipping online. Google your make and model, and upholstery attachemnt pump. Mine was called AP4561692 (43582018) PUMP ASSM, from http://www.appliancepartspros.com/. (there real good about the live chat and helping you find the part).There are Youtube videos on taking apart the shampooer, which is pretty easy. The one place that might give you problems after you get down to taking the pump off, there is only one screw holding but there is on the bottom side of the pump a black bump that clips in to the base of the shampooer and you need to stick a screw driver from the bottom up and pry the base one way and pull the pump the other to unhook it.

Posted on Feb 16, 2012

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Does it heat the water? when I empty the holding tank the water appears not to be hot.


I believe it does not heat water. you put hot water in w/cleaning solution. it is cool by time you empty holding tank.

Sep 03, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

There are two containers, where do I put the water and solution


The upper tank holds the cleaning solution. Mix 5 oz. of Hoover detergent to 1 gal. of hot water. The line on the tank indicates 1 gallon.

Apr 10, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

My SteamVac SpinScrub works fine then all of a sudden, the noise level of the vac seems higher and does not **** up water. I turn off vac then turn it back on, works good for awhile, then noisy, higher...


It sounds as if the ball in the tank in shutting down the suction prematurely. Be sure there is a gap of about 3/4 inch between the top of the filter inside the tank, and the lid of the dirty water tank. Without this gap, suction will pull the ball up too soon.

Apr 04, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

The suction stopped working after emptying dirty water and filling up with new water and cleaner


I have an older Hoover SteamVac Supreme #F5815 and I'm having trouble figuring out how to clean the part in the front that the dirty water goes thru before it gets to the tank. How do I clean it?

Mar 06, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

I have a Hoover SteamVac SpinScrub. The brushes


If the speed control switch on the hood is in the On position, it would appear the drive mechanism for the brushes is not spinning internally. The drive mechanism could easily be replaced by a technician.

Oct 03, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

How to clean my Hoover steamvac brushes? or


http://www.hoover.com/pdfs/manuals/F5914900.pdf

Press all four latches (B) and pull brush
block out. The brushes can be cleaned
under running water

Godbless

Jun 14, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

I don't know where to put the water?


The clean water goes on top. You want to check your bottom tank and make sure the lid is not lose.

Jun 11, 2009 | Hoover SteamVac F5914-900 SpinScrub...

2 Answers

Recovery tank not working


recovery tank empty where do you look to see where the hair ball is so i can clean it

Mar 28, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Hoover Steam Vac Deluxe Wont **** up water?


we can not as that type fix needs to be hands on not wireless

Dec 15, 2017 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

HOOVER STEAMVAC CLEAN SURGE


The tank lid is not securely shut. Or you have stopped up machine full of carpet lint and dirt. Take it apart starting with the lid and make sure its locked down good if that isnt it ..clean out your machine.

Oct 18, 2008 | Hoover SteamVac F5914-900 SpinScrub...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

84 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Brad Brown

Level 3 Expert

18438 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

Mike

Level 3 Expert

4369 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...