Question about Olympus SP-350 Digital Camera

Open Question

Camera was working fine then the screen went blank and no longer sees anything through the lens. The camera is fine otherwise

Posted by Martyn demers on

Ad

5 Related Answers

poolseman

zdenek vajdak

  • 206 Answers

SOURCE: Blank screen

This sounds like CCD sensor is faulty and should be replaced . Camera works fine in playback mode generally with this problem but not in capture mode ( camera has gone 'blind'). Should be repaired free of charge if the camera is as old as you say.

Posted on Sep 04, 2007

Ad

Anonymous

  • 1 Answer

SOURCE: FE 170 OLYMPUS digital camera

its fucked up olympus sux i bought a sony cybershot 4000000 times better than that trash fe-210.
i trashed it destroyed it mutilated it till it begged for mercy

Posted on Dec 03, 2007

Ad

Anonymous

  • 919 Answers

SOURCE: olympus D-510 camera, lens won't extend at all

Sounds as if it could be an issue with the sensor behind the lens cover door. Unfortunately Olympus is no longer repairing this camera. You may want to call their customer service to discuss what your options are at this point. Their telephone number is 800-622-6372 option 2 and then option 3.

Posted on Mar 09, 2009

Anonymous

  • 919 Answers

SOURCE: olympus stylus 725 SW has gone blank

The problem you are describing is a problem with one of the chips in the camera that controls image processing. It seems to have failed and needs to be replaced. Following are the instructions to send your camera to Olympus for service.

http://olympusamerica.com/cpg_section/cpg_servicerepair.asp

Olympus will charge a flat rate repair fee for this product if beyond the one year factory warranty or the warranty is voided. The cost is $128.85 plus your local sales tax. This covers parts and labor, factory cleaning and diagnostic check, 6 month warranty and the cost of shipping the product back to you is all included in that price.

Posted on Apr 07, 2009

fikretunalir

FIKRET UNALIR

  • 239 Answers

SOURCE: Lens not working

662a046.jpg
How to put the lens mechanism of the camera to its own place?
1. Turn off the camera.
2. Remove your battery and memory card.
3. Unscrew the screws and open the back cover of the camera.
4. Unscrew the screws of the main board.
5. Remove the lens mechanism.
6. Be careful not to touch the rear part of optic parts for protecting to the fingerprints and not to cut the wiring system.
7. Take out the lens mechanism and watch the lens roads. Is there any broken parts around there? If not it is a good news. Then go on to look carefully around the lens mechanism. Is there anything looking unusual? But if you have unusual noise that has two meanings.
a. There is a dust in the lens mechanism. Then it is very easy to fix it. In this position you should give a pressured air to clean it. And collect the camera parts together.
b. There are some broken parts in it. Then there are two solutions.
(1) Give pressured air to clean it. It is easy and does not need to change any part. Go on from 8.
(2) Lens mechanism needs to be changed. Buy new lens mechanism or find it from one of second hand and out of order cameras. Go on from 8.
8. If there is nothing looking unusual, take the lens mechanism to your hand. Then control its move while sliding it slowly and carefully.
9. Collect the camera part as you have unscrewed.
10. Install the memory card and battery.
11. Turn on the camera. Try to focus on any subject specially on the mode that you recently faced with.

Where can you buy a new lens mechanism and how much does it cost?
1. If you need to change the lens mechanism, then you can buy it from http://www.ebay.com
2. Open this address and write to the search box the item number:170482444552
3. You can see the price of this item there. If it is suitable for you then buy it and change it as I said above.


I hope it is helpful.

Posted on May 08, 2010

Testimonial: "Very Thorough. I have not got to try it yet, because I have not had time, but I will defintely try and also take the advice to a repair man, if I can't do it myself."

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1helpful
1answer
0helpful
1answer

Dsc w310 display white but camera working...any kind help please..??

Hello

White screens or screens with similar issues (black, "staticy") are indications that the CCD sensor has failed. It is the image sensor that the camera sees with. The camera itself may be operating just fine otherwise, but you can no longer see anything (as the camera can not) via the LCD screen (as it is relaying what the CCD sensor sees).

Unfortunately, your camera will have to be repaired. However, with a camera of that age, you may be better served by purchasing a new one, which will have more features for around the same price as a repair.
Mar 11, 2011 • Cameras
0helpful
1answer

When turning on camera, blinking red light and blank screen - replaced batter and charged it but still blank screen.

Hi Steven its look like Memory card or Lens error. Just try this below and let me know the result.

1. Ensure batteries are fully charged & clean the battery connector point in side the battery compartment.
2. Look carefully between the lens and the camera body for any sand, dirt or any damaged etc.
3. Try turning the camera with the lens facing down and shake to dislodge anything stuck
4. Try removing batteries and memory card, wait 5 minutes and refit the battery only.
5. Now turn on camera( with out card ) and see ,if working then fix the memory card & again turn on the camera. If working then fine . Otherwise format the memory card and fix back in camera again & try. Make sure before format the memory card take a back up all photos in your computer then format. If no luck then reset or restore the camera setting by pressing Menu key for 2 sec .. in not done the press both Menu & self time key for 2 - 4 sec.
i hope it will gives you success.
1helpful
1answer

Took a few photos, switch off, 5 minutes later switched back on, blank screen but can view playback and menus

Hi there please follow the steps and let me know the result.

1. Ensure batteries are fully charged & clean the battery connector point in side the battery compartment.

2. Look carefully between the lens and the camera body for any sand, dirt or any damaged etc.

3. Try turning the camera with the lens facing down and shake to dislodge anything stuck

4. Try removing batteries and memory card, wait 5 minutes and refit the battery only.

5. Now turn on camera( with out card ) and see ,if working then fix the memory card & again turn on the camera. If working then fine .
Otherwise format the memory card and fix back in camera again & try. Make sure before format the memory card take a
back up all photos in your computer then format. If no luck then reset or restore the camera setting by pressing Menu key for 2 sec ..
in not done the press both Menu & self time key for 2 - 4 sec.

0helpful
1answer

Screen is blank but still takes pictures fine

Try removing the battery or reseting the unit if there is a reset button. Otherwise it sounds like the screen died.
0helpful
1answer

Camera lens does not retract & view finder is just blue, will not go to other screens

The lens maybe out of track. Perhaps you have bumped the camera or dropped it. Look if the lens are a bit tilted, if so, try straighten the lens with your fingers, very gently. Hope it works.
0helpful
1answer

Protax DC500T Digital Camera lens won't open

It will need repairing.
Thanks,
Lee
Jun 17, 2008 • Cameras
0helpful
1answer

No image coming through on my cam

Dear Daeva,
CCD Imager of your DCR-TRV33 got defective due to unknown reason. You should go to nearest Sony service shop for replacement of faulty part.
0helpful
1answer

Aperture problem

you might have the lens on incorrectly .
or bent /jammed the small bar that inserts with the lens.
take off the lens and look at the little silver /black bar that sticks out the back does it move easily and look at he corresponding lever in the front to the camera
0helpful
2answers

Camera lens error

i need help. i have the same problem. i had my kodak easyshare 853 for about 4 days and it turns on saying kodak easyshare and then it just has a blank screen and turns off by itself. please help. and yes my screen is tilted sorta. but im havin a hard time getting it to go back in place.
Not finding what you are looking for?
Olympus SP-350 Digital Camera Logo

Related Topics:

96 views

Ask a Question

Usually answered in minutes!

Top Olympus Cameras Experts

Steven Wander
Steven Wander

Level 3 Expert

596 Answers

Ekse

Level 3 Expert

13435 Answers

Cindy Wells

Level 3 Expert

6412 Answers

Are you an Olympus Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...