Question about Pyle Dryver PLAD213 Car Audio Amplifier

1 Answer

Pyle dryver amp light protection stays on not green light stays red i have tried to disconnect everything and plug it back up but light stays red

Posted by keith_ric699 on

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Check your subs disconnect them the try to power the amp up if it powers up the the subs have died and it could be a problem with that amp i suggest you get a better amp

Posted on Jul 11, 2009

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Tc 8001 red light


on some amps there is a duel light. red and green usually. red means it is in protect mode or you didn't hook up your remote wire. if in protect mode, it could mean a number of things. did you hook it up with speakers and everything?

Mar 01, 2012 | MTX Thunder® TC8001 Car Amp

1 Answer

I cannot stay connected to internet, my model 2701HG-B 2wire at&t dsl will start flashing red then disconnect me from the internet or my game site, how can i get this to stay fluently connected please!


You might want to try disconnecting everything EXCEPT the power cord. If you still get the red power light (it should stay there forever) then bring the gateway to Radio Shack or somewhere they have a 5 volt DC @ 2 amp power supply and plug it in for 5 to 10 minutes and see if the power light then stays green. If it stays green then all you need is a new power supply! If not, then the gateway is fried. Mine keeps going from a solid green power light to a flashing green power light and I can hear a relay click every 2 minutes at which time a pop-up say "ethernet line disconnected". I tried new power supply etc. to no avail! It is fried after 1.5 years! No more 2wire for me!

Sep 28, 2010 | 2wire 2700HG-B Router (2700HGB)

1 Answer

Red protection light stays on all time....


try disconnecting one at a time each speaker till the red turns to green. One of your speakers may be bad. Amp is just telling you that its clipping and overheating due to the change in ohms of a shorted or bad speaker. Its also possible the amp is on its last leg due to heat. Heat breaks down electronics part and eventually get worse.

Apr 05, 2010 | Car Audio & Video

1 Answer

Amp not working


I had a similar problem with a pyle amp. try to disconnect the speakers and turn it on if the protect light doesn't come on then you might have blown something in your amp and it needs to be repaired. For my situation it was a blown resistors and only 1 channel worked. If you don't have soldering experience then I wouldn't bother trying to fix yourself, an unsteady hand can ruin your repair.

Mar 26, 2010 | AudioBahn A8000T Car Audio Amplifier

1 Answer

AMP LIGHT STAYS ON PROTECTION


shorting out check your speakerwires, or a bad speaker, remplace them

Jul 09, 2009 | Pyle Dryver PLAD213 Car Audio Amplifier

1 Answer

LIGHT RED PROTECTION


missmatched impedance, insufficient grounding or blown transistor/other internal problem within the amp.

Jul 09, 2009 | Pyle Dryver PLAD213 Car Audio Amplifier

2 Answers

My amp stays in protection mode


Does it go into protect in the vehicle if you disconnect the speaker wires from the speaker terminals of the amp?


Nov 29, 2008 | Sony XM-2002GTR Car Audio Amplifier

1 Answer

Amp shut down no power


If the red light is the protection LED, the amp probably has shorted output transistors. Read through the following page to eliminate other possible causes.

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Nov 13, 2008 | Pyle (DBPLA2480) Car Audio Amplifier

2 Answers

Protect led light


It appears that the amp is going into protect mode. To eliminate external causes, read through the following page. Let me know if you have any other questions.

Amp in Protect Mode - Troubleshooting

Oct 10, 2008 | Car Audio & Video

1 Answer

1200 watt legacy amp not working right


your amp its protect by releas of [powerout]one this releys is dead you mast chenche

Apr 14, 2007 | Pyle Dryver PLAD213 Car Audio Amplifier

Not finding what you are looking for?
Pyle Dryver PLAD213 Car Audio Amplifier Logo

297 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyle Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5023 Answers

The Knight
The Knight

Level 3 Expert

76466 Answers

Sheldon Dedek

Level 3 Expert

912 Answers

Are you a Pyle Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...