Question about Homelite Pressure Washer. 2700 psi 2.3 GPM Gas Pressure Washer

1 Answer

The machine starts up fine runs slightly rough for about 10 secondary then smooths out and runs for about another 10 seconds and cuts off. It will restart fine the same way after about 5 seconds. Drained and replaced the year old gas and removed and checked the carb bowl no water. Oil was overfilled by previous owner so I drained down to proper level. What am I missing? ,Thanks

Posted by Robert Call on

Ad

1 Answer

sgtstrat

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 34 Answers

Sounds like the carb is clogged with oil. Clean the carb and clean the fuel filter.

Posted on Jun 11, 2014

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Motor fires up fine runs slightly rough for about 10 seconds then smooths out for about 5 seconds and cuts off. Will start right back up after about 5 seconds and does the same thing. I have drained the...


Previous owner had way overfilled crankcase oil. Oil had gotten into carb and clogged air filter. Drained oil to correct level. Ran engine but kept cutting off-see above. Took off carb cover cleaned housing and ran without air filter-ran fine. Unsuccessfully tried to clean air filter with gas-did not work. Apparently, the engine could run just long enough to exhaust the air in the old filter and cut off which is why it would start back up after a few seconds. Bought new air filter-whole thing-about $15 at Carquest. Put in some carb cleaner and installed the new filter and it runs perfectly.

Jun 10, 2014 | Homelite Pressure Washer. 2700 psi 2.3 GPM...

1 Answer

Fuel system running rich and stalling


Sounds like it is slightly out of time.

Apr 14, 2014 | Ford Cars & Trucks

1 Answer

My 91 Chevy s-10 2 wheel drive p/u w/2.5 four cylinder wont idle and runs rough when i rev the motor which the only way i can keep it running is to feather the throttle. If i unplug the vacuum to the


the problem if from the map sensor.. when you change it it will run rough and keep cutting off,, keep stating it back and reeving over and over as soon as it cuts off again keep repeating until the CPU gets calibrated with the new sensor and it starts idling smoothly..

Dec 30, 2012 | 1991 Chevrolet S-10

1 Answer

I have a 10'' table saw


If it cuts straight it's fine. It's likely just some play in the bearings. I wouldn't worry about it unless it starts to cut not so straight...

Oct 06, 2009 | Craftsman 10" Table Saw

Not finding what you are looking for?
Homelite Pressure Washer. 2700 psi 2.3 GPM Gas Pressure Washer Logo

393 people viewed this question

Ask a Question

Usually answered in minutes!

Top Homelite Garden Experts

bryan st

Level 2 Expert

123 Answers

Randy Schumann
Randy Schumann

Level 2 Expert

410 Answers

colesmowers

Level 2 Expert

40 Answers

Are you a Homelite Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...