Question about Sony Xplod XM-554ZR Car Audio Amplifier

Open Question

I removed the faceplate now nothing works - Sony Xplod XM-554ZR Car Audio Amplifier

Posted by Anonymous on

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

2000 Lincoln town car a/c heater faceplate doesn't light up or work

Hello Jill,

When the faceplate does not light up, you will need to replace the faceplate.

Here is an option: https://amzn.to/2FpcCPc

You may have a chance that one of the wires may be loose. You may need to remove the faceplate from the dash, and remove the module to see if any wires are loose.

Make sure to wear rubber gloves (non-conductive) and remove the battery terminals so that it will provide safety.
1helpful
1answer

After removing faceplate on hallway controller two wires crossed and sparked after replacing faceplate nothing worked. checked breaker outside and nothing has been tripped now what

Double check your breakers, shut them all the way off, then back on. Sometimes when they trip they don't move much and they can be easially missed. Resetting all of them will let you know if it really isn't a breaker. If it isn't, it sounds like you may have broken or fried a wire somewhere. This can be very dangerous. I recommend calling an electrician to troubleshoot asap.
0helpful
1answer

Garmin Nuvi won't turn on

See if you can find the reset button on the unit and push it while the unit is on. On newer units the reset button is on the back, but on older units it may have a faceplate cover around the edge of the screen you have to remove and the reset button is sometimes located under the faceplate...this may work
0helpful
1answer

Pioneer deq 7600 display went black today the eq works fine.

the faceplate contacts may need to be cleaned. remove the faceplate, and using an eraser, clean the metal tabs on the main unit and rear of the faceplate.
If this doesnt remedy the problem, service is required. May be the light unit in the faceplate.
0helpful
1answer

Faceplate not working

is any sound coming out to the speakers
0helpful
1answer

Power on, but just show logo, then turn off immidiately.nothing change after I remove faceplate and reset

Have either of you tried charging this via the USB connection on your computer? Sometimes this helps. Give it a try.
0helpful
1answer

Functions do not work even after resetting.

try cleaning the faceplate pins on the faceplate and the deck with alchool and q-tips, that dont work id start with peanuts :-)

Don
Not finding what you are looking for?
Sony Xplod XM-554ZR Car Audio Amplifier Logo

Related Topics:

56 views

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

The Knight
The Knight

Level 3 Expert

76823 Answers

 Grubhead
Grubhead

Level 3 Expert

5720 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...