Question about Creative Labs Zen Nano Plus MP3 Player

1 Answer

Won't turn on

I have a Creative Zen Nano Plus MP3 player and it won't turn on. I've checked the batteries......nothing I do will turn it on. Any ideas?

Posted by Amara on

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Well, if you are new to the creative zen Nano plus, you may not have figured out how to turn it on. hold the play/pause button until the mp3 lcd screen lights up and that should work. if this is not the case i am sorry i cant help, but i also have a creative zen Nano Plus so i could find out for both of our benefits. i hope i helped!

Posted on Nov 24, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Mp3 won't turn on

I do have the same problem. When i turn it on ti would simply turn 'ON' and on the screen it would write CREATIVE, and nothing could be done. no buttons work at all! please help!! 
0helpful
1answer

Zen nano plus

Change the battery, or send it to somewhere to get it fixed.
0helpful
1answer
0helpful
2answers

Mp3 player Creative Nano 1GB

try downloading the MP3 player recovery tool from Creative's website (the tool contains the latest firmware update available -- 1.15.03). Plug your ZV+ into your PC, run the program and let it update the firmware. Then format, reload your music and try it.
0helpful
1answer

My mp3 won't start.

You could try reflashing the firmware onto the player. Go to www.creative.com and look for the support section. Search under downloads for firmware for your player and download that. Follow the instructions on the website.
0helpful
1answer

ZEN Nano Plus 512 MB HELP ME!!!!

upgrade the firmware
http://us.creative.com/support/downloads/

1helpful
2answers

Zen nano plus mp3 player 1gb

I`ve had the same problem twice, it seems the player erases the whole firmware when this happens. You can fix this by plugging it to your computer in recovery mode, this will allow you to reinstall firmware.(Search google for zen nano plus recovery mode to find instructions.)
0helpful
1answer

My mp3 player is broen HELP ME!!!!!!!!!!

I`ve had the same problem twice, it seems the player erases the whole firmware when this happens. You can fix this by plugging it to your computer in recovery mode, this will allow you to reinstall firmware.(Search google for zen nano plus recovery mode to find instructions.)
7helpful
7answers

Creative Zen Nano Plus FROZEN!!!

here is a fix if your creative zen nano plus just hang on the creative logo when you turn your player on.
download, Creative ZEN Nano Plus firmware.
you can find it at the creative website, download section.
double click the file you just dl'ed, now make sure your
zen nano player is already connected to your pc when you run the file. it may take a bit of time before your pc can detect your zen nano be patient, a window prompt will soon appear asking if you want to update your firmware with the one youve just dl'ed.
now, dont worry if the firmware is the same as the one already
installed in your zen nano, just continue with the update.
you can also check the box in which there is the option of also formatting the drive. ( note: all files in your zen nano will be lost)
after the firmware is flashed you can now play and transfer files to your zen nano plus.

0helpful
1answer

Creative Zen Nano Plus uncooperative!

Write to Creative's Helpdesk... So did I for the same problem. I'm waiting for their answer.
Not finding what you are looking for?
Creative Labs Zen Nano Plus MP3 Player Logo

Related Topics:

221 views

Ask a Question

Usually answered in minutes!

Top Creative Labs Audio Players & Recorders Experts

Ekse

Level 3 Expert

13435 Answers

Brad Brown

Level 3 Expert

18821 Answers

Jean Sintulaire

Level 3 Expert

759 Answers

Are you a Creative Labs Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...