Question about Crate FlexWave FW15 Guitar Amp Combo, 15 Watt Single 8 Speaker

2 Answers

Crate flexwave 120 head sound cuts out

I purchased a Creat Flexwave about 6 or 7 months ago, while I was in a band. As soon as it showed up the band broke up. So I set it up and have beraly played it. A couple months later I plugged it in, and the sound started cutting out. I thought it may be the cables I was using. Bought new ones. and still the sound is srisp and then it looses its highs and alot of its sound. I played with the knobs and when i push in on the faceplate or push on the knobbs the sound comes back full force, but when i relese pressure the sound goes away. It driving me quite crazy. any ideas?

Posted by persistantli on

  • persistantli Jun 07, 2009

    I couldn't find my product so i just selected one of the crates on the list

×

Ad

2 Answers

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

I also have this same problem, it really is upsetting. I traded alot of instruments Epi Special 2, Schecter Damien b-2, jackson RR v, B.c Rich warlock, an older beringer tube amp, and a ibenez weeping demon pedal. For a crate flex wave 120h (half stack) i had it for bout 2 months nothing wrong then all of a sudden, i turn it on and volume fluxes up and down on its own i also notice the reverb cutting in and out when this happens. I cant use warranty because even though owner of the store gave me registration card for it, he never gave me a receipt cause it was a trade in, so i cant send it away. Also just like this guy said when you press in on a knob (any knob, not just the channel you are on, it will go to full volume again. I am puzzled at this problem and searched on the web for days not much on the subject. I only use for practice never leaves volume of 4, never gigged never moved. I would like to maybe fix this problem as now i feel stupid for trading all that gear for an amp don't want to loose this amp. Also it was a brand new amp not preowned. Please Help......

Posted on Mar 08, 2010

Ad

Michial Gueffroy

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,140 Answers

You have a broken solder joint. You'll have to disassemble the amp enough to get at the soldered side of the circuit board that the controls are mounted to and touch up any suspect solder joints. Just be sure to resolder only the joints that were originally soldered or need to be soldered. Hope this helps.

Posted on Jun 08, 2009

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I am looking for the proper fuse needed for this amp. I keep purchasing the wrong ones


The fuse rating should be printed on the panet right by the fuse holder. If there's still a question about values, you're best bet is to contact Crate customer service.
Here's the link-
http://www.crateamps.com/support
However, if you're meaning that you keep blowing fuses and therefor think you're instaslling the wrong value, you may have a short in the amp that's casuseing the fuses to blow. In that case, it needs to go to the shop. If you're not a tech, don't poke around inside it. You can make the problem worse, or even get a nasty shock.

Mar 31, 2016 | Crate FlexWave FW120 Guitar Amp Combo w...

1 Answer

Crate flexwave 120 head effects malfunctioning


That is probably a momentary switch that is dirty and sticking. These onboard effects on guitar amps are usually nothing more than a computer sound card and I've found bad connections going to and from them as well. I do think that switch is dirty and sticking, though.

Feb 19, 2013 | Crate FlexWave FW120H Guitar Amp Head with...

1 Answer

I bought a Xenyx 1202fx roughly 9 months ago. I plugged it in following the instructions of desk to pack first, then pack to mains, but the LED display didn't show. I've heard that there's no...


If the blue power light does not light up then there is a problem with the unit or power supply. As it is less than a year from purchase I would advise returning it to the shop.

Sep 15, 2011 | Behringer Xenyx 1202fx Mixer 12 Input 2...

1 Answer

Flexwave 120H Speaker wire shorted amp won't work


Solid state amps are very subject to blowing out the output transistors if speaker leads get shorted. Take it in for repair.

Aug 31, 2011 | Crate FlexWave FW120H Guitar Amp Head with...

2 Answers

Crate flexwave 120 tuner and all effects stoped working


Hi there,I have the same problem with my flexwave 120. I opened the amp to measure several capacitors on the small effect circuit board. If one of this capaciters have internal short circuit, wich will effect the others causing effects to fail. I removed them one by one to find possible short circuit. All capacitors were ok. I think the problem is in the processor wich is to diffucult to replace. I think it's easier to replace the effects circuit board. But where do we find this board??10_29_2011_6_25_35_am.jpg

Aug 07, 2011 | Crate Flexwave Fw120h 120 Watt Head Dsp...

1 Answer

Basically i cannot seem to make the pedal work in tandem with my crate flexwave 120w 2x12 dsp amp i prefer to use the built in dis,chorus, and delay effects but can find no way to put the hb01 behind the...


Norrmally you run the guitar into the pedal and then into the amp. IF you want it behind the built in effects, The look on page 6 of your users manual showing the special cable you will need to do the "insert" of your effects pedal.
If you don't have a manual, download it here:

http://www.crateamps.com/pdf/manuals/FW120H_OM.pdf

Jan 11, 2011 | Behringer HB01 Hellbabe Wah Pedal

1 Answer

Crate Flexwave 120h (Half Stack) volume issues


Perhaps you have a bad capacitor on your volume control?

You can get an ESR meter and test your exposed isolation caps for leakage? The have to be removed so unplug the unit if you are gonna do any work inside the cabinet.

Also, try a shorter or higher quality guitar cable. This will cut impedance between the pickups and the amp.

Good luck and be careful!

Mar 08, 2010 | Crate FlexWave FW15 Guitar Amp Combo, 15...

1 Answer

Plugging line level into my crate TX15. all inputs sound distort


guitar amps are all set to a low Z resistance configuration. wich are made for guitar only. make sure you are using the right cables.
you need sheilded guitar cable not unshielded speaker cable in many cases these cables look exactly the same. look at your cable look for the words speaker or instrument. you need the instrument cable. if you still have that problem. then you may just not be satisfied with the quality of the amp it self.

Feb 26, 2009 | Crate FlexWave FW15 Guitar Amp Combo, 15...

Not finding what you are looking for?
Crate FlexWave FW15 Guitar Amp Combo, 15 Watt Single 8 Speaker Logo

883 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crate Music Experts

Brad Brown

Level 3 Expert

18596 Answers

Ngoro

Level 3 Expert

3085 Answers

ray gallant

Level 3 Expert

71004 Answers

Are you a Crate Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...