Question about Tannoy Fusion TS10 Speaker

2 Answers

Power Problem Tannoy TS10

My Tannoy TS10 seems to have no power getting to it. I've changed the fuse in the plug but no joy. Any ideas?

Posted by Brido on

Ad

2 Answers

berggei

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Loyalty:

    Visited the website for 30 consecutive days.

  • Expert
  • 65 Answers

Check the bipolar capasitor C100 on power amp module. Also Check C101 on same module.

Posted on Jan 19, 2016

Ad

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Have you checked the power supply. Maybe it has died.

Posted on Apr 18, 2009

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My sanitop is not working. i've changed the fuse but no joy. can the motor be burnt as it may have been on for a while since my son left the tap running


If anything goes wrong with the unit it usually happens in the pressure chamber, the motors are very durable, any part in there can be replaced. Im thinking the capacitor might have seized up and will probably need to be replaced.

Sep 20, 2012 | Saniflo SaniPlus-Round SaniPlus Macerator...

1 Answer

How do I replace a fuse in the Tannoy TS10 Subwoofer


The fuse is located under the AC input cable. Pull out the cable and you'll see there is a slot that will fitt a flat screwdriver. Pull this out and you'll find the fuse.

Jul 21, 2012 | Tannoy Fusion TS10 Speaker

1 Answer

The multi tool has stopped working, there seems to be no power, I;ve changed the fuse. still not working


THE PLUG MAY BE BAD OR THE CORD. IF YOU CHANGED THE FUSE, YOU SHOULD BE ABLE TO TEST FOR POWER,AT OR AROUND THE FUSE..THIS WILL TELL YOU IF THE CORD IS BAD.. JAY THE POOL PUMP REPAIR GUY IN LONGWOOD FLORIDA

Jun 20, 2011 | Garden

1 Answer

Came home and there was no power to my Logitech z-5500 speakers. Have changed fuse and power cable, still no joy any ideas


i have this same problem, i dno what the heck happend to my speakers. i tries changing the fuse in the plug, and also the timer fuse in the sub itself... stil no fix... im still getting no power to any of the units... the standby light doesnt even come on.

Dec 20, 2010 | Logitech Z-5500 Computer Speakers

1 Answer

My Tannoy TS10 keeps blowing fuses and I get no power signal on the LED


Something inside it is acting like it was just a piece of wire instead of doing it's job. That's why the fuses blow. Look at either the power supply section - transformer, diodes, voltage regulators. OR the main output devices. If they are transistors, you can test them with a ohm meter. The part will show up easy! It will be just like you had just touched the two probes together!!

Mar 20, 2010 | Tannoy Fusion TS10 Speaker

Not finding what you are looking for?
Tannoy Fusion TS10 Speaker Logo

Related Topics:

1,250 people viewed this question

Ask a Question

Usually answered in minutes!

Top Tannoy Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5700 Answers

Andrew Taylor
Andrew Taylor

Level 3 Expert

31566 Answers

Trippy Tripp

Level 2 Expert

194 Answers

Are you a Tannoy Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...