Question about Eclipse Premium 34230 Car Audio Amplifier

1 Answer

Eclipse 34230 no base

Just got hold of the amp and installed it, but the sub is not really being moved i've read that this amp is really powerfull. i have one xtant 12". the amp prior to this was a ppi pcx280. what am i doing wrong here i had the other amp bridged but i guess you cant with this one so where am i going wrong? also all the settings are on max...

Posted by saleen14 on

Ad

1 Answer

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If the woofer isn't moving significantly, try the following settings:

gain at highest (most sensitive) setting

crossover at highest frequency

subsonic filter at the lowest frequency

If those do nothing and you have a dual voice coil woofer, you may have one coil reversed. If you disconnect one voice coil and the woofer moves significantly more, check the polarity of all speaker wire connections.

Here's a brochure for the amp:

http://cartoys.com/cartoy/pdfs/eclipse_amp_manual.pdf

 

You're correct. this amp cannot be bridged to produce more power. It's minimum safe load is 4 ohms per channel. It's essentially two bridged amps in one chassis.

Posted on Oct 16, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Are xtant 604x sub amp


yes that is a badass amp do u wanna sell it

Feb 26, 2010 | Xtant X604 Car Audio Amplifier

2 Answers

One sub works other doesn't


Disconnect the wire from the speaker and meter it out. check it for a dead short, the meter would read 1..... You can also check the action of the sub by pushing on the center lightly, moving the cone. If it's blown, it will not travel smoothly. If your meter reads ......1 then you've really done it and totally cooked the wire clean thru, thus no resistance. Hope this helps.

Sep 29, 2009 | Xtant A3001 Car Audio Amplifier

1 Answer

I am trying to install my xtant 604x after i just had it sent out and repaired. I have 4 rca's coming from the head unit wired to the amp as FL, FR,RR,RL. The front speakers connected to the front output...


CLICK HERE for your Owners manual in PDF format
CLICK HERE for your Installation Guide in PDF format

As we agreed in chat - you are going to run your 4 channel amplifier as follows...

Front Channels of amplifier will run left and right independently.
Wire up the left speakers in parallel all + together and all - together.
This will yield a 2 Ohm load.

To the Same with the Right Side speakers - on the FRONT Right channel of the amplifier.

Now you have a 2ohm stereo load on the FRONT channels of your amplifier.

And using the BRIDGED nomenclature on the REAR channels of your amplifier - wire up your 4ohm sub mono.

Here is a crude drawing for a visual

589d9af.gif

Thanks for using FixYa - a 4 THUMB rating is appreciated.



Sep 05, 2009 | Car Audio & Video

2 Answers

Just got this amp, and was wondering what subs I should get with this amp


Did some research and it sounds like a wicked lil amp with clean clean sound-its hard to say what subs to tell you to run because everyone has different taste- and without knowing what your setup is going to be theres no real way to actually say-the amp is made to run 3 channels -so focusing on the sub channel only i personally say get a pair of 10s or a good 12-your not throwing a ton of power so you dont have to go balls out on the subs- i personally like MTX subs and xtant is made by MTX so that wouldnt be far from home -good luck with that

May 19, 2009 | Xtant 403A Car Audio Amplifier

1 Answer

Send me info how to connect a 4-channel car amp with 2 12-inch subs rear and 2 front 2-way speakers?


plug two subs in to amp in most powerful channel then your speakers in the less powerfull take your positive from your battery and hook it to your amp your ground wire shud just touch a solid piece of metal take your remote wire and hook it to your deck all other wires shud be with your deck need n e thing else holla

Apr 19, 2009 | Car Audio & Video

1 Answer

How do you make two dvc subs run at one ohm and put them to a 2 ohm mono block


Make sure your amp is one ohm stable. If you wire the subs at one ohm and the amp is not a one ohm stable you run the risk of blowing the amp if not both the amp and the subs

Sep 22, 2008 | Xtant A3001 Car Audio Amplifier

1 Answer

One sub working other is not


Lets narrow it down.

You've go two speakers, one works, one doesn't.

First off, switch the connections on the speakers.

- Good to bad
- Bad to good

Now, if the one that wasn't working, starts working: The speaker is OK

If the one the was working, still works: The Amp is OK

If the one the was working, stops working: Either the amp input for that channel has been compromised (check connections), That side of the amp is blown, or possibly (long shot) the heads balance is all the way to one side.

If they both are working: It fixed itself!!

Hope this helps locate the problem

Mike

Jul 15, 2008 | Xtant A3001 Car Audio Amplifier

1 Answer

Hi, i have jbl 1201.1 running 2 audiobahn aw1200v subs, i used to have 2 jl audios but the amp blew them, when i turn up to about 32 volume the subs cut out, they come on and off, amp doesnt go into...


well first off the cap should be reading 14.00 volts not 12 but check on ur settings maybe its to high if that dont work then ur amp or amps is way to powerfull for those sub or theres not enough watts from the amp to the sub causeing the amps to under power the subs but let me no if u got it im all wayz here to help

Apr 04, 2008 | Car Audio & Video

1 Answer

Lanxar VW12D no sound after excess play


I'm not understanding what you mean by the "Sub doesn't even sound blown" if it doesn't play at all. One thing you can check is if you gently push in on the cone you shouldn't hear anything, if you hear a scratching noise and can feel resistance then you have a problem. If you have an OHM meter, you can check the voice coil impedance, it is a down and dirty way of checking to see if it is good or not. Measure all of the voice coils that you have and they should all read about the same, not necessarily exactly the same but pretty close. This test should tell you a lot. If it seems to test out fine there is something wrong else where. Let me know if you need more help.
-Andrew Hawkins

Apr 03, 2008 | Xtant A3001 Car Audio Amplifier

1 Answer

Auto amplifier


It depends on if you want it to be able to play really loud and really clear. The deck will probably drive them pretty good on its own but when you really crank on some head decks the sound can start distortring.
Wheres the sub it the package?
Get a less powerfull, 50 Watt X4, amp and get a decent sub with a mono amp or they have all in one 4.1 channel amps. To drive the whole system and keep it easy.
Have fun

COEch

Mar 11, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Eclipse Premium 34230 Car Audio Amplifier Logo

Related Topics:

159 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eclipse Car Audio & Video Experts

The Knight
The Knight

Level 3 Expert

76416 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8984 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

Are you an Eclipse Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...