Question about Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Subs wont turn on

I have all of the wires hooked up correctly my power lihht is on but when my remote battery hooks up it dims down the light! I have never seen a red light! then when everything is right my subs wont work? please help!

Posted by Forrest Rankin on

Ad

1 Answer

Computer Hardware ECT.

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

Make sure there is correct wattage with the subwoofers and the power supply

Posted on Dec 07, 2013

Ad

5 Related Answers

Anonymous

  • 14 Answers

SOURCE: amp turns on and stays on but no sound

are you shure you not connect the amplifier in a wrong connection ...B+,GND,ACC.....ok...then checkif the speakers wires stay in good condicions, some times when we intalled the spk wires for the border of the doors a few times skrewered too.check if it hapen. another ....check if the terminal spk is not going at ground whit the chasis another to....4 ohms per channel ,anny voice coil spk burned...in short. good look.

Posted on Mar 15, 2007

Ad

Anonymous

  • 631 Answers

SOURCE: Protection light keeps coming on

Check the wiring between the sub and the amplifier. That's seems to be the only thing left that could cause a problem. If it's shorted to ground or pinched so the conductors are shorted together, it could cause the symptoms you listed.

Posted on Oct 02, 2007

Lexdiamonzz

Alex

  • 203 Answers

SOURCE: my amp works but my sub doesn't...!!!????????????

Whats the condition of your amplifier? New , Used, Old?

 

You might have a blown channel off your amplifier, this may cause little or no sound. You will have some distortion, crackle sound and then maybe nothing at all. What kind of subs are you running to it? Make sure the subs arent blown and check the voice coils to see that they are not torn off the subs , these are the 2 little silver or copper wires that are connected from the speaker connectors to the sub itself.

 

Let me know what happens?

Posted on Oct 21, 2007

Anonymous

SOURCE: sony xplode 1000 watt amp

just make sure that your wiring is for 1000w or more
and check the + and - even at the speakers.

Posted on Nov 10, 2007

Dalynn Turner

  • 346 Answers

SOURCE: Amp powers on but sub does not come on

I would double-check your RCA's on the amplifier. You should hear a thud if you unplug them. If not they are either not hooked up or defective.

Posted on Feb 08, 2009

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

How can i know if my starter relay is bad on a dodge stratus 2001

IF STARTER RELAY BAD THE STARTER WONT MAKE NO NOISE AT ALL HEADLIGHTS WONT DIM.IF YOU CLICKING NOISE BATTERY VOLTAGE TOO LOW. MAKE SURE BATTERY VOLTS ARE 12.6 VOLTS AND USE TEST LIGHT TO SEE IF STARTER GETTING POWER.COULD HAVE BLOWED IGNITION FUSE OR FAULTY IGNITION SWITCH. TO CHECK STARTER SOLENOID FIRST TURN OFF RADIO THEN REMOVE NEGATIVE BATTERY CABLE AND POSITIVE BATTERY CABLE.THEN REMOVE STARTER BUY A REMOTE SWITCH.YOU NEED BATTERY JUMPER CABLES HOOK BATTERY JUMPER CABLES TO BATTERY PUT POSITIVE CABLE ON POSITIVE BATTERY POST THEN PUT NEGATIVE BATTERY CABLE ON NEGATIVE POST. HOOK BATTERY CABLES TO STARTER USE NEGATIVE CABLE GROUND STARTER BODY AND PUT POSITIVE BATTERY CABLE ON THE LARGE POSITIVE POST ON STARTER SOLENOID. NOW TAKE REMOTE SWITCH HOOK RED WIRE TO STARTER SOLENOID POSITIVE POST THEN HOOK BLACK WIRE TO REMOTE SWITCH TO STARTER SOLENOID SWITCH TERMINAL WITH LETTER S THEN PRESS REMOTE IF STARTER SPINS STRONG WITH A GOOD KICK STARTER GOOD.YOUR PROBLEM COULD BE CORRODED WORN BATTERY CABLES. WEAK BATTERY FAULTY IGNITION SWITCH. IF STARTER DONT WORK WHEN YOU PRESS THE REMOTE SWITCH STARTER SOLNOID BAD OR STARTER ITSELF BAD.IF ALL IS GOOD. CODE SCAN CAR FOR THEFT SECURITY FAULT CODE.
0helpful
1answer

I just bought a hifonics amp the brz2100.1D and when i tryed to hook it up every thing is correct as far as the wireing compared to the manual and the blue lights come on power light is on but its not...

MAKE SURE YOUR GROUND WIRE IS GROUNDED GOOD,,AND IT IS IMPORTENT TO HAVE YOUR REMOTE WIRE HOOKED UP. IT WILL BE A BLUE WIRE,,FIND THE HOT WIRE FOR YOUR TAIL LIGHTS AND HOOK IT THERE THEN WHEN YOU TURN YOUR CAR ON THE AMP WILL ALSO COME ON.THAT SHOULD STOP ALL THE NOISE AND POWER YOU UP.
0helpful
1answer

I have an XM-2150GSX 760watt sony amp, ive gotten everthing hooked up to it, but for some reason i have power to the amp but not to the subs, i know the subs are good still (i hooked them up directly to...

If you are hooking 'blue wire' (remote turn on for amp) to the power antenna wire (usually also blue) from the radio that could be your problem since the antenna only gets power when the radio is used

try using the switched 12 volt wire you used to connect your stereo power

i will assume all other wiring is correct and if so this should fix your issue - if not write me back with as many details as you can about how you have things wired and i will try to help more

good luck!!
0helpful
1answer

Power is hooked up. Ground is connected. Both subs are connected. The triangle light is red, and there is now sound. All wires are hooked correctly...

on most amp red isnt good that means it in protection mode try turning your setting on the amp down all the way and turn the volume down tell you can get sound out of them then turn up the volume to were you would to them most and set the to what sounds the best but make sure the light doesnt dim down when the base hits
0helpful
3answers

I have this hooked up and works fine with the key on, but when i start the car, sub light, amp and sub dont come on.

You have connected it to the wrong power wire - one that is only active in service mode - first key position.
You should draw a wire directly from the battery (don't forget to add a 40 amps fuse on the wire) to the amps. If you don't want them constantly operational (you will have to manually shut them down) install a relay on the wire with the command coming from a wire from the instrument key position - second position of the key. Use a voltmeter to identify the wires.
0helpful
1answer

A2200 htc wont bump my subs and the fans never turn off

check your wiring's, there are two positive lines, one is directly connected to the batteries positive terminal and the remote positive is connected to the ignition's positive, and make sure it is properly grounded.
0helpful
1answer

Sub cutting out

Check the 12v wire running from the battery to the amplifier. Also the sony explode is a garbage subwoofer compared to the Alpine.. sony (they say 1200w max but its more like 100w to power the thing) Amp could be going. Is the amplifier hot when running. If there is a burnt smell comming from the amp, its the amplifier
0helpful
2answers

Subs and amp problems

make sure you have the wires from the amp to the box, and the box to the subs hooked up right... red is positive black is negative
0helpful
1answer

52 in. redington III cieling fan

Did you have to wire in the remote? If so you prob hooked up the light to constant power source. more info on number of wires on remote unit and wires on ceiling fan pls.
1helpful
1answer

Concept CC-2502 Car Audio Amplifier

The amps are probably going into protection mode. The wires are most likely not hooked up correctly. Make sure you have a good ground, good power source, and the remote wire is run correctly. Also make sure the speaker output wires aren't touching each other, and you have the correct ohm load for the amp. What kind of speakers/subs are hooked up and how are they wired?
Not finding what you are looking for?
Sony Xplod XM-554ZR Car Audio Amplifier Logo

75 views

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

The Knight
The Knight

Level 3 Expert

76823 Answers

 Grubhead
Grubhead

Level 3 Expert

5720 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...