Question about RTO Welding Tools

Open Question

Millermatic 135 mig welder circuit board

Red light on the circuit board comes on when i pull the triger there is a green light but not coming on

Posted by Leslie Stewart on

Ad

4 Related Answers

Anonymous

  • 2 Answers

SOURCE: Toolex 140 mig welder, wont feed wire.

You may have the scew settint your wire tension set to tight. Try loosening the tension and if that doesnt work check the eletrical wire that supplies the power to the roller and make sure it hasnt become disconected.

Posted on Jun 28, 2009

Ad

Anonymous

  • 2 Answers

SOURCE: My Lincoln 135 mig welder suddenly doesn't have enough arc

check the diodes that there not short or open circuit you will need a meter with diode test..

Posted on Aug 10, 2009

Ad

Anonymous

  • 1 Answer

SOURCE: Lincoln Pro-mig 175 w/ no wire feed but relay clicks fan runs

Normal 0 false false false MicrosoftInternetExplorer4 /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} The problem with my MIG 175 Pro is the "voltage selector switch" (part # M15750-1). I took it apart and saw all of the contact points where corroded. I can hold the knob between two settings and the machine will work.

I have the same issue only after about a year of very light use. I am not sure how to prevent this from happening again.

Posted on Sep 04, 2009

con_fuse9

  • 52 Answers

SOURCE: my sp 135 welder is burning the wire

The wire will burn back between wherever it gets the power, to wherever it is grounded. If it burns back to the rollers, it must not be getting power at the contact tip.
Remember, if you are using a shielding gas, the gun wires up to the (+). If you are using flux core, the gun wires to the (-).
Of course the 'ground' connects to the opposite.
Sounds like the drive rollers are shorted to 'ground'.

Posted on Nov 24, 2009

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I need Q1 transistor for 135 hobart welder


The transistor is mounted on the main circuit board, you cannot buy the part from Hobart or Miller, they only sell the complete circuit board.
If you can read any part numbers from the transistor you can purchase the part from a electronic parts supplier.

Jul 13, 2014 | Hobart Handler 140 Mig Welder

1 Answer

I have a millermatic 251 but the gat wont come out when i pull the triger


First, you need to check that you have the correct input voltage going to the machine. The main PC board on the welder disperses the input voltage to many different things,ie. the gas solenoid, the drive motors, contactors, transformer, stabilizer etc.

So if your machine is made to run on 230v and it is plugged into 208v, the first thing to stop working is the gas solenoid because it requires more voltage (34vdc on this model) to actuate.
If it turns out you are running the correct power to the machine, there is something wrong with an internal component on the machine and it needs to be brought to a certified miller service center where it will most likely be one of two things, the gas solenoid (about $30+ labor) or the main PC board ($500-600+labor) hope for the best on that one.
best of luck!

Aug 14, 2011 | Miller Welding Tools

1 Answer

Millermatic 180 wire don't feed lights won't come on fan keeps running


Machine will run only on 220V, check your braker nust be at lest 20Amp.

Dec 18, 2010 | Miller MATIC 180 MIG w/cart/AND SPOOLMATE...

1 Answer

The welder fan is running and when i push triger air flows but wire motor does not run


Check the heat resistor which is located on the circuit board behind the wire speed dial! Looks like a white oblong component and tends to desolder itself through heat on the board! Resolder it back in and it should work again!

Nov 27, 2010 | Clarke Power Products Mig/Fluxcore 180En...

1 Answer

The millermatic 135 gun has stopped working. Could this be from the switch going out?


If the switch is dead, the gun will not work. Pulling the trigger tells the machine to initiate delivery of the wire, gas and current. If the switch is dead, none of that will happen.

Feb 09, 2010 | Miller Welding Tools

1 Answer

Hi, i have a Millermatic 135 that barely sparks when i try to weld with it. this happened between welds.


Check the rectifire and/or diodes.Also could be a bad connection any where in the welding output circuit.

Sep 05, 2009 | Miller Welding Tools

1 Answer

My hobart 135 will not feed wire. I checked for voltage at the drive motor no voltage. The gas still comes on when trigger is pulled but seems that the problem is in the control board?


does it have a reset button? if so it has gone bad, if not there is a fuse or something inside. they protect that circuit against shorting at the working end of the gun. happens ALL the time.
Hawk

Mar 31, 2009 | Hobart Handler 140 Mig Welder

Not finding what you are looking for?
Welding Tools Logo

Related Topics:

394 people viewed this question

Ask a Question

Usually answered in minutes!

Top RTO Welding Tools Experts

Brad Brown

Level 3 Expert

18591 Answers

Bill Boyd

Level 3 Expert

53816 Answers

ray gallant

Level 3 Expert

71004 Answers

Are you a RTO Welding Tool Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...