Question about Orion 1200D Car Audio Amplifier

1 Answer

Orion XTR PRO 2400 power on... no sound

Ive had this amp running 3 12s at 2.67 for a while without any problem ,one un hooked it and i think a speaker wire touched the remote , it powers on but has no sound ive been inside with a magnifying glass and couldnt find anything . can anyone help?

Posted by on

Ad

1 Answer

It could be that it burned the stereo inputs or outputs

Posted on Feb 26, 2008

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

SP OFF mode?


if you turned it on without speakers hooked to it you may have blown the speaker output amps or if the end of the amp remote wire touched a ground you may have burned a trace on the board did you here it play at the pawn shop? or did it just light up? sometimes the people at the pawn shop think if the unit lights up it is working and sometimes they check them is just hook power to them without speakers if so this can blow the speaker output I would take it back to the pawn shop

Jan 29, 2014 | Kenwood KDC-MP235 CD Player

1 Answer

How to get amp out of safe mode


first check all connections, fuses and speaker wiring. Check to make sure that the amp is getting enough power to keep it running, meaning a piece of 4 to 8 gauge minimum wre from your battery to the amp. Make sure no wires are touching ground on the speaker outputs all the way to where they connect to the speakers. You can check this with a Ohm Meter to see if their is a direct short to ground. Or unhook all speakers and 1 by 1 touch them onto the amp to see if it cuts out. If the amp is going iinto protect mode without any speakers hooked up to iit (I have a bad keyboard sorry for the extra or missiing I's) and all other things I mentioned are OK then your amps bad and needs to be serviced. Hopefully It's just be a shorted speaker or wire.

Aug 07, 2013 | Jensen XA4100 Car Audio Amplifier

1 Answer

Installing a subwoofer in a honda integra


if you already have a after market radio hook the remote to either the remote/power antenna wire or the acc/key switch wire hook up rca,s run them down same side of car hook amp power wire down other side of care it stops engine noise make sure you do a good ground iy needs to touch bare metal for best performance hope this helps

Mar 03, 2013 | Kenwood Car Audio & Video

1 Answer

My amp blew the 20 amp fuses. Replaced and they blew as soon as the radio kicked in. Took the back off to look for any burnt connections or blown open/expanded capacitors or resistors. It smells like...


Remove all the wires from the amp including the remote turn on wire. Once you do that, after about 30 seconds the amp will reset. Hook the power up first, then the ground then the remote. Turn the unit on and check for power WITHOUT the speakers hooked up. If you get no power by now it's a good chance that the amp is cooked. If you do get power, try hoking up your speakers first on one channel then the other channel and then bridged. If it cuts out or off when you touch the speaker wires to one channel or the other, then that channel is no good. Hope this helps.

Mar 17, 2011 | Kenwood KAC-728S Car Audio Amplifier

1 Answer

When i hook up my amp my speakers wont play music? ive hooked up my rca cables up but i ont know if you hook it up to the input or output frum the cd player?


you rca hookup, back of cd player is rca out, at the amp it is rca in, make shure you hook up blue remote wire, also make shure you have a good ground if not amp will not turn on. if you run wires make shure you run power wire down one side of car and remote and rca down the other, This will keep all motor noise out of system.

Oct 07, 2010 | Audiofonics Car Audio & Video

3 Answers

My amp turns on but stay in protect mode


check your wiring, is it properly grounded? is your remote positive wired to your ignition's positive line?

Jun 10, 2010 | Car Audio & Video

1 Answer

Problem with subs and amp


I would first suggest un-hooking the subs, and hooking them up to another known good radio other than the one its hooked to now. Just to make sure you didnt blow the speakers. What is the wattage of the subs? Then if the speakers do work I would hook them up bypassing the amp just to see if the problem exist before or after. Come back after doing this. Thanks

Jul 05, 2009 | Car Audio & Video

1 Answer

Red protection light


If the amp is going into protect mode, it probably has shorted output transistors. To eliminate other possible problems, do the following.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

If the voltage remains near or above 12v, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp almost certainly has shorted output transistors and will need to be repaired.

Sep 12, 2008 | Nitro BMW-482 Car Audio Amplifier

1 Answer

How do I hook up amplifier?


Well make sure you have enough power wire, remote wire, RCA's make sure they are long enough as well. Now depending on wattage the amp can kick out determins on the power wire size. Run a wire bout a foot from the battery + terminal and add a in-line fuse (once again depends on the power of the amp) now run the rest of the power wire to the back. (along with the remote wire and RCA's) Now hook up your RCA's on the sub output, (If no sub output hook up to the rear) this will connect to your amp RCA's input. Now for the remote wire, wire it up to the BLUE remote wire or power intena, this will go to your remote terminal on the amp. from thier all thats left is your speaker... Hope this was helpful

Apr 22, 2008 | Car Audio & Video

1 Answer

Help! Amp not turning on


Im sorry to have to inform you my friend, if you saw smoke, you burned one or more of the resistors or output devices inside the amp. Without a service manual, it will be a hard call on what exactly cooked. In alot of cases please forgive me for saying so, but the ampis not worth taking into a repair shop to be repaired, because of the high cost these days of labor. Its too bad there are no user replacable parts inside of these amps. Good Luck. Ps Please do not forget to rate this thread?

Oct 16, 2006 | MTX Thunder 421D Car Audio Amplifier

Not finding what you are looking for?
Orion 1200D Car Audio Amplifier Logo

Related Topics:

309 people viewed this question

Ask a Question

Usually answered in minutes!

Top Orion Car Audio & Video Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1176 Answers

Dalynn Turner

Level 2 Expert

346 Answers

Marvin
Marvin

Level 3 Expert

85222 Answers

Are you an Orion Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...