Lanzar VIBE266 Car Audio Amplifier Logo

Related Topics:

Tanya Snow Posted on Apr 18, 2009
Answered by a Fixya Expert

Trustworthy Expert Solutions

At Fixya.com, our trusted experts are meticulously vetted and possess extensive experience in their respective fields. Backed by a community of knowledgeable professionals, our platform ensures that the solutions provided are thoroughly researched and validated.

View Our Top Experts

Lanzar amp 1000 watt stays on protect mode - Lanzar VIBE266 Car Audio Amplifier

2 Answers

Anonymous

Level 3:

An expert who has achieved level 3 by getting 1000 points

All-Star:

An expert that got 10 achievements.

MVP:

An expert that got 5 achievements.

Vice President:

An expert whose answer got voted for 100 times.

  • Master 655 Answers
  • Posted on Apr 18, 2009
Anonymous
Master
Level 3:

An expert who has achieved level 3 by getting 1000 points

All-Star:

An expert that got 10 achievements.

MVP:

An expert that got 5 achievements.

Vice President:

An expert whose answer got voted for 100 times.

Joined: Dec 13, 2008
Answers
655
Questions
0
Helped
311291
Points
2081

Hello snow11879,

I haven't been able to locate any support information online about your product, other than the email contact for support questions:

[email protected]

If the amp stays in protect mode all of the time, I would suspect a short in the speaker wiring or speaker(s) voice coil(s), or perhaps a faulty ground. If it plays for a short period of time and then goes into protect mode, it is most likely overheating. First check all of the wiring. Test your speakers on a known good amp and make sure there are no places in your wiring where the insulation may have been damaged, causing an intermittent problem.

Many owners have reported that this particular amp has a tendency to overheat. Also, when run in bridged mode, the speaker impedance needs to be at least 4 ohms. It will overheat if the impedance is below 4 ohms.

Hope this helps.

FastHarley

Level 3:

An expert who has achieved level 3 by getting 1000 points

Superstar:

An expert that got 20 achievements.

All-Star:

An expert that got 10 achievements.

MVP:

An expert that got 5 achievements.

  • Lanzar Master 761 Answers
  • Posted on Dec 18, 2014
FastHarley
Lanzar Master
Level 3:

An expert who has achieved level 3 by getting 1000 points

Superstar:

An expert that got 20 achievements.

All-Star:

An expert that got 10 achievements.

MVP:

An expert that got 5 achievements.

Joined: Jun 18, 2014
Answers
761
Questions
2
Helped
357276
Points
2528

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty Time to fund an old school opti drive lanxar. A 59 will blow those subs apart .A thumbs up would be greatly appreciated if this answer is helpful to you.

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

I have two lanzar max 8 pro subs and a 1000 watt koiller amp what is best way to wire these components

Depends entirely on the output impedance of the amplifier and of course if it matches your loudspeakers.
0helpful
1answer

I have a lanzar vector VCT-2210 2000 watt amp hooked up to two menace 1300 watt subs. when i turn the volume up on the head unit the amp goes into protection mode. i checked all my wiring and it seems all...

Things to check: Is the wire between the amp and the subs heavy enough to pass 167 amps? 2000 * 12 = 166.66666 amps. Max volts on the subs are 10 volts....close enough. Are you sure you're using the line out on the head unit? You may be over driving the amp if it's anything else.If the head unit doesn't have line out connectors then you'll need to get an attenuator for each channel. Do you have caps on the 12 v power in wires? They'll keep the headlights from dimming and the alternator will last longer if you do.
0helpful
1answer

Lanzar vibe266 2000 watt stays in protect mode

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty .
.A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-vibe266-2000-watt-stays-in-zb4bomd1rt4qms0dqd12kkt2-3-0.jpg
0helpful
2answers

How do i reset my 4000 watt lanzar vibe 286 from being in protect mode

You can only reset it by disconnecting power to it. If it is in protect you may want to check your speakers and speaker wires for shorts and/or grounds. If they check out all right you may have internal problems in the amp.
0helpful
3answers

I have a Lanzar 4000 watt amplifier hooked up to 2 12inch MA Audio subs. When I crank my car the green power light on the amplifier comes on, but after a second or two it changes to protection mode. I have...

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to get an old school Opti Drive. .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-4000-watt-amplifier-hooked-up-2-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar
0helpful
1answer

I have a lanzar opti drive plus 500 old school,i have 2 12'' 1200 watt pyles,running in parallel at 2 ohm. when i bridge it at 2 ohm 1000 watts it blew my 40 amp in line fuse.

The 40 amp fuse is too small. 1000 watts = 12 volts @ 83 AMPS. Bigger power wire my friend. If you want to sell, let me know.
0helpful
2answers

Lanzar 800 watt amp protect mode stays on

protect mode usaully means that something has disrupted the power of feed lines to the subwoofer/speakers possibly fuse is blown in amp or amp is blown in which we hope not. see if you have a warrenty if blown and send back or bring it to where you purchased it from.
1helpful
2answers

How do I fix the problem so they work again.?

A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED
0helpful
1answer

Audio bahn 1205n

sounds like your over working your amp 800 watt on a 2000 watt sub. might wanna upgrade your amp
Not finding what you are looking for?

1,227 views

Ask a Question

Usually answered in minutes!

Top Lanzar Car Audio & Video Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1212 Answers

Marvin
Marvin

Level 3 Expert

85242 Answers

xxxxxx xxx

Level 3 Expert

5110 Answers

Are you a Lanzar Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...