Question about Black & Decker Husky 750w Power Inverter

1 Answer

Not working I went to plug my unit onto the battery and it shot sparks. Is my unit still good? if so what so I need to do to fix it?

Posted by matt788 on

Ad

1 Answer

Jan McZeal

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 632 Answers

Its still ok

Posted on Jun 19, 2009

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have had problems starting my vette i replaced the starter soloid that was shot then went to start it got nothing checked fuses replaced alarm fuse that was burnt out horm kept going off pulled made a...


first things first. if its the alarm system you wont have spark so check that first withan inductive timing light on one of the plug wires while you try to start it. if it was runnung fine before the solenoid fix its the most like cause. you will need to find a amnual online to figure out how to bypass the system or troubleshoot it to find out if it has a reset. next is fuel. if your getting good spark check to see if your getting fuel to the cylinders. if you have an electric fuel pump you may have blown the fuse in its circuit as well. start here and see how far you get. its always one or the other, either fuel or spark. good hunting.

Jun 01, 2010 | 1987 Chevrolet Corvette

1 Answer

My 2002 suzuki tl 1000 is not starting and the battery its good what could it be. when i turn the ignition nothing turn on i check the the relay an fuses and ther good


Check the ignition coil unit to start with. Is the spark blue or orange? Take sparkplug out,..put on plug cap...touch bottom edge of plug onto metal..[cyl. head], turn bike over...and check for spark color. If spark is "orange",..the coil is shot...replace it.

Apr 12, 2010 | 2002 Suzuki TL 1000 R

2 Answers

1999 Polaris 500 ATV: Battery went shot. Just use pull start for quite awhile. After awhile, head light and low beam lights quit wokring. Replaced battery, all other lights work except those noted. Riding...


I had a simular problem with my 99 sportsman 500 and it turned out to be my pulse coil somehow became out of alinement. The pulse coil air gap should be between0.016 to 0.040 inch, But I would start by checking the coil it should read 0.3 to 0.5 ohms. Good luck and hope this helps

Mar 23, 2010 | Polaris ATV

1 Answer

Snap fish error


Hi sharanmca84,

ok i gave my phone for repair and had same problem. so i went onto the sony ecrisson site, downloaded the software update program onto my computer and followed the instructions. this has solved the problem,,


good luck with your fix,,,
have a nice day,,

Regards
Arul

Mar 06, 2010 | Sony Ericsson Cyber-shot C905 Cell Phone

2 Answers

LCD screen started getting fuzzy, then went dark.


Hi,

You have inserted battery in your camera after splashing water onto it. Switching ON the device caused short in the circuit. It needs to be send for service (repair), there is no other way to fix the problem.

Rating the solution is highly appreciated....Good Luck

Mar 05, 2010 | Sony Cyber-Shot DSC-P72 Digital Camera

1 Answer

Rreplaced battery car will turn over but not fire


My Dodge did that! Turned out that it was oil falling onto the starter. My heat shield had dissintegrated and I had an oil leak...The only way to start it was to use a broomstick and hit the starter while turning the key...lol.
I gave up and went and had a new starter put in,a heat shield,and got the hose fixed that was spraying oil onto motor...
I'm not saying that this is what's wrong with your's however.
It could be spark plugs,starter,etc.
Have you checked for any leaks? The spark plugs?
Just a few things to look at before calling a mechanic. Hope this helps.

Sep 29, 2009 | 1997 Dodge Caravan

1 Answer

Engine wont start


The spark plugs if they are blackish it means rich on mixture and thus they have fouled up and will give you hard start. If they are brownish whitish tht means they are ok, and if they are whitish means the engine is running lean.
Since you checked the the fuel pump and after removing the pipe fuel gushed out it proves tht the pump is functioning.
Getting back to spark plugs....remove one of the spark plugs and earth it on the cylinder head somewhere and fix the lead head to it and thn crank start the engine and see if theres good bluish sparks at the spark plug.
I would recommend you first to examine the spark plugs , replace them if necessary and try to start it.
Hope this helps!

Jun 15, 2009 | 1999 Yamaha FZX 250 Zeal

3 Answers

1987 Jeep YJ Hard to start hot


Sounds like a bad distributor control module. You blew-up your muffler because there was no spark.....lots of fuel in the exhaust....then an intremittent spark......BOOM!
Once the module cools off, it works again, because the crack in the circuit board re-connects....until it gets hot again, and opens the circuit........no more spark. Replace the module.

May 28, 2009 | 1990 Jeep Wrangler

Not finding what you are looking for?
Black & Decker Husky 750w Power Inverter Logo

Related Topics:

249 people viewed this question

Ask a Question

Usually answered in minutes!

Top Black & Decker Electronics - Others Experts

Cindy Wells

Level 3 Expert

6199 Answers

Sheldon Dedek

Level 3 Expert

912 Answers

Vernon Taylor

Level 3 Expert

7190 Answers

Are you a Black & Decker Electronics - Other Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...