Question about Hoover F7431-900 SteamVac Vacuum

1 Answer

Steamvac quit spraying

Hi.... I am cleaning my carpet and everything was fine the "first round". I emptied the dirty water and refilled the clean water reserve and when I tried to pick up where I started, the sprayer won't spray. I cleaned the black filter, checked the rubber washer, and can't find out what's wrong. HELP!! THANK YOU!!

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Check the seal that the clean water tank sits on, may have come loose. The filter inside the dirty water tank has been pushed up too far, needs to have a 1/4 in. gap from the top to the top of the filter.

Posted on Jan 10, 2008

Ad

1 Suggested Answer

Anonymous

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hoover SteamVac LS F5899-910


Hi,

Did you try to clean first the unit..

Jun 01, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

It is not dispensing water and solution


Clean Water

Solution Tank

won't dispense.

1. Clean Water Solution Tank

not firmly in place.

1. Make sure tank is securely locked in

position.

2. Clean Water Solution Tank

empty.

2. Refill tank according to instructions for

surface being cleaned.

3. Dirty Water Tank lid not on

correctly.

3. Make sure lid is firmly in place.

4. Pump needs to be "primed"

(when using tool).
4. See "Before Using Tool" section.

Dec 17, 2012 | Hoover SteamVac F5914-900 SpinScrub...

2 Answers

Leaving bigger dirtier wet spots after cleaning


Sounds like the vacuum motor is defective or you have a clog in the vaccum line. Basically everything is running except the vacuum "Suction" cycle. Do you hear the "Suction" phase (light indicator) during operation when it loudens like a whine? That would be the vacuum phase. Is the dirty water reservoir clean, do you rinse it thoroughly when you empty it? Have you removed the hose assy and rinsed it out? I think it is still part of the auto cycle even if you don't use the manual tool.

Feb 24, 2010 | Bissell SpotBot Robotic Wet/Dry Vacuum

1 Answer

Water does not dispense on wash cycle


this would be the soap/ water valve. it is stuck closed or isn't opened.( no cure for an non-opened valve, just replace.)

Jul 16, 2009 | Hoover F7220900 SteamVac V2 Upright Vacuum

1 Answer

Bissell pro heat 2x multi surface carpet cleaner making spots


maybe there's not enough vacuum or it hasn't been primed enough. I have a proheat that drove me crazy till I started leaving the heat switch on. I get wads of carpet fiber that mat around brush and spit out on the carpet, so I frequently remove them. I'm just wondering if after you empty the water, it may not have built up the suction. Good luck! hope this may be helpful

Jan 13, 2009 | Bissell 1699 ProHeat Clear View Upright...

1 Answer

Hoover Upright Steam Vac, 12 amp


  • Check to make sure that the lower dirty water lid is installed and secure and not cracked.
  • Check to make sure the front duct panel is installed on the dirty water tank (this will transition the water from the front nozzle into the tank)
  • Check the filter in the dirty tank lid, clean if necessary
  • Remove the lower tank and look at the motor cover, locate a round hole, you should see a black ring (gasket).
  • with the lower tank removed, turn the machine on to check suction at the round hole, if OK then your problem will be with one of the above reasons


I’m happy to assist further over the phone at https://www.6ya.com/expert/robert_b96ba3f038cf317c

Jan 12, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Bissell ProHeat 7901 will not **** up water


Hi,

Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101
adfa

Nov 11, 2008 | Bissell 7920 ProHeat Pro-Tech Upright...

1 Answer

Within an Hour my SpotBot stopped working


Some of that water must have gotten inside amd shorted something. If this is less then 1 year, it would be under warranty. It iwll have to be taken apart and checked.

Dec 02, 2007 | Bissell SpotBot Robotic Wet/Dry Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

168 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Gerry Harvey
Gerry Harvey

Level 3 Expert

1481 Answers

Brad Brown

Level 3 Expert

18165 Answers

Marvin
Marvin

Level 3 Expert

85223 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...