Question about Yamaha 12V Air Pump

2 Answers

Have 1997 yamaha gp1200...starts and idles fine...runs fine for first five minutes then just loses power or shuts off. Wait a couple minutes...starts back up runs great then loses power to idle or shuts off. Checked fuel lines, fuel filter, vent hoses, carbs clean, oil lines zip tied tight, compression good, checked kill switch, disconnected thermoswitch and ran....still does it. Someone mentioned rectifier/regulator and cdi? Any help appreciated!

Posted by Kell on

Ad

2 Answers

Karl Kittsteiner

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 220 Answers

Check the converter on the exhaust they do plug up if on too long

Posted on Jun 21, 2017

Ad

Bill Boyd

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Yamaha Master
  • 53,816 Answers

Indicates that a component in the ignition circuit is overheating internally and failing
could be a coil or cdi unit or any sensors if fitted

Posted on Jun 21, 2017

Ad

4 Related Answers

Anonymous

  • 207 Answers

SOURCE: Ran my Yamaha GP 1200R Out of Gas

you cant clean the carbs out once u take the diaphrams out u just need to replace them get three carb kits from riva yamaha and put kits in them and ill bet you $20 it will run

Posted on Jul 08, 2009

Anonymous

  • 207 Answers

SOURCE: I have a 2002 Yamaha FX140 Waverunner.Fuel problem or electronic?

you have fouled spark plugs change them all fixed all the newq yamaha sare doing it it is the in thing to do

Posted on Jul 08, 2009

Anonymous

  • 1 Answer

SOURCE: 1994 Yamaha Waverunner 3 will idle but wont take throttle

Switch to reserve tanke to check to see if there is a clog at the fuel pickup in the tank.
My friend had the same issue with his waverunner 3.

Posted on Aug 31, 2009

heimlich

David Belcher

  • 1978 Answers

SOURCE: 1998 yamaha waverunner xl760;just purchased it

Take the carburetors apart and clean them. There is probably water caused white corrosion in the fuel needle assemblies. Once the needles are cleaned the fuel should pump and flow through the carburetors again.

Posted on Sep 27, 2011

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

2010 Ford F150 would suddenly loose power and only idle. Pull over shut off sit a couple minutes crank and run fine for a while then do same thing again. Wrench would show up on instrument panel

Sounds like the catalytic converter or muffler maybe getting plugged up and the computer is putting the truck in limp home mode. Did you put a scanner on the truck. You might try to remove the 02 sensor ahead of the cat and see if it runs a little better it will not be perfect but should stay running if so do an exhaust check. When the cat or muffler gets plugged it puts back pressure on the engine and won't allow the fuel to be pulled into the engine properly.
0helpful
1answer
1helpful
1answer

I have a 1997 SAAB 2.0 Turbo and it has started to run rough after it warms up and when driving it loses power and runs very rough until power taken off. Any ideas?

suspect low fuel pressure to the injectors
run the fault codes to determine where the fault may be before you spend money
0helpful
1answer

Have 94 Evinrude 48 horse motor starts idles fine runs good at idle speed after giving gas runs three to five minutes shuts off after a couple minutes starts back up all new fuel lines bulbs and plugs

Your have a magneto on this. On the top. it gets rusty.(just like a lawn mower) Use sand paper and clean it(coil and flywheel). reset coil gap. If it still happens, adjust again and or replace the coil.
0helpful
1answer

1997 yamaha mountain max 700 runs but then boggs then runs normal again

will most likely be the Carburettor is dirty. WHAT CAN YOU DO for this; In the market there to spray purified karmpylater.
DEDUCTIONS after the air filter, the engine ignited and psekazeis the contents of the spray inside the karmpylater while playing with the throttle
Nov 27, 2013 • Motorcycles
0helpful
1answer

It will run good for a while on hot heat and then shuts off for abut 5 mins but it doent shut off on cold cyc

why does my roper electric dryer shut off after five or ten minutes of running fine. then wait five or ten minutes, restart and it runs fine for another five or ten minutes, and so on....
0helpful
1answer

High idle 1997 gp1200

obviously your fuelling isn't set up correctly
0helpful
1answer

Car runs for about five minutes then shuts off

1999
mit eclipse runs for five ten min then shuts off i have to wait a while befour starts back up why?
0helpful
1answer

Truck idles fine but has no power

Does the exhaust sound muffled? Could be a bad catalytic converter.
Not finding what you are looking for?
Yamaha 12V Air Pump Logo

Related Topics:

2,077 views

Ask a Question

Usually answered in minutes!

Top Yamaha Water Sport Experts

Mike

Level 3 Expert

4377 Answers

Oloyede Monsuru

Level 3 Expert

1468 Answers

johnny bonacci
johnny bonacci

Level 2 Expert

276 Answers

Are you a Yamaha Water Sport Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...