Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum Logo
Posted on Sep 03, 2007
Answered by a Fixya Expert

Trustworthy Expert Solutions

At Fixya.com, our trusted experts are meticulously vetted and possess extensive experience in their respective fields. Backed by a community of knowledgeable professionals, our platform ensures that the solutions provided are thoroughly researched and validated.

View Our Top Experts

Kenmore progressive vaccuum

The vacccuum is working fine until I put the Hepa filter into the spot in the vaccuum. When I do it emmitts a loud sound like something is constricting tubes. All tubes are clear. I have taken the cover off and everything looks fine, I sumize that the problem is with the plastic cannister when i put it into the vaccuum.. I have cleaned the entire unit.

  • Lisa77 Nov 11, 2007

    I have the same issue. There is not enouph suction and it makes the noise described above. I took everything apart and can find no blockage. I read another comment that referenced reversing the air flow, because this seems to be the issue, but I cannot locate my manual and cannot find any kind of switch to change the air flow. I turned the hepa filter both ways and this did nothing. The noise decreases and stops when I turn the suction down (there is high, medium and low options.

×

1 Answer

Anonymous

Level 3:

An expert who has achieved level 3 by getting 1000 points

All-Star:

An expert that got 10 achievements.

MVP:

An expert that got 5 achievements.

President:

An expert whose answer got voted for 500 times.

  • Master 1,673 Answers
  • Posted on Jan 05, 2008
Anonymous
Master
Level 3:

An expert who has achieved level 3 by getting 1000 points

All-Star:

An expert that got 10 achievements.

MVP:

An expert that got 5 achievements.

President:

An expert whose answer got voted for 500 times.

Joined: Jan 03, 2008
Answers
1673
Questions
1
Helped
705836
Points
3439

Did you replace the hepa filter with a new one? Those filters may not look bad, but after a period of time and use, air is restricted thru them. They should be changed at least once per year.

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Where do you put the prefilter on a miele canaster vaccuum

Hi If the power head isn't working it may be clogged. Try taking it apart to see if threads and general dirt has got in at the sides. Also without the power head if the Miele still isn't working then its a possibility that the on switch wiring is either loose or check the plug at the end of the power cord.

1helpful
2answers

Kenmore progressive 360 vacuum cleaner has low suction

Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck
0helpful
1answer

I was using the vacuum and noticed the filter had fallen down. It's making a very loud sound now. Appears the dirt might have gotten into the motor. Any way to clean this out? Any other thoughts?

Solution: cleaned out plugged hose lines. Changed filter and made sure it snapped into place and that bottom cap was secure. Also changed hepa filter and everything is good now.
0helpful
1answer

Loud noise/Sounds clogged

You could have a clogged air filter and vacuum is not getting air to motor. You could have hair and string buildup on ends of roller brush. You can put a vaccum hose over a broom handle to clean it out. Also, check the little elbow of the hose at the bottom f vacuum where it bends.
0helpful
1answer

Kenmore progressive Direct Drive Vacuum w/Hepa

Check the hose and dirt inlet for a blockage. Also the brush roll, check it to see if you can turn it or not by hand. If not, then something may have jammed it.
5helpful
4answers

Kenmore Progressive Direct Drive Upright - noise and bad suction

Had the same problem tonight. Took the entire thing apart only to find there was a much simpler solution. Check the small hose that runs from the brush rollers where the longer hose (on the back) attaches to the side of the vacuum. Easiest way to do this is to lay the handle down and stick something (coat hanger worked good) through it until it comes out of the head. I found a pretty good sized fuzz plug in mine. As soon as I removed it, everything worked great again - and no noise!
0helpful
1answer

HEPA FILTER REPLACEMENT

Looks like there are is an 2 indentations on the back, these are tabs, push them in and push the cover up, it should come off.
Not finding what you are looking for?

284 views

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

ZJ Limited
ZJ Limited

Level 3 Expert

17989 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3054 Answers

Cindy Wells

Level 3 Expert

6690 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...