Jl Audio 500/1 Car Audio Amplifier Logo

Related Topics:

Question about Jl Audio 500/1 Car Audio Amplifier

1 Answer

No sound the light on the amp is green, i checked the rca's and the sub its hooked up too. i cant get any power to my sub

Posted by papako on

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

If tghelight is green the power is there...but themost common problem s power return..meaning that you might have a bad ground. i wouldsuggest inspecting your ground cable..it should be 6awg minimum and make sure that its grounded to either the frame or negative battery terminal. nothing painted and nothing that doesnt eventually connect to the frame.

Posted on Sep 06, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Subs not working

has everything been hook up correctly more specifically the RCA,s.make sure theres a source. If u sure everything is fine check ur subs with a dmm
0helpful
1answer

Power light comes on but no sound :(

Good amp but gave me nightmares because of cliping and power protect. if wired correctly then your sub might be blown check subs by using a multimeter and check ohms. No ohms means its blown. Ohms vary between subs. double check Rca inputs as well I just hook up my comp speakers to do this.
0helpful
2answers

The light on my amp is green but no sound

have you got the auto ariel lead from the head unit connected to the remote connection on your amp?
if not then that is your problem, it turns the power on when you turn on the unit. and turns it off when you switch unit off.

hope this helps
4helpful
2answers

I have checked all connections to my amp battery,head unit,remote or trigger wire,fuses,power cable,rca leads,ground wire,amp has a green led light on it indicating if it works ok,red if it`s not,light...

Your amp could be in protection mode! Sometimes turning up to high or wires touching will put in protection mode! It will have to be unplugged for a day or two to drain all power out of the memory. Leave accessorie/ignition wire hooked up, just not power and ground wiring. It should reset itself.
0helpful
3answers

Audiobahn amp help...

You have a Direct Short in the System Between the Head Unit and the Amp. Check the Ground on the Amp and then Check all the Wires behind the Stereo and the Common Ground There. You could even have a Spot in the New RCA Cables that is Touching Metal Somewhere. Please Rate My Response! Thanks!
0helpful
2answers

Sony xplode 1000w amp has green light puts out no power to subs

may haveto turn sub on through the stereo itself if rca cables are good.
0helpful
3answers

Kicker 750.1 Amp wont play music

it is probably the rca inputs on the amp may have fried. was your cd decked turned up loudly before the power went out? did any wires accidently touch each other? If had worked fine and then suddenly stopped, than either a wire came loose or the inputs fried. try using different cables and I also suggest disconnecting power for 24 hours and then reconnect. If the green light is on then it is getting power and the problem is in the rca cables or the inputs
0helpful
1answer

Jl 500/1 no sound, green light

This is an indication that the MOSFETs are ok but the driver stages may have a problem. Get a schematic find the pre-amp stages and test the voltages levels there as compared to the schematic. I do believe that you will find the problem in the pre-driver pre-amp atages.
0helpful
1answer

Jl 500/1 no sound

If all of your connections are correct you may have sustained damage to the driver amplifier that controls the subwoofer. If you have electronics experience and can get the schematic, you may want to trace the audio signal to see where it drops off. it is my guess that it will either a one of the pre-driver transistors, or at the main power driver MOSFET devices. In any event they will need replacing if they are bad. I don't they are bad because the light does not remain red so it might be on of the pre-driver transistors.
0helpful
1answer

Rockford Fosgate P3002 Amp

what are the color of the lights that stay on.red= protect/ green=on.if the amp has little sound it probably still working,check deck output volume(rca)
Not finding what you are looking for?

172 views

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Morne Olivier
Morne Olivier

Level 2 Expert

265 Answers

Mike

Level 3 Expert

4383 Answers

Joseph Hoffmann

Level 3 Expert

1756 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...