Question about Sony Cyber-Shot DSC-T3 Digital Camera

1 Answer

UNABLE TO TAKE PICTURES

THE CAMERA SCREEN IS BLANK (DARK, WITH ICONS SHOWING) WHEN I SET IT ON CAMERA OR VIDEO MODE .I'VE TRIED SWITCHING IT ON AND OFF,RESETTING IT ,INSERTING AND RE-INSERTING THE MEMORY STICK TO NO AVAIL. PLEASE ADVISE. THANKS. Sella

Posted by on

  • SELLA Sep 03, 2007

    DEAR SLOBANS,
    THANKS FOR THE TIPS.WILL TRY TO SORT IT OUT.
    BEST REGARDS
    SELLA

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 39 Answers

My guess ccd chip is faulty.check sony site,they admit that they had problems with certain models.good luck. ps i had similar problems with my p10,it was ccd that died...

Posted on Sep 03, 2007

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Cannon PowerShot S2 IS digital camera, about 5 years old. The LCD Monitor and Viewfinder both only show a black screen with some of the Dispay Icons across the top and bottom, and after a few...


A stuck shutter is another common failure mode for digital cameras. The symptoms of a stuck or "sticky" shutter are very similar to CCD image sensor failure. The camera may take black pictures (for shutter stuck closed), or the pictures may be very bright and overexposed, sometimes with lines, especially when taken outdoors (for shutter stuck open). To confirm a stuck shutter, put the camera in any mode other than "Auto", and turn the flash OFF (you don't want to blind yourself for the next step). Next look down the lens and take a picture. You should see a tiny flicker in the center of the lens as the shutter opens and closes. If no movement is seen, then you likely have a stuck shutter. If so, please see this link for further info and a simple fix that may help.

Jun 06, 2011 | Canon Cameras

1 Answer

Hi, Have installed an Nvidia Geforce 7600GT on my PC but got an error Frequency out of range. Installed latest drivers can get a desktop but no icons or task bar tried properties, arrange icons, checked...


The PC video resolution is too high, native resolution for this monitor is 1280x1,024 @60Hz.
It does not make sense thogh thst you get blank sceen on safe mode, you may have video card set up problem. Does it work with another PC? Cna you try another monitor with thsi PC?
http://www.fixya.com/support/r4873371-fixing_out_range_format_not_supported

Basic LCD monitor and TV troubleshooting guide:
http://www.fixya.com/support/r6150077-basic_lcd_monitors_troubleshooting
http://www.fixya.com/support/r5093881-lcd_flat_panel_tv_troubleshooting_guide
http://www.fixya.com/support/r7406380-tv_training_manuals
Failed TV and Monitors: http://s807.photobucket.com/albums/yy352/budm/

Learn about bad caps: http://en.wikipedia.org/wiki/Capacitor_plague

Capacitors kit: http://lcdalternatives.auctivacommerce.com/ he can make you a set of caps for you.

Or www.digikey.com just make sure to use caps with low ESR, 105c, high ripple current, long life rating such as PANASONIC FM or FC series.

Mar 10, 2011 | Gateway FPD1960 19" Flat Panel LCD Monitor

1 Answer

All of the icons are still visible, but otherwise, the screen of my t99 is showing up blank. The camera still takes pictures, but the photos are black and so is the display. Please help! No temperature...


Hi,

This may be due to the CCD Image Sensor failure in the Camera.
To confirm the issue, please check if the previously captured images are displaying normally. The previously captured images and icons will get displayed normally if the CCD image sensor issue is there in the Camera.
If this happens only with the live view, then try Initializing the Camera.

The Initialize option can be done only if the Menu of the Camera is accessible. To access Initialize select MENU-->SETTINGS-->MAIN SETTINGS-->INITIALIZE-->OK.

You may also try power resetting the camera. To power reset the Camera, remove the batteries from the Camera and then press and hold the POWER BUTTON of the Camera for 15 seconds and then reinsert the batteries after 1 minute and check if the Camera works normally.

If the issue is not resolved after resetting, service may be required.


Thanks for using FixYa.

Jan 18, 2011 | Sony DSCT99 Digital Camera

1 Answer

Camera switching on ok but lcd sceen blank


Your problem can be the result of a number of causes - two common ones I will list here.
Most common cause would be a failed printed connecting cable between the main camera electronics and the flip out display panel. This special cable passes through the display hinge and is sometimes subject to failure.
A second possibility is a faulty display backlight.
You can check that the camera is still producing video output by using the AV cables conected to a TV display with the camera set to CAMERA mode.
I trust that this information is of assistance. RHN

Jan 02, 2010 | Sony Video Cameras

1 Answer

Blank screen


Try this...if you can still get into the setup menu, scroll to "reset" and follow the on-screen instructions. If not, remove the memory card and battery...press all the buttons...leave the camera alone for 20 minutes...insert the card and then the battery...turn it on. Did that help?

Sep 28, 2009 | Canon PowerShot SD750 / IXUS 75 Digital...

2 Answers

Screen display blacked out though all funtional icons are visible


CCD Failure !!! dont worry they will do it free of charge i am pretty sure see the link if ur camera model is not incl in the list and even if u are out of warranty they will do it free of charge just call them in ur region and they will do it free of charge it is a manufacturing fault in some CCD chips

http://support-asia.canon-asia.com/index.jsp?fuseaction=support&prod_type=image-phenomena_notice

see this to confirm ur problem and plsrate me FIXYA for help

http://www.imaging-resource.com/badccds.html

Mar 21, 2009 | Canon PowerShot S3 IS Digital Camera

1 Answer

Agfa ephoto 1280 - blank screen on "Play" OK in "Rec"


Tried replacing the memory card, and the camedra came alive again.

Feb 18, 2009 | Agfa ePhoto 1280 Digital Camera

1 Answer

Screen black in all lighting. Icons and menu show and can view photos already on card, but screen black in all modes. Can take picture, but it is also black. Lens cover is open. Nikon Coolpix 4600. Thanks...


Hello, I went and researched a few points in the manual and hope this helps to some extent. If this doesn't help, try resetting your camera by removing the batteries for 30 seconds, then reinstalling them and turning on the camera again.
Monitor is blank:
• Camera is off.
• Batteries are not correctly inserted or battery-chamber
cover is not properly latched.
• Batteries are exhausted.
• EH-62B AC adapter (available separately) is not properly
connected.
• Camera is in sleep mode. Press shutter-release button
halfway.
• Monitor is off.
• USB cable is connected.
• AV/Video cable is connected


No picture is taken when shutter release button is pressed:


• Camera is in playback mode.
• Batteries are exhausted.
• Red (!) lamp flickers: flash is charging.
• Green (AF) lamp flickers: camera unable to focus.
• Message "CARD IS NOT FORMATTED" appears in
monitor: memory card is not formatted for use in your
camera.
• Message "OUT OF MEMORY" appears in monitor:
insufficient memory to record picture at current Image
mode setting.

Dec 02, 2008 | Nikon Coolpix 4600 Digital Camera

2 Answers

LCD Display Blank


I have a sony cybershot DSC-S650, the LCD was very dark and could not see anything except if I pointed it at a bright object, everything else worked ok. I could take pictures but could barely see them in playback as well.

I took it to Sony authorised repair outlet and was told the CCD was damaged, they charged me USD $55 to repair it (in Quito, Ecuador)

Jul 31, 2008 | HP Photosmart R607 Digital Camera

1 Answer

Blank screen


This sounds like CCD sensor is faulty and should be replaced . Camera works fine in playback mode generally with this problem but not in capture mode ( camera has gone 'blind'). Should be repaired free of charge if the camera is as old as you say.

Aug 16, 2007 | Olympus FE-170 Digital Camera

Not finding what you are looking for?
Sony Cyber-Shot DSC-T3 Digital Camera Logo

Related Topics:

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Cameras Experts

Vish Iyer
Vish Iyer

Level 2 Expert

75 Answers

 Larry
Larry

Level 2 Expert

126 Answers

 MikeWang
MikeWang

Level 2 Expert

42 Answers

Are you a Sony Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...