Performance Teknique ICBM-774 Car Audio Amplifier Logo

Question about Performance Teknique ICBM-774 Car Audio Amplifier

1 Answer

Wiring question I'm piecing togeather a system for Van #3..I have a Performance Teknique ICBM 774 Amp and a Phase Linear ( Jensen )PMP180U CD Deck..I do Not have the manual for the Deck or the Amp..My problem is that the deck has 4 sets of speaker wires ( LF,LR,RF and RR) and 2 RC Style plugs marked Left Rear and Right Rear..Tha Amp has only RC jacks ( 1,2,3 + 4 CH )for input from the Deck...I am running 4 Identical speakers ( 2 front and 2 rear ) and I would like them to all have the same power....Any ideas on how to wire this up and what the amp settings would be ? Thanks......JD

Posted by d-vanman on

Ad

1 Answer

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 6,966 Answers

Hi, If I got the specs right, your amp is a 4 channel hence the 4 RCA inputs. Probably the simplest would be to feed the 2 X RCA out of the deck to the 1 & 2 RCA in of the amp. This amp has also a line out, feed the amp's lineout back to the 3 & 4 in. This way, all four channels get same input from the deck and you will have identical power to all 4 speakers (front & rear). An afterthought is to also use the 4 outputs of the deck (since they are there anyway and it is not a good tech practice to leave outputs without load/speakers) and connect 4 mid-range or 4 smaller speakers. Hope this be of some idea/help. Post back should you need additional information. Good luck and kind regards.

Posted on Sep 02, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Proction light stays on

If it stays on even when the speaker are not connected to it then the amp is fried but f it goes off when the amp is hooked up with no speakers then check the Ohm load on the amp and wire the speakers to match that but don't go below the ohm load on the amp...this site will help.... http://www.crutchfield.com/S-ApB0sVuYqNs/learn/learningcenter/car/subwoofers_wiring.html
0helpful
1answer

Red lightstays on no power how to fix

Sounds like something is shorting out and it is protection mode. Check that the wiring is correct and there are no bad spot on the power wires
0helpful
1answer

How to tune properly

make sure your speakers are wired to the amp with correct ohm load, turn gain, bass boost all the way down on amp, zero out your equilizer on the cd player and turn it all the way down then start raising volume on cd player., when u can start hearing music thru the subwoofers adjust the cd player volume till the sound from your subs is at its peak without any distortion. then start raising the gain on your amp till you are happy with the sound. It gives you the optimal signal strength coming from the cd player and the smoothest sound.
0helpful
1answer

Tengo un performance teknique 774 yse apaga cuando le sibo volimen

Si dos cosas bien importante deves acer primero es la entrade de tierra debe estar en buen metal,segundo que no este interferiendo ningun corto falso.
0helpful
1answer

Performance teknique icbm-896 stick on diagnostics

If it's in protect mode, it probably has shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.
0helpful
1answer

Performance Teknique ICBM-779

You may have a defective speaker or a wiring fault. Disconnect the speaker from the amp and measure the resistance across the speaker wires. The resistance should be near the rated impedance of the speaker.
0helpful
1answer

Performance Teknique ICBM-774

It is almost obvious to me that the New Box is Unvented. If you went from Vented to non-Vented. there you go. The Amps and Subs should be doing the same thing. If your Sony 10's are designed for Vented they will not thump right in a NON-vented box.
0helpful
1answer

Icbm 779

If there is significantly less bass even though the speakers are moving approximately the same as before, you may have one speaker wired out of phase. Disconnect one speaker. If the bass increases, double-check your wiring.
0helpful
1answer

Performance Teknique ICBM-9550 Amp Problem.

one of the power transistor of your unit shorted check use a tester
Not finding what you are looking for?

246 views

Ask a Question

Usually answered in minutes!

Top Performance Teknique Car Audio & Video Experts

Pierre Laplante

Level 3 Expert

2061 Answers

woodzowl307

Level 3 Expert

668 Answers

mark woodring
mark woodring

Level 3 Expert

498 Answers

Are you a Performance Teknique Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...